Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Joined
Oct 4, 2019
Messages
4
Hi,
Thanks for this guide, 99,9% things working.
But i can't see the time remaining in activity monitor for the battery can you help me?
% of battery work.

I have a Hp probook 6470b with original battery and a ivy cpu. Installed os : Sierra
 
Joined
Sep 24, 2012
Messages
244
Motherboard
HP ProBook 4740s (Clover)
CPU
Intel Core i5-3210M CPU @ 2.50GHz/HM76
Graphics
Intel HD Graphics 4000, 1600x900
Mobile Phone
Other
Can I install Catalina according to these instructions?
Or do I need to wait for a RehabMan repository update?
 
Joined
Oct 3, 2013
Messages
26
Motherboard
HP Elitebook 8470p(Clover)
CPU
Intel Core i5 (3rd Gen) 3210M / 2.5 GHz
Graphics
Intel HD Graphics 4000, 1366x768
Mobile Phone
Android
Hi On my Elitebook 8470p, in first time mount rw "sudo mount -uw /"
copy BrcmBluetoothInjector.kext, BrcmPatchRAM2.kext, BrcmFirmwareRepo.kext, BrcmFirmwareData.kext
In /S /L /E
After sudo kextcache -i /

Reboot and all works fine Wireless and BT
:mrgreen::mrgreen:
Hi
I have an hp elitebook 8470p too
Could you lend me your efi folder to do a fresh install please?

Did you follow the guide to do it works? Except the Bluetooth

Thanks
 
Joined
Mar 19, 2013
Messages
62
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
Intel Core i7-4770
Graphics
Intel HD Graphics 4600 1536 MB
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
Hi everyone. I'm pretty familiar with the process for hp elite book 1040 g3, since I have one for several years and thanks to the Guide: https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.261719/ I was able to install and maintain it. I'm considering to buy a HP Elitebook 1040 g4 i7, but in the guide there is not a resource about ACPI for 1040 g4 Kaby Lake. And @RehabMan is not here in since March, so I'm not sure if I would be able to succeed. Any suggestions?
 
Last edited:
Joined
Aug 30, 2016
Messages
46
Motherboard
HP EliteBook 8470p-F.65-Clover
CPU
i5-3320M//HM179b
Graphics
HD 4000, 1600x900
Mac
MacBook Pro
Mobile Phone
iOS
Hi
I have an hp elitebook 8470p too
Could you lend me your efi folder to do a fresh install please?

Did you follow the guide to do it works? Except the Bluetooth

Thanks
I followed exactly the guide for refresh install, Except the Bluetooth,
for bluetooth in first time mount rw "sudo mount -uw /"
copy BrcmBluetoothInjector.kext, BrcmPatchRAM2.kext, BrcmFirmwareRepo.kext,In /System/Library/Extensions
After sudo kextcache -i /

Reboot and all works fine Wireless and BT

I attach the Efi Folder, USE your config.plist in Cover Folder
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
13,234
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I followed exactly the guide for refresh install, Except the Bluetooth,
for bluetooth in first time mount rw "sudo mount -uw /"
copy BrcmBluetoothInjector.kext, BrcmPatchRAM2.kext, BrcmFirmwareRepo.kext,In /System/Library/Extensions
After sudo kextcache -i /

Reboot and all works fine Wireless and BT

I attach the Efi Folder, USE your config.plist in Cover Folder
3rd party kexts belong in /Library/Extensions
 
Joined
Oct 3, 2013
Messages
26
Motherboard
HP Elitebook 8470p(Clover)
CPU
Intel Core i5 (3rd Gen) 3210M / 2.5 GHz
Graphics
Intel HD Graphics 4000, 1366x768
Mobile Phone
Android
I followed exactly the guide for refresh install, Except the Bluetooth,
for bluetooth in first time mount rw "sudo mount -uw /"
copy BrcmBluetoothInjector.kext, BrcmPatchRAM2.kext, BrcmFirmwareRepo.kext,In /System/Library/Extensions
After sudo kextcache -i /

Reboot and all works fine Wireless and BT

I attach the Efi Folder, USE your config.plist in Cover Folder
Thanks bro
 
Last edited:
Joined
Nov 13, 2017
Messages
5
Motherboard
HP 840 G2-Clover
CPU
i5-5300U
Graphics
HD 5500
Mac
Mac mini
Mobile Phone
iOS
Same here, HP EliteBook 840 G4, update from the App Store went OK, only Bluetooth is not working.

Wireless Card: DW1830

I tried to load firmware with this BrcmPatchRam fork (head to releases): headkaze/OS-X-BrcmPatchRAM

What I already tried so far:

load the 3 kexts in /EFI/Clover/kexts/Other -> leads to no bluetooth available

load the 3 kexts in /Library/Extensions [or load them both in /E/C/k/O and /L/E] then fix permissions and rebuild cache then restart -> BT shows and kinda scans devices.. but I cannot connect any device and something new I've noticed is that the physical BT indicator in my laptop flashes when it is scanning or trying to connect to something.

View attachment 429264View attachment 429266

Handoff works...

View attachment 429267

BT firmware fails to load with kexts in /L/E I guess... Firmware Version: v5 c4096

View attachment 429261
How is your fan? I cloned my Mojave SSD and ran the App Store Catalina update. Applied the same fixes as mentioned here for Wi-fi and Bluetooth and all is running fine. Except the fan, which is on all the time. Are you seeing similar?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
13,234
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
How is your fan? I cloned my Mojave SSD and ran the App Store Catalina update. Applied the same fixes as mentioned here for Wi-fi and Bluetooth and all is running fine. Except the fan, which is on all the time. Are you seeing similar?
please read the faq for proper hardware profile setup:
 
Joined
Nov 13, 2017
Messages
5
Motherboard
HP 840 G2-Clover
CPU
i5-5300U
Graphics
HD 5500
Mac
Mac mini
Mobile Phone
iOS
P
please read the faq for proper hardware profile setup:
Profile updated - apologies.
 
Top