Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Joined
Apr 3, 2015
Messages
4
Mac
Classic Mac
Mobile Phone
I updated it like a real Mac, using the Installer from the App Store, even though it took long (quite an hour or so), it works. What doesn't work is Bluetooth. I've already tried many things, but nothing helped and honestly I don't really need it, but you should keep that in mind. The first thing I've noticed was the pretty long boot and shutdown time (3 or 4 times as long as it was under Mojave). The battery seems to be okay, not much better or worse as ist was under Mojave.
I am using the BCM43225HMB (branded by AzureWave)
I've noticed the long boot is due to the old BrcmRamPatch, replace or remove those 3 kexts and boot & shutdown will be normal again.
 
Joined
Jan 29, 2019
Messages
8
Motherboard
Gigabyte H110-S2H
CPU
i5-7500
Graphics
RX 590
Mac
MacBook
Mobile Phone
Android
I've noticed the long boot is due to the old BrcmRamPatch, replace or remove those 3 kexts and boot & shutdown will be normal again.
Well, it worked. Thanks.
But I've noticed something else. After I booted my System, it takes several Minutes till I can connect to or even choose a Wifi. Do you know why it takes that long?
 
Joined
Dec 12, 2012
Messages
15
Motherboard
HP Probook 4440s
CPU
i3
Graphics
HD 4000
Mobile Phone
iOS
I have directly updated my Hp Probook 4440s to Catalina.

Everything working expect Audio.

Anyone can please help me.

kextstat showing below result:

46 1 0xffffff7f83425000 0xdf000 0xdf000 as.vit9696.AppleALC (1.3.3) B60FCBAF-6BC2-36EF-A1E6-D5BE2863C35B <43 13 8 6 5 3 2 1>
 
Joined
Mar 6, 2011
Messages
11
Motherboard
HP Elitebook 840 G5
CPU
i5-8350U
Graphics
UHD 620
Mobile Phone
Android
I updated it like a real Mac, using the Installer from the App Store, even though it took long (quite an hour or so), it works. What doesn't work is Bluetooth. I've already tried many things, but nothing helped and honestly I don't really need it, but you should keep that in mind. The first thing I've noticed was the pretty long boot and shutdown time (3 or 4 times as long as it was under Mojave). The battery seems to be okay, not much better or worse as ist was under Mojave.
I am using the BCM43225HMB (branded by AzureWave)




I can't help you with the Bluetooth problem (it seems that almost everyone has some kind of problem with Bluetooth),
but I may can help you with the sound. In my case, the update changed the injected Audio-ID. What I did :

1. update Apple ALC
2. changing the injected Audio-ID back to the number I used before updating
3. reboot

After that it worked.
Hey, thank you! It worked...
Another update: When I first updated, my wifi was working, but very slow, some minutes to conect...
I think I moved something out of place, and now I don't have wifi, as I don't have bluetooth (DW1560) :(
 
Joined
Dec 12, 2012
Messages
15
Motherboard
HP Probook 4440s
CPU
i3
Graphics
HD 4000
Mobile Phone
iOS
I updated it like a real Mac, using the Installer from the App Store, even though it took long (quite an hour or so), it works. What doesn't work is Bluetooth. I've already tried many things, but nothing helped and honestly I don't really need it, but you should keep that in mind. The first thing I've noticed was the pretty long boot and shutdown time (3 or 4 times as long as it was under Mojave). The battery seems to be okay, not much better or worse as ist was under Mojave.
I am using the BCM43225HMB (branded by AzureWave)




I can't help you with the Bluetooth problem (it seems that almost everyone has some kind of problem with Bluetooth),
but I may can help you with the sound. In my case, the update changed the injected Audio-ID. What I did :

1. update Apple ALC
2. changing the injected Audio-ID back to the number I used before updating
3. reboot

After that it worked.
I did direct update my Hp Probook 4440s but Audio is not working for me. How can i get Audio-ID which was working before.
 
Joined
Aug 30, 2016
Messages
46
Motherboard
HP EliteBook 8470p-F.65-Clover
CPU
i5-3320M//HM179b
Graphics
HD 4000, 1600x900
Mac
MacBook Pro
Mobile Phone
iOS
I have do a refresh install of Catalina on my HP EliteBook 8470p, the bluetooh do not works
 
Joined
Oct 8, 2019
Messages
2
Motherboard
4540s
CPU
i3
Graphics
intel
I did direct update my Hp Probook 4440s but Audio is not working for me. How can i get Audio-ID which was working before.
copy newest AppleALC, Lilu, WhateverGreen kexts to Library/Extensions, than rebuild cache, than reboot. It works on my 4540s.
 
Joined
Dec 12, 2012
Messages
15
Motherboard
HP Probook 4440s
CPU
i3
Graphics
HD 4000
Mobile Phone
iOS
copy newest AppleALC, Lilu, WhateverGreen kexts to Library/Extensions, than rebuild cache, than reboot. It works on my 4540s.
@peti1000 Thanks for your reply. From where i can get the mention kext?
 
Joined
Apr 3, 2015
Messages
4
Mac
Classic Mac
Mobile Phone
Well, it worked. Thanks.
But I've noticed something else. After I booted my System, it takes several Minutes till I can connect to or even choose a Wifi. Do you know why it takes that long?
I had the same issue, I noticed it connected as fast as before when I removed those 3 kexts, rebuild cache & fix permissions then restart.

I forgot to mention that since Catalina now moved macOS main file system to read-only mode you first need to run this command to

Disable Gatekeeper and mount file system in read/write mode:
Code:
sudo spctl --master-disable
sudo mount -uw /
sudo killall Finder
Repair permissions & rebuild kernel cache:
Code:
sudo chown -v -R root:wheel /System/Library/Extensions
sudo touch /System/Library/Extensions
sudo chmod -v -R 755 /Library/Extensions
sudo chown -v -R root:wheel /Library/Extensions
sudo touch /Library/Extensions
sudo kextcache -i /
Alternatively you can use Hackintool which does this among other things: Hackintool read this guide
 
Last edited:
Top