Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Joined
Aug 26, 2014
Messages
51
Motherboard
HP Elitebook 840 G5
CPU
I5-8350U
Graphics
1920x1080 / HD620
Mobile Phone
Android
Anyone get 10.14.5 working on a G5?
I just updated from 10.14.2 to 10.14.5 on an Elitebook G5 and its working fine, sound, trackpad, etc.. I use the i2c branch

Updated clover to the last version before the OSX update.
 
Joined
Apr 7, 2019
Messages
4
Motherboard
HP ProBook 440 G5
CPU
i5-8250U
Graphics
UHD 620, 1366x768
I just updated from 10.14.2 to 10.14.5 on an Elitebook G5 and its working fine, sound, trackpad, etc.. I use the i2c branch

Updated clover to the last version before the OSX update.
I have an EliteBook 830 G5, what ACPI and config plist using? I try with the G5 but the trackpad and sound not working.
 
Joined
Aug 26, 2014
Messages
51
Motherboard
HP Elitebook 840 G5
CPU
I5-8350U
Graphics
1920x1080 / HD620
Mobile Phone
Android
I have an EliteBook 830 G5, what ACPI and config plist using? I try with the G5 but the trackpad and sound not working.
Switch to i2c branch and use elitebook G4 files and you should be fine
 
Joined
Jun 9, 2019
Messages
2
Motherboard
Fujitsu AH532/G32-Clover
CPU
i5-3210M/HM76
Graphics
HD 4000/ GT 640M (1366x768)
Mobile Phone
Android
Hi,

First of all I stumbled across this guide when I was looking for a fix for my audio (ALC269VC) until i tried this method and got it finally fixed with the layout ID=6. Speakers, mic, Headphone and mic jack works like a charm as well.

I have several issues though:
1) BRIGHTNESS: slider is present but there is no change in levels when dragging the slider left or right. Shortcuts aren't responding too (fn6 + fn7, also set them in sysprefs>keyboard>shortcut), I guess I have to follow the keymapping guide by Rehabman?This might just be my hardware because I also tried adjusting it in windows and MX Linux but there is also no change in levels but I don't know for sure so I'm reporting it here anyways.

2)USB ports: USB 3.0 flash drives are recognized in the 2.0 port but when I plug it in the 3.0 port, a notification appears saying "USB accessory needs power". A USB 2.0 flash drive works fine in all ports. My laptop has 3x3.0 and 1x2.0 ports. Also, I also get a notification about my webcam needing power from time to time (FJ Camera).

3)TOUCHPAD: it is not detected in sysprefs>trackpad. I believe it is ALPS after googling. It has a touchpad and left and right click buttons. Double finger gestures are not working in Windows but works in Linux. If there is such a fix for it to be enabled, please tell me.

note:
-my battery is not working so I use the power cord, gonna purchase one soon or 'fix' the dead cells from my dead battery pack
-ethernet is ok, this one's wifi card is unsupported (Intel 2230)
-I read about updating to the sourceforge Clover after the hotpatch so I tried updating the Clover to the official (not RehabMan's) but it gets stuck on boot so I reverted to RehabMan's Clover. I also made sure to copy the original Clover files (ACPI, kexts, driversUEFI64, config.plist) to the new one.
-tried Rehabman's guide for booting macOS but I don't have access to an external keyboard so I used multibeast then installed Rehabman's clover after installation

I'm afraid I might mess something up if I follow other guides since I think it will affect the settings installed by this guide so I'm consulting the experts.

Thanks!
 

Attachments

Last edited:
Joined
Dec 11, 2011
Messages
160
Motherboard
HP ProBook 4440s-Clover
CPU
i5-3360M
Graphics
HD 4000, 1366x768
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
Hi,

First of all I stumbled across this guide when I was looking for a fix for my audio (ALC269VC) until i tried this method and got it finally fixed with the layout ID=6. Speakers, mic, Headphone and mic jack works like a charm as well.

I have several issues though:
1) BRIGHTNESS: slider is present but there is no change in levels when dragging the slider left or right. Shortcuts aren't responding too (fn6 + fn7, also set them in sysprefs>keyboard>shortcut), I guess I have to follow the keymapping guide by Rehabman?This might just be my hardware because I also tried adjusting it in windows and MX Linux but there is also no change in levels but I don't know for sure so I'm reporting it here anyways.

2)USB ports: USB 3.0 flash drives are recognized in the 2.0 port but when I plug it in the 3.0 port, a notification appears saying "USB accessory needs power". A USB 2.0 flash drive works fine in all ports. My laptop has 3x3.0 and 1x2.0 ports. Also, I also get a notification about my webcam needing power from time to time (FJ Camera).

3)TOUCHPAD: it is not detected in sysprefs>trackpad. I believe it is ALPS after googling. It has a touchpad and left and right click buttons. Double finger gestures are not working in Windows but works in Linux. If there is such a fix for it to be enabled, please tell me.

note:
-my battery is not working so I use the power cord, gonna purchase one soon or 'fix' the dead cells from my dead battery pack
-ethernet is ok, this one's wifi card is unsupported (Intel 2230)
-I read about updating to the sourceforge Clover after the hotpatch so I tried updating the Clover to the official (not RehabMan's) but it gets stuck on boot so I reverted to RehabMan's Clover. I also made sure to copy the original Clover files (ACPI, kexts, driversUEFI64, config.plist) to the new one.
-tried Rehabman's guide for booting macOS but I don't have access to an external keyboard so I used multibeast then installed Rehabman's clover after installation

I'm afraid I might mess something up if I follow other guides since I think it will affect the settings installed by this guide so I'm consulting the experts.

Thanks!
If you are using a ProBook guide for a Fujitsu laptop, you are clearly doing everything wrong. The ACPI patching provided by this guide is for the ProBook series of laptops by Hewlett Packard, and ONLY ProBook laptops. Any other use can cause damage to the internal components of the laptop if the incorrect settings are applied. Please consult Post #1 for supported laptops before trying specific patch jobs to fix certain components. And also browse through the guide forum for your specific laptop and run through that guide first.

If you did use another guide and are using this guide's audio patching as a patchwork fix, then please consult that thread and post relevant problem reporting files there, as posting it here is off topic to this thread.
 
Joined
Jun 9, 2019
Messages
2
Motherboard
Fujitsu AH532/G32-Clover
CPU
i5-3210M/HM76
Graphics
HD 4000/ GT 640M (1366x768)
Mobile Phone
Android
Thanks Krazy-Killa, but I thought I read somewhere to try some guides closest/similar to your hardware but apparently I was wrong to assume.
If you are using a ProBook guide for a Fujitsu laptop, you are clearly doing everything wrong. The ACPI patching provided by this guide is for the ProBook series of laptops by Hewlett Packard, and ONLY ProBook laptops.
I have only seen posts planning to buy the same model (dated 2013), no specific guides. Can another clean install revert back the changes? The USB ports were working 'pre-hotpatch'.
If you did use another guide and are using this guide's audio patching as a patchwork fix, then please consult that thread and post relevant problem reporting files there, as posting it here is off topic to this thread.
I used other guides but it simply didn't work. And yes I have tried all the available layout ids (around 18 of them) for a set of configuration. This guide fixed my audio but after injecting layout-id 6.
 
Joined
Aug 26, 2014
Messages
51
Motherboard
HP Elitebook 840 G5
CPU
I5-8350U
Graphics
1920x1080 / HD620
Mobile Phone
Android
Thanks, I change the branch and use the G4 files but the trackpad is not working at all.
Mine is a 840 G5, not 830. Earlier in this thread I have posted PR files that you may take a look. The trackpad works, the cursor is a little jumpy sometimes, but overall its fine.
Did you get sound working?
 
Top