Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Ok, here is the debug zip.
to elaborate a bit more in the issue, i get some horizontal lines while watching videos, this only occurs in the video picture, not in any other part of the screen. Problem happens after using laptop for a while 2+ hours. Since the fresh install (3 days ago)I have also gotten two system freezes, i cant move the mouse arrow around but it doesnt respond to clicks(this has appears to have resolved after EC reset). Today watching video laptop fan went crazy with around 40% battery left, 5 minutes later battery drained down to 6%. I followed your guide very closely and while long, is a straight forward process, great write up. In the post above, when i asked for the EFI file, i was just been lazy :D
Thank you for your time and help.
Note: i had the i5-2520M on the laptop and it was having the same issue.
As per guide, try OsxAptioFixDrv-64.efi instead of AptioMemoryFix-64.efi.
 
Joined
Jul 3, 2013
Messages
208
Motherboard
HP EliteBook 8460P-CLover
CPU
i7-2670QM
Graphics
HD 3000 1366 x 768
Mac
MacBook Pro
Mobile Phone
iOS
As per guide, try OsxAptioFixDrv-64.efi instead of AptioMemoryFix-64.efi.
Will do when I get home
EDIT: Still doing the same horizontal lines after changing to OsxAptioFixDrv-64, it get worst as the CPU load/temperature increases.
I guess i will live with it since i just use this laptop to do web browsing and to stream video.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Will do when I get home
EDIT: Still doing the same horizontal lines after changing to OsxAptioFixDrv-64, it get worst as the CPU load/temperature increases.
I guess i will live with it since i just use this laptop to do web browsing and to stream video.
Any change requires new PR files.
None attached.
 
Joined
Jul 3, 2013
Messages
208
Motherboard
HP EliteBook 8460P-CLover
CPU
i7-2670QM
Graphics
HD 3000 1366 x 768
Mac
MacBook Pro
Mobile Phone
iOS
Any change requires new PR files.
None attached.
@RehabMan here is new PR files attached.
Battery also once again drained from 30ish percent down to 7%. This battery drain issues never happened under windows 10 same laptop. I will contact vendor to get another one, just to make 100% is not a defective brand new battery.
Also, I just installed the wifi card recommended in the guide, it got connected a few minutes out of the box, but then it disconnected, cannot turn it back on. I recreated dsdt files, put a brand new config.plist, nothing, not working (it work under windows 10)
New PR attached with all new changes.
Edit: this morning turned on laptop, WiFi was working o_O
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
@RehabMan here is new PR files attached.
Battery also once again drained from 30ish percent down to 7%. This battery drain issues never happened under windows 10 same laptop. I will contact vendor to get another one, just to make 100% is not a defective brand new battery.
Also, I just installed the wifi card recommended in the guide, it got connected a few minutes out of the box, but then it disconnected, cannot turn it back on. I recreated dsdt files, put a brand new config.plist, nothing, not working (it work under windows 10)
New PR attached with all new changes.
Edit: this morning turned on laptop, WiFi was working o_O
Your CPU PM configuration is wrong.
Read main laptop guide regarding proper enabling of "alternate DropTables".
 
Joined
Sep 19, 2012
Messages
713
CPU
i3
Update - solved - intel kext file missing from clover other folder

Ethernet not working

After a clean fresh install 10.13.6, can boot up and login, stuck at Ethernet. Can’t proceed to download rehabmans scripts etc.

About this Mac / system report

Hardware - intel card not showing

Network - active services - Ethernet en0

Anyone had same issue? Solved?

No internet access, no pr files.
 
Last edited:
Joined
Sep 19, 2012
Messages
713
CPU
i3
UEFI without CSM - BIOS setting and Elitebook G1 HP,

anyone else have a uefi without csm boot working?

I have tested a fresh install and booting up with this setting is a hit and miss, and when it does hit, the clover boot manager screen is at different resolutions, pressing f9 and esc and arrow keys appears to switch the screen resolution, but not 100% working.

tried another uefi boot solution - customised boot path to point to efi\clover\cloverx64.efi , and this also didn't work.

uefi with csm - bios, clover boots as normal, but the clover screen resolution isn't always right, is there a way for clover to choose the right screen resolution for the screen size?

thanks in advance.

@RehabMan big thanks I appreciate and am grateful for the post install script you've worked on. very different to pbi, just as good. keep up the good work. cheers

From research on the hp g1 elitebook bios uefi without csm I read:

"the problem is that HP hard coded the paths for the OS boot manager in their UEFI boot manager to \EFI\Microsoft\Boot\bootmgfw.efi to boot Microsoft Windows, regardless of how the UEFI NVRAM variables are changed."


Even if UEFI, Arch Linux and (e.g.) GRUB are correctly configured and with the correct UEFI NVRAM variables set, the system will not boot from the HDD/SSD. The problem is that HP hard coded the paths for the OS boot manager in their UEFI boot manager to \EFI\Microsoft\Boot\bootmgfw.efi to boot Microsoft Windows, regardless of how the UEFI NVRAM variables are changed. There are two workarounds:

The latest HP firmware allows defining a “Customized Boot” path in the UEFI pre-boot graphical environment. Select the “Customized Boot” option in the UEFI pre-boot graphical environment under “Boot Options” and set the path to your OS boot loader on the ESP (see UEFI#EFI System Partition[broken link: invalid section]), e.g.:
\EFI\grub\grubx64.efi
Always verify the correct path to the .efi file. Also, adjust the device boot order (also in the UEFI pre-boot graphical environment) to boot this entry first.




CLOVER update?.. the version I installed from rehabmans build, tells me there is a update available, is it ok to update or wait for rehabman to update clover?
 
Last edited:
Joined
Jul 28, 2012
Messages
12
Motherboard
HP ProBook 450 G4
CPU
i7-7700U
Graphics
HD 620
Mac
MacBook Pro
Mobile Phone
Android
Good day and thank you for the great guide. I have managed to install Mojave on my Hackintosh (Probook 450 G4) and I am in search of the compatible wifi card. All seems to working fine, except sound and I have tried almost any trick. VoodooHDA enabled sound, but with a lot of hiccups now and then, so I decided to remove it and try AppleHDA patcher.
Please check my attached report and see if you can assist.

Thank you,

I got the audio working by correctly following the guide. Just a heads up to everyone, you have to do everything step by step and all will be good. Here in South Africa seems like it's a mission to obtain the compatible wifi cards, as that's the only thing standing between me and my perfect Hackintosh ;-)
 

Attachments

Last edited:
Joined
Sep 19, 2012
Messages
713
CPU
i3
Show Launchpad Modifier key not working - left ALT. how to fix it? thanks

in sys prefs/shortcuts pressing the left ALT key doesn't show.

but it works in general for other tasks like minize windows Left ALT+m
 

Top