Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Status
Not open for further replies.
Joined
Jul 28, 2016
Messages
121
Motherboard
ASRock B365M Pro4
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
  1. Android
Nice to hear you have determine the source of the problem.

Goes to show: Must test your assumptions regarding hardware function on Windows before assuming there is some software problem!


Another question:

Should I bother patch my DSDT ? Your native DSDT have F60 BIOS version and I have F67.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Another question:

Should I bother patch my DSDT ? Your native DSDT have F60 BIOS version and I have F67.

This guide uses hotpatch for all ACPI patching, not static patch.
 
Joined
Jul 28, 2016
Messages
121
Motherboard
ASRock B365M Pro4
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
  1. Android
This guide uses hotpatch for all ACPI patching, not static patch.
So there is no need. Thanks ! In the meantime I will try search the forums maybe I can find some patch regarding the handoff problem.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
So there is no need. Thanks ! In the meantime I will try search the forums maybe I can find some patch regarding the handoff problem.

There are rumors that handoff is better behaved on hacks in Mojave. I have not really tested it (I think it is a gimmick anyway).
 
Joined
Jul 28, 2016
Messages
121
Motherboard
ASRock B365M Pro4
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
  1. Android
There are rumors that handoff is better behaved on hacks in Mojave. I have not really tested it (I think it is a gimmick anyway).

Yeah, the solution was simple enough: logout from iCloud on my iPad and log back in.

I have Mojave.

I almost never use my iPad because is slow as hell but I like testing new things. I didn't feel the need of this on my Android phone just sometimes on SMS but that's it.
 
Joined
Jul 28, 2016
Messages
121
Motherboard
ASRock B365M Pro4
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
  1. Android
New branch: beta_weg

Everything works just fine ! WhaterverGreen loads just fine and everything seems okay. Just reporting in case if you need feedback.

If you need debug files they are attached
 

Attachments

  • debug_30888.zip
    1.9 MB · Views: 47
Joined
Dec 5, 2016
Messages
4
Motherboard
HP Zbook 15 G2
CPU
i7-4810MQ//QM87
Graphics
Quadro K1100M+ HD 4600
Hi Rehman!
My laptop HP zbook 15 G2 / 15GHz Core i7-4810MQ / Quadro K1100M + 4600hd / ALC280
I installed hotpatch for high-sierra 10.13.6 on my laptop. But when I was running the command line "./install_downloads.sh" to install kext L / E. after installing some kexts, the laptop is panic then restart immediately. ,The laptop couldn't boot up anymore.
I do not know how to delete the kexts in L / E from the windown, so I backed up with time machine and installed OSX EL Capitan 10.11.6. Now I have 3 OS: windown 10, high-sierra and EL.And when I run the command line on EL, the result stays the same. I try to run the command line then the result is not build .aml(picture)
Can you give me a solution?
If manual build, how to do with .asl files?
kien_build.png
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
New branch: beta_weg

Everything works just fine ! WhaterverGreen loads just fine and everything seems okay. Just reporting in case if you need feedback.

If you need debug files they are attached

Your ACPI files are not up-to-date with respect to the github project.
Maybe you forgot to use install_acpi.sh.

Your config.plist is also not from the beta_weg branch.
Seems you forgot to follow the instructions in the guide "Final config.plist".

Your kextcache output looks as expected.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi Rehman!
My laptop HP zbook 15 G2 / 15GHz Core i7-4810MQ / Quadro K1100M + 4600hd / ALC280
I installed hotpatch for high-sierra 10.13.6 on my laptop. But when I was running the command line "./install_downloads.sh" to install kext L / E. after installing some kexts, the laptop is panic then restart immediately. ,The laptop couldn't boot up anymore.
I do not know how to delete the kexts in L / E from the windown, so I backed up with time machine and installed OSX EL Capitan 10.11.6. Now I have 3 OS: windown 10, high-sierra and EL.And when I run the command line on EL, the result stays the same. I try to run the command line then the result is not build .aml(picture)
Can you give me a solution?
If manual build, how to do with .asl files?
kien_build.png

What is the output in Terminal?
Code:
iasl -v
which iasl

And please attach your entire probook.git as ZIP.
 
Status
Not open for further replies.
Top