Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Status
Not open for further replies.
Joined
Jul 28, 2016
Messages
123
Motherboard
ASRock B365M Pro4
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
  1. Android
Bad idea to run down that low.
Plug it in before the battery fails to power the laptop.
Unlike a real Mac, laptop hacks have hibernation disabled, which prevents auto-hibernate in low battery situations.



I will compare my result here...
But I think your major mistake is the (unreasonable) expectation that the laptop is going to auto-hibernate in low battery...


My expectation was to not shutdown at 10 % maybe at 4-5 % but it never reaches that point. I will monitor the battery % and see other things. I will plug it in at around 20 % and see if I get any jumps in battery %.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
My expectation was to not shutdown at 10 % maybe at 4-5 % but it never reaches that point.

10% is close enough that it may shutdown quite soon, depending on what you're doing/devices plugged in/etc.
 
Joined
Jul 28, 2016
Messages
123
Motherboard
ASRock B365M Pro4
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
  1. Android
10% is close enough that it may shutdown quite soon, depending on what you're doing/devices plugged in/etc.

Okay, thanks for the clarification !
 
Joined
May 2, 2013
Messages
72
Motherboard
HP ProBook 4540s- F.60-Clover
CPU
i3-3110M
Graphics
HD4000, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
You didn't install the latest 'beta' ACPI files with beta copy of github project, beta copy of install_acpi.sh.
This can be done by switch to beta branch. Right? If so I'm doing the exact thing.
When I try to install acpi.sh the following error shows:

"Rizis-MacBook-Pro:probook.git rizi$ ./install_acpi.sh install_4x40s

Error: Unknown model, "install_4x40s", specified." (Please see terminal command text output)

So I manually copy/paste using finder but nothing changed. Is there anything I'm missing?
 

Attachments

  • Terminal Saved Output.zip
    2.7 KB · Views: 51

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
"Rizis-MacBook-Pro:probook.git rizi$ ./install_acpi.sh install_4x40s

install_4x40s is not valid.

Note:
Code:
NUC6i7KYK:probook.git rehabman$ ./install_acpi.sh help |grep 4x40
install_4x40
install_4x40_hires
 
Joined
May 2, 2013
Messages
72
Motherboard
HP ProBook 4540s- F.60-Clover
CPU
i3-3110M
Graphics
HD4000, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
install_4x40s is not valid.

Note:
Code:
NUC6i7KYK:probook.git rehabman$ ./install_acpi.sh help |grep 4x40
install_4x40
install_4x40_hires
RehabMan... Still not working.... :((((
 

Attachments

  • Archive.zip
    5.3 MB · Views: 34

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Now, it shutted down around 10 %, didn't turn on blinking light, plugged AC in, booted to macOS showed 0 % unplugged the AC jumps to 20 %.

1. Fully charge the ProBook
2. Go to System Information and take a look at the Full Charge capacity. Note the value
3. Unplug the AC, refresh via Command + R, take a look again at Full Charge capacity and it changes. (First thing)

Not reproducible here. My full charge capacity is 4013 and remains the same after AC unplug.

4. Let it die until it turns off (note the battery % at which it turns off)
5. Now, you can't turn it on because of the dead battery.
6. Plug the AC in, turn on the ProBook, and now the battery shows 0 %

That would all be expected.

7. Unplug the AC and now the battery % should be more, like 15-20 % and also, the Full Charge capacity should be different in System information.

Did you install to APFS or HFS+J?

Note: Currently letting my 4540s run down the battery. Will try to note any stuck battery state. So far working fine (is currently at 99%, down from 100% a few minutes after unplugging).
 
Joined
Jun 26, 2015
Messages
9
Motherboard
HP Probook 450 G3
CPU
Intel core i5-6200U(2.2GHz)
Graphics
Intel HD520, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
NGFF/M.2 WiFi slot BCM94352Z: Tested, it's working well for me.
 
Joined
May 2, 2013
Messages
72
Motherboard
HP ProBook 4540s- F.60-Clover
CPU
i3-3110M
Graphics
HD4000, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

But for sure I see a problem... you forgot to update config.plist. Read post #1, "Final config.plist"
Yes, indeed it is working now. Thank you very much RehabMan. I was using 4x40s.config before. Thank you very much for your help.
Any advise for future update?
 
Status
Not open for further replies.
Top