Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,207
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Ahh okay that's why the scripts weren't working. I have no idea what issues went on during the install process, but once I was able to finally get it to boot in safe mode and install from your repo everything worked great as usual.

I didn't even realize you could hide the recovery partition, whoops!

I believe I was trying OsxAptioFix*.efi+EmuVariableUefi-64.efi since I was having issues and trying to see what would let me boot, but I will switch back to the recommended and give it a shot.

Thanks again
You should install "RC scripts" in any case, but if you use EmuVariableUefi-64.efi, the "RC scripts" are actually required to get NVRAM working.
 
Joined
Sep 20, 2017
Messages
15
Motherboard
HP EliteBook 840 G1 (Clover)
CPU
i5-4300u
Graphics
HD4400, 1600x900
Mac
iMac
You should install "RC scripts" in any case, but if you use EmuVariableUefi-64.efi, the "RC scripts" are actually required to get NVRAM working.

I've swapped to AptioMemoryFix.efi and removed OsxAptioFix*.efi, I did not see EmuVariableUefi-64.efi. I believe the rc.d scripts were already there when I looked, are these the proper ones?


/private/etc/rc.shutdown.d/80.save_nvram_plist.local

/private/etc/rc.boot.d/10.save_and_rotate_boot_log.local
/private/etc/rc.boot.d/20.mount_ESP.local
/private/etc/rc.boot.d/70.disable_sleep_proxy_client.local

/private/etc/rc.clover.lib


Thanks
 
Joined
May 2, 2013
Messages
71
Motherboard
HP ProBook 4540s- F.60-Clover
CPU
i3-3110M
Graphics
HD4000, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
Sorry for the late replying RehabMan! Busy at work these days. Please find attached files for your kind review again. Kext loaded but audio still not active. Also, please have a look screenshot. Thanks
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,207
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I've swapped to AptioMemoryFix.efi and removed OsxAptioFix*.efi, I did not see EmuVariableUefi-64.efi.
Any change requires updated PR files.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,207
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Sorry for the late replying RehabMan! Busy at work these days. Please find attached files for your kind review again. Kext loaded but audio still not active. Also, please have a look screenshot. Thanks
You didn't install the latest 'beta' ACPI files with beta copy of github project, beta copy of install_acpi.sh.
 
Joined
Sep 20, 2017
Messages
15
Motherboard
HP EliteBook 840 G1 (Clover)
CPU
i5-4300u
Graphics
HD4400, 1600x900
Mac
iMac
Any change requires updated PR files.
Sorry, I'm not sure I follow what you're saying here. Are you saying I should replace the rc scripts with the new ones even if they were already there? Or is this relating to the .efi files? Thanks
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,207
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Sorry, I'm not sure I follow what you're saying here. Are you saying I should replace the rc scripts with the new ones even if they were already there? Or is this relating to the .efi files? Thanks
Any change you make you must upload new PR files.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Sep 20, 2017
Messages
15
Motherboard
HP EliteBook 840 G1 (Clover)
CPU
i5-4300u
Graphics
HD4400, 1600x900
Mac
iMac
I've swapped to AptioMemoryFix.efi and removed OsxAptioFix*.efi, I did not see EmuVariableUefi-64.efi. I believe the rc.d scripts were already there when I looked, are these the proper ones?


/private/etc/rc.shutdown.d/80.save_nvram_plist.local

/private/etc/rc.boot.d/10.save_and_rotate_boot_log.local
/private/etc/rc.boot.d/20.mount_ESP.local
/private/etc/rc.boot.d/70.disable_sleep_proxy_client.local

/private/etc/rc.clover.lib


Thanks
Any change you make you must upload new PR files.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

Ahh okay. Attached. Thanks
 

Attachments

Joined
Sep 20, 2017
Messages
15
Motherboard
HP EliteBook 840 G1 (Clover)
CPU
i5-4300u
Graphics
HD4400, 1600x900
Mac
iMac
But what is the current issue/problem/bug?
Everything's working fine. You had told me to add new PR files after my post quoted below:

I've swapped to AptioMemoryFix.efi and removed OsxAptioFix*.efi, I did not see EmuVariableUefi-64.efi. I believe the rc.d scripts were already there when I looked, are these the proper ones?


/private/etc/rc.shutdown.d/80.save_nvram_plist.local

/private/etc/rc.boot.d/10.save_and_rotate_boot_log.local
/private/etc/rc.boot.d/20.mount_ESP.local
/private/etc/rc.boot.d/70.disable_sleep_proxy_client.local

/private/etc/rc.clover.lib


Thanks

Thanks
 
Top