Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
the device specific ssdt compiles well without errors, so I could try that, but it seems worse thaN before: after changing changing that IGPI from "Zero" to "0x591b0000" the external monitor connected via HDMI doesn't work at all anymore, turns black (standby).
No ideas for you without PR files.

Can you help me out maybe about this, I am having a hard time interpreting the kernel log. what should I be looking for? what could be the reason for the driver failing to identify the trackpad as synaptics? can this be associated to some NVME-installation (timing) problems?
Look for logs related to the PS2 kexts.
I'm guessing that findMouseDevice is failing.
More data in logs if you install the debug VoodooPS2Controller.kext...

This slight addition of IOSleep in findMouseDevice (in AppleACPIPS2Nub.cpp) might help:
Code:
IOService *AppleACPIPS2Nub::findMouseDevice()
{
    OSObject *prop = getProperty("MouseNameMatch");
    /* Slight delay to allow PS2 mouse entry in IOACPIPlane to populate */
    IOSleep(500);
    /* Search from the root of the ACPI plane for the mouse PNP nub */
    IORegistryIterator *i = IORegistryIterator::iterateOver(gIOACPIPlane, kIORegistryIterateRecursively);
    IORegistryEntry *entry;
    if(i != NULL)
    {
        while((entry = i->getNextObject()))
        {
            if(entry->compareNames(prop))
                break;
        }
        i->release();
    }
    else
        entry = NULL;
    return OSDynamicCast(IOService, entry);
}
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank for @
RehabMan
I installed successfully with your guide
But I have two problem
- No Audio
- very lag about 20s when laptop log in
Help me!
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

And why did you attach an image of the HDA patcher script?
This guide does not use the HDA patcher.
 
Joined
Dec 2, 2014
Messages
16
Motherboard
HP ProBook 450 G3
CPU
Intel Core i5-6200U
Graphics
HD520 & Radeon R7 M340, 1366x768
Mobile Phone
Android, iOS
Make sure you have the latest BIOS installed (and correct BIOS options).
Hello RehabMan,
I re-try to run commands in "Post Installation" and currently don't see the warning of BIOS anymore (warning that the CMOS is reset and the option to choose default setting...). I think its OK now and don't care about the reason why this warning gones. :D

However, sometimes, the boot process is very slow (compare to some very fast ones). I already check that the TRIM patch is disabled in the config.plist as in the guide. For more details, these are my laptop settings:
- triple boot: Windows 10 (Intel SSD in Caddy-bay), Ubuntu (HHD), and Mac OSX High Sierra 10.13.3 (Samsung EVO M2)
- the Clover EFI ZIP is attached with this message.

And, please suggest me the process to update my hackintosh from 10.13.3 to 10.13.4?

Thank you for your help.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello RehabMan,
I re-try to run commands in "Post Installation" and currently don't see the warning of BIOS anymore (warning that the CMOS is reset and the option to choose default setting...). I think its OK now and don't care about the reason why this warning gones. :D

However, sometimes, the boot process is very slow (compare to some very fast ones). I already check that the TRIM patch is disabled in the config.plist as in the guide. For more details, these are my laptop settings:
- triple boot: Windows 10 (Intel SSD in Caddy-bay), Ubuntu (HHD), and Mac OSX High Sierra 10.13.3 (Samsung EVO M2)
- the Clover EFI ZIP is attached with this message.

And, please suggest me the process to update my hackintosh from 10.13.3 to 10.13.4?

Thank you for your help.
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Dec 2, 2014
Messages
16
Motherboard
HP ProBook 450 G3
CPU
Intel Core i5-6200U
Graphics
HD520 & Radeon R7 M340, 1366x768
Mobile Phone
Android, iOS
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
Yeah, these are my dump files, which generated by gen_debug.sh.

P.S: In the last 3 boots for generating debug files (I forgot press F2, F4 in the Clover boot screen), the boot process is very fast. I hope the later boots will quick like those.

Thank you for your help and patience!
 

Attachments

Joined
Sep 2, 2017
Messages
4
Motherboard
HP Probook G4 450
CPU
i5-7200U
Graphics
HD 620
Mac
iMac
Mobile Phone
Android, iOS
Everything OK, up and running.

  • I bought the ProBook 450 G4 (15.60", Full HD, Intel Core i5-7200U, 8GB, HDD)
  • Upgrade with a Samsung[/B] 850 EVO (250GB, M.2 2280)
  • Replaced the Wifi card with Tarjeta de Red Inalámbrica WiFi BCM94352Z NGFF M.2 Wifi Bluetooth 4.0 06 XRYC DW1560 802.11AC Wifi 867 Mbps
In addition to following the fantastic Rehabman guide I have installed a triple boot, Windows 10 + Ubuntu + MacOS HighSierra
I had some intial problems, but all due to not following EXACTLY the guide.

The only caution in my case is to repeat these lines everytime there I perform an update.
cd ~/Projects/probook.git
./download.sh
./install_downloads.sh
The trackpad is not super-sentitive, but just works, the rest is perfect.

Thanks RehabMan for this fantastic guide.
 
Joined
Jul 28, 2017
Messages
5
Motherboard
HP Elitebook 840 G1
CPU
Intel Core i5-4300u
Graphics
Intel HD4400, 1600x900
One of my kids tried to update itunes on my hackintosh and now I'm getting a kernel panic. Everything was working smoothly beforehand. Pics of what comes up in verbose mode attached (scroll through in gallery).

Any suggestions on what happened/how to fix? Thanks
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Yeah, these are my dump files, which generated by gen_debug.sh.

P.S: In the last 3 boots for generating debug files (I forgot press F2, F4 in the Clover boot screen), the boot process is very fast. I hope the later boots will quick like those.

Thank you for your help and patience!
This configuration looks mostly fine, but you should have installed on HFS+J, not APFS.

but...
USB WiFi not recommended. Remove and install recommended WiFI hardware as per post #1.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
The only caution in my case is to repeat these lines everytime there I perform an update.
Procedures required for system updates are covered in post #1...
 
Top