[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch (10.11)

Discussion in 'El Capitan Laptop Guides' started by RehabMan, Mar 29, 2016.

  1. gaoqi7

    gaoqi7

    Joined:
    Dec 1, 2016
    Messages:
    12
    Motherboard:
    HP Elitebook 840 G1 (Clover)
    CPU:
    Intel Core i5 (4th Gen) 4200U / 1.6 GHz
    Graphics:
    HD 4400,1920x1080
    Mobile Phone:
    iOS
    Feb 14, 2018 at 8:44 PM #7681
    gaoqi7

    gaoqi7

    Joined:
    Dec 1, 2016
    Messages:
    12
    Motherboard:
    HP Elitebook 840 G1 (Clover)
    CPU:
    Intel Core i5 (4th Gen) 4200U / 1.6 GHz
    Graphics:
    HD 4400,1920x1080
    Mobile Phone:
    iOS
    Hi Rehabman,

    My situation:
    Laptop connect on dock. External screen attached on dock by DP port. MacOS version is 10.12.6

    Problem:
    With the laptop lid closed.
    1)System's automatic sleep always turn to shut down. if I use Apple->Sleep, it works very well.
    2)System can't turn on. it boots loop. While with the laptop lid open, system turn on without any problem.

    The problem that listed above didn't appear when I use Yosemite.
    Thanks for your effort to add dock support.
     
  2. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    179,791
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Feb 14, 2018 at 9:31 PM #7682
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    179,791
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS

    No "Problem Reporting" files attached.
    Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
    https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
    Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
     
  3. gaoqi7

    gaoqi7

    Joined:
    Dec 1, 2016
    Messages:
    12
    Motherboard:
    HP Elitebook 840 G1 (Clover)
    CPU:
    Intel Core i5 (4th Gen) 4200U / 1.6 GHz
    Graphics:
    HD 4400,1920x1080
    Mobile Phone:
    iOS
    Feb 14, 2018 at 10:44 PM #7683
    gaoqi7

    gaoqi7

    Joined:
    Dec 1, 2016
    Messages:
    12
    Motherboard:
    HP Elitebook 840 G1 (Clover)
    CPU:
    Intel Core i5 (4th Gen) 4200U / 1.6 GHz
    Graphics:
    HD 4400,1920x1080
    Mobile Phone:
    iOS

    Attached Files:

  4. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    179,791
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Feb 14, 2018 at 10:48 PM #7684
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    179,791
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    You might try this patch:
    Comment: 0105 port as DP, 0x04260000
    Find: 01 05 09 00 04 00 00 00 04 00 00 00
    Replace: 01 05 09 00 00 04 00 00 04 00 00 00
    Name: com.apple.driver.AppleIntelFramebufferAzul
     
  5. gaoqi7

    gaoqi7

    Joined:
    Dec 1, 2016
    Messages:
    12
    Motherboard:
    HP Elitebook 840 G1 (Clover)
    CPU:
    Intel Core i5 (4th Gen) 4200U / 1.6 GHz
    Graphics:
    HD 4400,1920x1080
    Mobile Phone:
    iOS
    Feb 15, 2018 at 12:23 AM #7685
    gaoqi7

    gaoqi7

    Joined:
    Dec 1, 2016
    Messages:
    12
    Motherboard:
    HP Elitebook 840 G1 (Clover)
    CPU:
    Intel Core i5 (4th Gen) 4200U / 1.6 GHz
    Graphics:
    HD 4400,1920x1080
    Mobile Phone:
    iOS
    Hi , after using the patch, with the lid closed, automatic sleep work. for the boot loop issue, not lucky. But it is fine. I don't turn down often.
     

    Attached Files:

    Last edited: Feb 15, 2018
  6. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    179,791
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Feb 15, 2018 at 12:30 AM #7686
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    179,791
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    The patch is doing what I expected: changed connector-type to DP <00 04 00 00> for framebuffer@1, it was eDP <04 00 00 00>.

    Try patching to eliminate the 0204 connector (I'm assuming it isn't used)...
    Comment: 0204 port as NULL, 0x04260000
    Find: 02 04 09 00 00 08 00 00 82 00 00 00
    Replace: FF 00 00 00 01 00 00 00 40 00 00 00
    Name: com.apple.driver.AppleIntelFramebufferAzul

    Otherwise, you might try other ig-platform-id values... for example, we used to use 0xa260006 but changed to 0x04260000 as some users reported problems. You can see how the ig-platform-id (IGPI) and PWMMax values (LMAX) are overridden in your model specific SSDT.

    Also, you should check that DVMT-prealloc is set correctly in BIOS. 0x04260000 requires 64mb whereas 0xa260006 requires only 32mb.
     
  7. kocurr

    kocurr

    Joined:
    Sep 5, 2017
    Messages:
    10
    Motherboard:
    HP 840 G3
    CPU:
    i7-6600U
    Graphics:
    Intel HD 520
    Mar 1, 2018 at 10:04 PM #7687
    kocurr

    kocurr

    Joined:
    Sep 5, 2017
    Messages:
    10
    Motherboard:
    HP 840 G3
    CPU:
    i7-6600U
    Graphics:
    Intel HD 520
    Guys. Please help - after OSX update I have kernel panic. What I can do to make my hp work again?
     

    Attached Files:

    • IMG_20180301_230053.jpg  (4.2 MB, 37 views)
  8. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    179,791
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Mar 3, 2018 at 1:22 AM #7688
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    179,791
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    You need to update Lilu.kext.
    As per guide, "System updates", it is something you should have done *prior* to the update.
     
  9. fransyozef

    fransyozef

    Joined:
    May 13, 2017
    Messages:
    57
    CPU:
    i7-6600U
    Graphics:
    Intel HD Graphics 520
    Mac:
    MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Mar 3, 2018 at 10:15 AM #7689
    fransyozef

    fransyozef

    Joined:
    May 13, 2017
    Messages:
    57
    CPU:
    i7-6600U
    Graphics:
    Intel HD Graphics 520
    Mac:
    MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Yay .. after a very long time, I managed to get a hold on the Broadcom Wifi module for my HP 840 G3 hackintosh .. and it's working like a charm!!! Now I will try to install Sierra High :) ... thanx for all the tips
     
  10. videokuenstler

    videokuenstler

    Joined:
    Jul 2, 2015
    Messages:
    4
    Motherboard:
    HP ZBook Studio G3 Mobile Workstation (Clover)
    CPU:
    Intel Skylake i7-6700HQ / Mobile Intel CM236 Express
    Graphics:
    NVIDIA Quadro M1000M 4K-UHD-display
    Mar 6, 2018 at 6:18 PM #7690
    videokuenstler

    videokuenstler

    Joined:
    Jul 2, 2015
    Messages:
    4
    Motherboard:
    HP ZBook Studio G3 Mobile Workstation (Clover)
    CPU:
    Intel Skylake i7-6700HQ / Mobile Intel CM236 Express
    Graphics:
    NVIDIA Quadro M1000M 4K-UHD-display
    i tried with the probook.git script and the 'SSDT-ZBook-G3-Skylake' settings, different bios settings with and without hybrid-graphics (finaly i would need discrete graphics), different smbios and with el cap, sierra and high sierra. unfortunately i was not able to get any graphics on the screen instead of 1024 px vesa with 'nv-disabled'.

    anyone any ideas or sucessfull build with HP zbook studio G3 UHD-display ?

    clover-folder attached - thx in advance !
     

    Attached Files:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice