Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch (10.11)

Status
Not open for further replies.
Joined
Sep 4, 2011
Messages
16
Motherboard
Dell Precision 7730-Clover
CPU
E-2186M
Graphics
P3200 + UHD P630, 1920x1080
Your ioreg shows no USB storage devices plugged in.
It also shows Android File Transfer hooking your USB ports. See FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

USB3 devices don't connect to a hub (they connect directly to XHC), so USBHubPowerFix is nonsense in this scenario.

I have no issue with my USB3 storage devices here and my 4540s.
It could be your specific device needs more power than mine.
You might try increasing the power properties (refer to SSDT-XHC.asl).

You are right of course, I've forgot to connect the USB devices prior to running IOReg :rolleyes:
Can I reupload it?

Thank you for the insight about Android File Transfer, do you think that simply removing it from "/Applications" would suffice to "disable" it? Or should I also look at Launch Deamons/Agents?

Regarding the power draw I don't think that it is an hardware problem since in both Windows/GNU-Linux I can use the same devices just fine, I'll try looking at SSDT-XHC.asl :)

I've updated my previous post with additional information about another minor problem (maybe it is also related to Android File Transfer?)
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
You are right of course, I've forgot to connect the USB devices prior to running IOReg :rolleyes:
Can I reupload it?

Might be worthwhile. Nothing to look at otherwise.

Thank you for the insight about Android File Transfer, do you think that simply removing it from "/Applications" would suffice to "disable" it? Or should I also look at Launch Deamons/Agents?

Read the FAQ.

Regarding the power draw I don't think that it is an hardware problem since in both Windows/GNU-Linux I can use the same devices just fine..

Power draw greater than the power properties injected.
Obviously, a macOS/OS X specific thing.
Windows and Linux determine power supply on USB differently.

I've updated my previous post with additional information about another minor problem (maybe it is also related to Android File Transfer?)

As per FAQ (you should read it), Android File Transfer is known to interfere.
 
Joined
Sep 4, 2011
Messages
16
Motherboard
Dell Precision 7730-Clover
CPU
E-2186M
Graphics
P3200 + UHD P630, 1920x1080
Might be worthwhile. Nothing to look at otherwise.



Read the FAQ.



Power draw greater than the power properties injected.
Obviously, a macOS/OS X specific thing.
Windows and Linux determine power supply on USB differently.



As per FAQ (you should read it), Android File Transfer is known to interfere.

Sorry, I've underestimated the power of F.A.Qs :D
Thank you again for your ultrafast support, much appreciated :)
 
Joined
Sep 4, 2011
Messages
16
Motherboard
Dell Precision 7730-Clover
CPU
E-2186M
Graphics
P3200 + UHD P630, 1920x1080
Another thing that I've noticed: now in post installation phase my system seems to have duplicate kexts eg. /EFI/CLOVER/kexts/Other/(FakeSMC.kext,IntelMausiEthernet.kext and VoodooPS2Controller.kext) and /Library/Extensions/(FakeSMC.kext,IntelMausiEthernet.kext and VoodooPS2Controller.kext)
Should I leave them like that or the kexts in the ESP are no longer necessary now that they are also present in /L/E?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Another thing that I've noticed: now in post installation phase my system seems to have duplicate kexts eg. /EFI/CLOVER/kexts/Other/(FakeSMC.kext,IntelMausiEthernet.kext and VoodooPS2Controller.kext) and /Library/Extensions/(FakeSMC.kext,IntelMausiEthernet.kext and VoodooPS2Controller.kext)
Should I leave them like that or the kexts in the ESP are no longer necessary now that they are also present in /L/E?

By design.

It is the correct way.
You can read about it in post #2 of the main Clover laptop guide.
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Sep 4, 2011
Messages
16
Motherboard
Dell Precision 7730-Clover
CPU
E-2186M
Graphics
P3200 + UHD P630, 1920x1080
Understood :)

I've removed Android File Transfer completely and it fixed the Bluetooth issue :)

However the USB issues persist, this time after resuming the laptop from sleep I get two notification messages regarding both the external USB hard disk and the internal HP WebCam, I've tried to access the WebCam through FaceTime and in fact the software cannot use it :(
 

Attachments

  • Screen Shot 2017-09-05 at 5.03.16 PM.png
    Screen Shot 2017-09-05 at 5.03.16 PM.png
    1.5 MB · Views: 88
  • Screen Shot 2017-09-05 at 5.03.55 PM.png
    Screen Shot 2017-09-05 at 5.03.55 PM.png
    36.9 KB · Views: 79
Joined
Sep 4, 2011
Messages
16
Motherboard
Dell Precision 7730-Clover
CPU
E-2186M
Graphics
P3200 + UHD P630, 1920x1080
Like before If I connect the USB devices prior to the laptop power on then there is no problem, I'm able to access them without issue
If I remove and connect them in succession then the laptop won't be able to even detect them
 
Joined
Nov 30, 2016
Messages
23
Motherboard
Intel Zbook 15u G2
CPU
i7-5500u
Graphics
Intel HD 5500
Mobile Phone
  1. iOS
HI @RehabMan very good guide, I have used it several times for different notebooks, but I have noticed that with 10.12+ things have become more difficult, random restarts, bluetooth stops working, no sound after reboot, etc, and in an elitebook 9480m does not work the screen after wake, recommend using 10.11.6? , intel skylake or kabylake are supported on 10.11.6? thanks
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Understood :)

I've removed Android File Transfer completely and it fixed the Bluetooth issue :)

However the USB issues persist, this time after resuming the laptop from sleep I get two notification messages regarding both the external USB hard disk and the internal HP WebCam, I've tried to access the WebCam through FaceTime and in fact the software cannot use it :(

You forgot to attach "Problem Reporting" files.

Note: The "not ejected" problem is a very common/typical problem. Don't leave USB storage devices plugged in across sleep/wake cycle.
 
Status
Not open for further replies.
Top