Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch (10.11)

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks for your work first.
When I turn on bluetoot and try to send a file, no devices are found (i double checked with my Macbook, devices were visible).

May be issue with your SMBIOS/iCloud setup. For example, you have so far neglected to create a custom SMBIOS as per post #1.
 
Joined
Jul 23, 2015
Messages
9
Motherboard
Gigabyte Z68XP-UD3 rev 1.3
CPU
Intel Core i7
Graphics
Gigabyte Nvidia GTS 450
Mac
  1. MacBook Pro
May be issue with your SMBIOS/iCloud setup. For example, you have so far neglected to create a custom SMBIOS as per post #1.
I changed my SMBIOS, got a new serial number, rebooted several times, still no success :( but thank you anyways
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I changed my SMBIOS, got a new serial number, rebooted several times, still no success :( but thank you anyways

Probably an issue specifically with your chosen bluetooth controller then.
 
Joined
Jan 6, 2014
Messages
16
Motherboard
HP Elitebook 9470m - Clover
CPU
i5-3427U
Graphics
HD 4000, 1366x768
Hi,
Audio on my 9470m works perfectly 90% of the time, but every now and then the audio will come out of the speakers only and not the audio jack. A reboot always fixes this, but I was wondering if there was a way to reset audio w/o having to reboot.

Minor issue
Thanks.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi,
Audio on my 9470m works perfectly 90% of the time, but every now and then the audio will come out of the speakers only and not the audio jack. A reboot always fixes this, but I was wondering if there was a way to reset audio w/o having to reboot.

Minor issue
Thanks.

No idea without "Problem Reporting" files. Read post #1, "Problem Reporting". Carefully.
 
Joined
Jan 21, 2017
Messages
1
Motherboard
2560p
CPU
i7 2620M
Graphics
HD 3000
Hey. I have a 2560p HP Elitebook and I want to use hackintosh on it. Is it possible to run my WWAN module with Mac OS X?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hey. I have a 2560p HP Elitebook and I want to use hackintosh on it. Is it possible to run my WWAN module with Mac OS X?

This guide does not cover WWAN (therefore is off-topic). But you may find some information by using search.
 
Joined
Oct 3, 2013
Messages
28
Motherboard
HP 8460p
CPU
I5-2520 2.5
Graphics
HD3000
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
:oops: Apologies all USB's working as expected having followed all instructions!
I have installed El Capitan using the SSDTs you mention in the configuration you supplied in your zip files ... but ... like others I cannot get the USB ports on the left side of the 8460p to work. I rebooted several times with USB 2.0 sticks in the ports without luck. I have the same 8460p. Any ideas?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have installed El Capitan using the SSDTs you mention in the configuration you supplied in your zip files ... but ... like others I cannot get the USB ports on the left side of the 8460p to work. I rebooted several times with USB 2.0 sticks in the ports without luck. I have the same 8460p. Any ideas?

If your laptop has USB3 (NEC/Renasas), you need to install GenericUSBXHCI.kext.
They won't be perfect but will work if you plug the device in before booting.
It is why 6-series laptops with USB3 are not a good choice for 10.11.x+.
 
Joined
Oct 3, 2013
Messages
28
Motherboard
HP 8460p
CPU
I5-2520 2.5
Graphics
HD3000
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
If your laptop has USB3 (NEC/Renasas), you need to install GenericUSBXHCI.kext.
They won't be perfect but will work if you plug the device in before booting.
It is why 6-series laptops with USB3 are not a good choice for 10.11.x+.

I have placed GenericUSBXHCI.kext in the "other" folder under Clover/kexts in the EFI... but ... no success. Am I doing something wrong? Do I have to boot with any special options?
 
Top