Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch (10.11)

Status
Not open for further replies.
Joined
Jul 24, 2015
Messages
135
Motherboard
Gigabyte Z270N-WIFI
CPU
i7-7700K
Graphics
RX 560
Rehabman, could you help me with a DisplayPort? EliteBook 2570P, I5-3360M, HD4000. External monitor is Dell U3417W hooked with DP -> mDP (3440x1440). When I add the SSDT's I get crash on boot when external monitor is connected. I guess it's because of the HDMI patch.
 

Attachments

  • applehda.zip
    1.2 KB · Views: 75
  • CLOVER.zip
    1.4 MB · Views: 81
  • ioreg.zip
    678.7 KB · Views: 70
  • kextcache.zip
    1.5 KB · Views: 81
  • kextstat.zip
    1.4 KB · Views: 70
  • Patchmatic.zip
    51.5 KB · Views: 56

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
After installing an extra SSD (Samsung 850 EVO M.2 250GB) in the empty SSD slot I started hackintoshing my HP Zbook Studio G3. I used
Code:
# ProBook_4x0s_G3_Skylake is CX20724, Skylake, HDMI
, and MacBookPro13,3.

First of all thumbs up for the nice explanatory guide(s), the information is very clear. Still there are some issues with my laptop:

Using 'hybrid graphics' in bios only. The laptop 'feels' extremely fast, booting, starting programs etc.

What's working:
- Built in display (including brightness, no left corner glitches)
- Laptop keyboard
- Built in speakers
- Ethernet
- USB type A ports
- Battery percentage indicator
- (wake from) sleep (power button light starts blinking and fans turn off)
- Webcam

What's not working:
- Trackpad
- USB type C ports
- Headphone jack
- HDMI
- shutdown (actually does reboot)

Now the HDMI port is important to me, I would like to connect the laptop to an external monitor. The HDMI port is not 'hard-wired' to the discrete graphics card, as visible in the output of lspci -nn on Ubuntu. Also under Ubuntu the HDMI port works using 'hybrid graphics' so I believe this should be possible in macOS also.

I believe there is no 'power' on the HDMI port because the monitor on-light does not become 'on' but keeps blinking (indicating no input source). Already tried injecting intel true/false but no difference. Some help would be appreciated (even indicating where to start reading).

Should I report the progress on this laptop somewhere (explaining which exact steps are taken etc. to help other people with this laptop)?

Your trackpad is ALPS... not supported by this guide.
Your HDMI is likely attached directly to the Nvidia chip. Not covered by this guide...
As for the shutdown problem, you need customized USB SSDT.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Rehabman, could you help me with a DisplayPort? EliteBook 2570P, I5-3360M, HD4000. External monitor is Dell U3417W hooked with DP -> mDP (3440x1440). When I add the SSDT's I get crash on boot when external monitor is connected. I guess it's because of the HDMI patch.

You did not follow the guide. Read post #1.
 
Joined
Jul 24, 2015
Messages
135
Motherboard
Gigabyte Z270N-WIFI
CPU
i7-7700K
Graphics
RX 560
You did not follow the guide. Read post #1.

What did I miss?

Edit: I just read it again, was it my sig? I updated it right after I made the post, so you might not have seen it before you replied.
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
What did I miss?

You missed the entire post-installation process. The EFI/Clover you attached is the EFI/Clover used for installation USB.
 
Joined
Jul 24, 2015
Messages
135
Motherboard
Gigabyte Z270N-WIFI
CPU
i7-7700K
Graphics
RX 560
You missed the entire post-installation process. The EFI/Clover you attached is the EFI/Clover used for installation USB.

No, it's the post installation Clover, I just had to use plist from usb and delete patched ssdt's to be able to use my external monitor with DP. With post installation plist and SSDT's I got crash when plugged the DP, so I couldn't even get ioreg with monitor plugged.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
No, it's the post installation Clover, I just had to use plist from usb and delete patched ssdt's

Wrong. Follow the guide as written.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I did the post installation steps again, here's clover.

This looks as expected (when using the wrong ig-platform-id). If you have some issue with DP, you should try disabling the "HDMI-video, 64MB BIOS, HD4000 0x01660004 #1 of 2". The #2 of #2 patch is, of course, needed to enable the DP port at all.
 
Last edited:
Status
Not open for further replies.
Top