Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch (10.11)

Status
Not open for further replies.
Joined
Oct 23, 2016
Messages
330
Motherboard
HP EliteBook 1030 G1 (Clover)
CPU
m7-6Y75
Graphics
HD515, 3200x1800
BTW, how are you collecting ioreg if you can't boot?
The ioreg shows WiFi working.
The BCM94350ZAE have several problems reported by hackintosh community on most models like Dell XPS, HP XXXBook, Lenove XXPad etc. But it was reported successful working on other models (e.g., my ECS Liva Core).
After searching on google and tested on my elitebook so long times, I found all scenario was occurred on my elitebook folio 1020 g1. Let me list and explaining those:

0. Lose BCM94350
BIOS - System Information:
Code:
WLAN FCC ID: Test WLAN
Bluetooth FCC ID: Not Applicable
Under some condition, `WLAN FCC ID: Test WLAN' was disappear, there is no wi-fi hardware found in BIOS, and no wi-fi hardware found on laptop, even `lspci -nn'.
Repair: Remove AC adapter, wait Wi-Fi button status light/led off, then goto BIOS, WLAN comes back.

1. AirportBrcm4360 panic
If I remove AC adapter, wait Wi-Fi button status light/led off, the next boot will panic, so I boot into ubuntu first.

2. card installed/enabled, but cannot power on.

3. card can powered on, but no ssid search result.

4. once connect an ssid, but get 169.x.x.x ip.

5. once it works normally, may be after reboot from windows/linux.

PS: not finished.
 
Last edited:
Joined
Nov 10, 2012
Messages
29
Motherboard
HP Elitebook 8460p MacOs Sierra 10.12.1
CPU
i5 2.5ghz 12GB ram
Graphics
HD 3000 1600x900
Hello RehabMan, I can boot from HDD only if I copy the config.plist from the clover efi usb, if I follow your guide the config doesn't allow to boot, I still have a black screen.
By the way bluetooth works but wifi never worked even if I have the good Broadcom.
Battery percentage doesn't work and I can't enable the sound because I don't have the possibility to boot without caches. maybe I took a too recent clover uefi version ?
thanks again and again
 
Last edited:
Joined
Dec 24, 2016
Messages
9
Motherboard
HP Folio 13-2000 (Chimera)
CPU
Core i5 2467M / HM65
Graphics
Intel Graphics 3000
Mac
  1. MacBook Pro
Delete - I messed up :(
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,935
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
The BCM94350ZAE have several problems reported by hackintosh community on most models like Dell XPS, HP XXXBook, Lenove XXPad etc. But it was reported successful working on other models (e.g., my ECS Liva Core).
After searching on google and tested on my elitebook so long times, I found all scenario was occurred on my elitebook folio 1020 g1. Let me list and explaining those:

0. Lose BCM94350
BIOS - System Information:
Code:
WLAN FCC ID: Test WLAN
Bluetooth FCC ID: Not Applicable
Under some condition, `WLAN FCC ID: Test WLAN' was disappear, there is no wi-fi hardware found in BIOS, and no wi-fi hardware found on laptop, even `lspci -nn'.
Repair: Remove AC adapter, wait Wi-Fi button status light/led off, then goto BIOS, WLAN comes back.

Hardware incompatibility/defect. Nothing to do with this guide.

1. AirportBrcm4360 panic
If I remove AC adapter, wait Wi-Fi button status light/led off, the next boot will panic, so I boot into ubuntu first.

2. powered on, but no ssid search result.

3. once connect an ssid, but get 169.x.x.x ip.

4. once it works normally, may be after reboot from windows/linux.

PS: not finished.

You should also try without FakePCIID_Broadcom_WiFi.kext. Outside of that no more ideas for you.

Sounds like more incompatibility. You should consider installing BCM94352Z.
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,935
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi,

Long time lurker, first time poster. Thanks for the great work on the guide. Setup El Cap on a ZBook 15u G2 which is running nicely, and just wanted to get a custom USB SSDT created since there isn't one for this particular model?

IOReg output attached.

Thank you!

Your profile is not filled out per guide.

Please provide complete details in your profile/signature
("Personal Details" link from "profile menu" in upper right corner of this site)

Mobo: manufacturer/model + bootloader(Clover/Chameleon/Chimera)
CPU: detailed CPU model + motherboard chipset
Graphics: all graphics devices + laptop internal screen resolution

For example, typical Ivy laptop:
Mobo: HP ProBook 4540s (Clover)
CPU: i5-3320m/HM76
Graphics: HD4000, 1366x768

Use CPU-Z on Windows to find CPU (Core iX-xxx) and motherboard chipset (HMxx), and graphics capabilities. For a laptop, these details are important and affect critical installation procedures.

Note: When specifying your bootloader, if using Clover legacy, please be sure to specify "Clover legacy"). Specifying "Clover" will be assumed as "Clover UEFI"
 
Joined
Nov 10, 2012
Messages
29
Motherboard
HP Elitebook 8460p MacOs Sierra 10.12.1
CPU
i5 2.5ghz 12GB ram
Graphics
HD 3000 1600x900
I can boot from HDD only if I copy the config.plist from the clover efi usb, if I follow your guide the config doesn't allow to boot, I still have a black screen.
By the way bluetooth works but wifi never worked even if I have the good Broadcom.
Battery percentage doesn't work and I can't enable the sound because I don't have the possibility to boot without caches. I think almost nothing works because the config.plist isn't the good one with wifi Andy sounds kexts. But I don't know which step I have to make the new config.plist working and booting well.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,935
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I can boot from HDD only if I copy the config.plist from the clover efi usb, if I follow your guide the config doesn't allow to boot, I still have a black screen.

You never replied to #4688.

Second request: Attach EFI/Clover folder as ZIP (omit 'themes' folder).
 
Last edited:
Joined
Nov 10, 2012
Messages
29
Motherboard
HP Elitebook 8460p MacOs Sierra 10.12.1
CPU
i5 2.5ghz 12GB ram
Graphics
HD 3000 1600x900
You never replied to #4688.

Second request: Attach EFI/Clover folder as ZIP (omit 'themes' folder).

Sorry I didn't see this previous message. Here is what you requested me (screen+clover folder), thank you for your help !
 

Attachments

  • cloverlog.zip
    2.1 MB · Views: 85

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,935
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Sorry I didn't see this previous message. Here is what you requested me (screen+clover folder), thank you for your help !

You used the wrong parameter for install_acpi.sh. For 1600x900 you need SSDT-IGPU-HIRES.aml, not SSDT-IGPU.aml.
Use the correct option for install_acpi.sh.
 
Status
Not open for further replies.
Top