Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch (10.11)

Joined
Jul 21, 2012
Messages
6
Motherboard
Asus Rampage IV Extreme, Asus G750Jx, Zbook Studio G3
CPU
i7 3970x, i7 4700HQ, Xeon E3-1505M v5, i7 3960x
Graphics
Dual AMD 7970, Nvidia GeForce 770M, Nvidia Quadro M1000M + Intel P530
Hi RehabMan,
I've following you for while but so far I was able to build my hackintosh without any extra help just following yours or others tutorials.. However, this time I'm need of some help to make my GPU to fully work. It's working but I can't play mkv videos, just mp4 on Quicktime or Youtube videos as acceleration doesn't seem to be fully working.

To get to this point I had to add inject Intel and add the fake id:
Code:
        <key>ig-platform-id</key>
        <string>0x191b0000</string>
        <key>NvidiaSingle</key>

GPU Bios is set to:
Mem: 64MB
Graphics: Auto - there is no way to use HD P530 only, so your SSDT disable the NVidia.

Audio - Mic/Speaker work great.
Camera too - tested on Skype

I haven't run the power management scripts(ssdtPRGen.sh) yet and done the hibernate/sleep change.
Here is my spec:
http://h20386.www2.hp.com/AustraliaStore/Merch/Product.aspx?id=T9S44PA&opt=&sel=NTB

Zbook Studio G3
Intel Xeon E3-1505M V5 2.80GHz
32GB RAM DDR4
Intel HD P530 - IGPU - 90% working
NVidia Quadro M10000M - not working
15.6" diagonal FHD UWVA IPS anti-glare LED-backlit (1920 x 1080)
Intel® Dual Band Wireless-AC 8260 802.11 a/b/g/n/ac (2x2) non-vPro Wi-Fi and Bluetooth® 4.0 combo - not working - not supported hardware
HDMI port - not working
DP -> USB 3 type C - not working
USB 3 ports - working
Kingston 240GB HyperX Predator M.2 SSD SHPM2280P2/240G - Fully working
Toshiba XG3 SSD 512GB THNSN5512GPU7 M.2 2280 NVMe - Showed up once and never more. Also, it showed up on a recovery boot in the Disk Utility.

I've attached the files asked on the first post - unsupported laptops - however I can't do a lscpi -nn on a Linux terminal as this laptop doesn't have a CD/DVD drive and the only USB drive I have, I used to install El Caption on it first before moving to the internal SSD(Kingston).

Any help will be very much appreciated.. Thanks a lot!!!

Some pictures:
Screen Shot 2016-08-20 at 5.52.03 PM.png
IMG_3194.jpg
Screen Shot 2016-08-20 at 6.05.05 PM.png
Screen Shot 2016-08-20 at 11.12.57 AM.png
Screen Shot 2016-08-20 at 4.38.38 PM.png
Screen Shot 2016-08-20 at 4.39.31 PM.png
Screen Shot 2016-08-20 at 5.30.16 PM.png
Screen Shot 2016-08-20 at 11.12.37 AM.png
Screen Shot 2016-08-20 at 11.13.18 AM.png
Screen Shot 2016-08-20 at 11.13.35 AM.png
Screen Shot 2016-08-20 at 11.15.18 AM.png
Screen Shot 2016-08-20 at 11.15.29 AM.png
Screen Shot 2016-08-20 at 11.15.52 AM.png
Screen Shot 2016-08-20 at 11.16.24 AM.png
Screen Shot 2016-08-20 at 11.43.05 AM.png
Screen Shot 2016-08-20 at 11.43.29 AM.png
 

Attachments

  • Archive.zip
    591.3 KB · Views: 93
  • RehabMan.zip
    80.8 KB · Views: 97
  • CLOVER.zip
    4.8 MB · Views: 119
  • Screen Shot 2016-08-20 at 6.05.05 PM.png
    Screen Shot 2016-08-20 at 6.05.05 PM.png
    450.8 KB · Views: 143

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,309
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi RehabMan,
I've following you for while but so far I was able to build my hackintosh without any extra help just following yours or others tutorials.. However, this time I'm need of some help to make my GPU to fully work. It's working but I can't play mkv videos, just mp4 on Quicktime or Youtube videos as acceleration doesn't seem to be fully working.

Try with the changes just checked into SSDT-IGPU and the new build of FakePCIID.
 
Joined
Feb 8, 2016
Messages
23
Mac
Classic Mac
Mobile Phone
I noticed under System Profiler my computer was recognized as a MacBook Pro. I was putting off setting up my SMBIOS because I was happy with it booting. So, I set it up as a MacBookPro and now it won't boot. I think it had no fields filled in before except for the identifier which was a MacBookAir7,1 but I'm not sure.

I have an HP ProBook 450 G3
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,309
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I noticed under System Profiler my computer was recognized as a MacBook Pro. I was putting off setting up my SMBIOS because I was happy with it booting. So, I set it up as a MacBookPro and now it won't boot. I think it had no fields filled in before except for the identifier which was a MacBookAir7,1 but I'm not sure.

I have an HP ProBook 450 G3

Boot verbose, show photo. Attach EFI/Clover folder as ZIP (omit 'themes' folder).

--

Please provide complete details in your profile/signature
(Profile/Settings link in upper right corner of this site)

Mobo: manufacturer/model + bootloader(Clover/Chameleon/Chimera)
CPU: detailed CPU model + motherboard chipset
Graphics: all graphics devices + laptop internal screen resolution

For example, typical Ivy laptop:
Mobo: HP ProBook 4540s (Clover)
CPU: i5-3320m/HM76
Graphics: HD4000, 1366x768

Use CPU-Z on Windows to find CPU (Core iX-xxx) and motherboard chipset (HMxx), and graphics capabilities. For a laptop, these details are important and affect critical installation procedures.

Note: When specifying your bootloader, if using Clover legacy, please be sure to specify "Clover legacy"). Specifying "Clover" will be assumed as "Clover UEFI"
 
Joined
Feb 8, 2016
Messages
23
Mac
Classic Mac
Mobile Phone
Boot verbose, show photo. Attach EFI/Clover folder as ZIP (omit 'themes' folder).

--

Please provide complete details in your profile/signature
(Profile/Settings link in upper right corner of this site)

Mobo: manufacturer/model + bootloader(Clover/Chameleon/Chimera)
CPU: detailed CPU model + motherboard chipset
Graphics: all graphics devices + laptop internal screen resolution

For example, typical Ivy laptop:
Mobo: HP ProBook 4540s (Clover)
CPU: i5-3320m/HM76
Graphics: HD4000, 1366x768

Use CPU-Z on Windows to find CPU (Core iX-xxx) and motherboard chipset (HMxx), and graphics capabilities. For a laptop, these details are important and affect critical installation procedures.

Note: When specifying your bootloader, if using Clover legacy, please be sure to specify "Clover legacy"). Specifying "Clover" will be assumed as "Clover UEFI"
I'll be sure to do all that when I get home. I don't know how I'll upload my Clover folder as I cannot boot. I know it won't boot because I messed with the SMBIOS. Can I just post that section in clover?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,309
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I don't know how I'll upload my Clover folder as I cannot boot.

Boot using your USB. Or remove the HDD and connect it to a working computer.
 
Joined
Jul 21, 2012
Messages
6
Motherboard
Asus Rampage IV Extreme, Asus G750Jx, Zbook Studio G3
CPU
i7 3970x, i7 4700HQ, Xeon E3-1505M v5, i7 3960x
Graphics
Dual AMD 7970, Nvidia GeForce 770M, Nvidia Quadro M1000M + Intel P530
Try with the changes just checked into SSDT-IGPU and the new build of FakePCIID.

RehabMan,
I LOVE YOU!!!!! :clap::headbang: You rocks!!!

I tried patching the SSDT-IGPU myself but instead of using the fake id I used it's original id. So, it didn't work.

I need to figure out:
Also needs fixing:
1) USB 3 type C ports need fixing.
2) trackpad - it's not working.
3) how to fix the HDMI port, it's no working, there is no signal when connecting an external monitor.
4) Targus BT ACB75AU works fine on my Asus G750JX hackintosh laptop - El Capitan 10.11.5, but fail on this one. http://targus.com/au/Bluetooth-4_0-DualMode-Micro-USB-Adapter-acb75au
5) Wifi - get a dongle as I couldn't find a compatible mini card for the Zbook Studio - I have few wifi mini cards but they are still bigger than the original intel 8260. They do fit on my Asus G750JX.

I need to create a forum signature with my hackintoshes, so far 2 PCs and 2 laptops.

Can you help me with the USB 3 type C and HDMI port?
I can live without BT and wifi for now as a dongle may fix that.

Also, if you need any help with development/code, I'm happy to help. I've 22 years of development experience, I don't know everything but I know a few tricks on Assembly, C/C++, Objective-C, Java and others.
I'd love to understand DDT and SSDT better to help the community. So far I've being greatful for all work that has been done and with just blogs, forums posts, patches, I was able to install hackintosh on my other 3 devices with success and I always wanted to help but I usually got stuck with the DDT and SSDT and drivers debugging on OS X.. I did develop a few simple drivers but that was it.

Again thanks a lot!! You rock man!
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,309
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
1) USB 3 type C ports need fixing.

I don't think the support for USB-C is complete in 10.11. Maybe in 10.12. But you should go through the process identified in "USB Customization".

2) trackpad - it's not working.

Post "Problem Reporting" files.

3) how to fix the HDMI port, it's no working, there is no signal when connecting an external monitor.

Like other ZBooks, your HDMI is probably directly connected to Nvidia. Will require getting the Nvidia device working...

4) Targus BT ACB75AU works fine on my Asus G750JX hackintosh laptop - El Capitan 10.11.5, but fail on this one. http://targus.com/au/Bluetooth-4_0-DualMode-Micro-USB-Adapter-acb75au

Probably a USB issue, see above...

5) Wifi - get a dongle as I couldn't find a compatible mini card for the Zbook Studio - I have few wifi mini cards but they are still bigger than the original intel 8260. They do fit on my Asus G750JX.

Replace internal WiFi card with compatible card. Read post #1.

Also, if you need any help with development/code, I'm happy to help. I've 22 years of development experience, I don't know everything but I know a few tricks on Assembly, C/C++, Objective-C, Java and others.

That's good because it means you can probably contribute the custom USB SSDT... after you determine all the ports needed.
 
Joined
Jul 21, 2012
Messages
6
Motherboard
Asus Rampage IV Extreme, Asus G750Jx, Zbook Studio G3
CPU
i7 3970x, i7 4700HQ, Xeon E3-1505M v5, i7 3960x
Graphics
Dual AMD 7970, Nvidia GeForce 770M, Nvidia Quadro M1000M + Intel P530
I don't think the support for USB-C is complete in 10.11. Maybe in 10.12. But you should go through the process identified in "USB Customization".


Post "Problem Reporting" files.


Like other ZBooks, your HDMI is probably directly connected to Nvidia. Will require getting the Nvidia device working...



Probably a USB issue, see above...



Replace internal WiFi card with compatible card. Read post #1.



That's good because it means you can probably contribute the custom USB SSDT... after you determine all the ports needed.

I've posted the "Problem Reporting" files on my original post.. I'll upload them again.
I'll debug the USB as recommended and post back.
I'm aware that my wifi is not compatible, I tried a few mini cards that I've they don't fit on the Zbook, they do fit on the Asus G750Jx. The Zbook Studio G3 seems to use a card even smaller than mini card..
Again thanks a lot!!
 

Attachments

  • RehabMan.zip
    80.8 KB · Views: 46
  • Archive.zip
    591.3 KB · Views: 47
Last edited:
Joined
Feb 8, 2016
Messages
23
Mac
Classic Mac
Mobile Phone
Boot using your USB. Or remove the HDD and connect it to a working computer.
I don't have either of these options available to me while I'm away. Why can't I just edit the SMBIOS in Clover. I know it should boot when I only leave "MacBookPro11,1" in the identifier field but I'm getting the attached error instead.
 

Attachments

  • image.jpg
    image.jpg
    2.8 MB · Views: 109
Top