Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch (10.11)

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,490
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Finally able to boot my 840 G2 with this tutorial. Thanks RehabMan!

Slight problem with the Post Installation part. It tells me: iasl: command not found. What can I do to fix this?

It means you didn't run ./download.sh and ./install_downloads.sh.

Read the guide carefully.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,490
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Having huge problems with sound on 10.11.5. Everything seems fine except the sound. In systeminfo it says no sound installed. Any help is appreciated. Tried several times now following the guide and also patch the 10.11.4 sound fix for pro books.

Edit: sound problems like in it works on 10.11.3 with PBI but not on 10.11.3 with this guide.

Probook G1 450
Intel I5 HD4200
12GB RAM

Read post #1, "Problem Reporting".
 
Joined
Jun 15, 2016
Messages
37
Motherboard
MSI X99S SLI PLUS
CPU
i7-5820K
Graphics
GTX 980TI
It means you didn't run ./download.sh and ./install_downloads.sh.

Read the guide carefully.

Really thought I ran that haha, got it fully working now! Working ethernet and sound. Super happy with this guide. Even 6 hours battery time. Thanks :)
 

Attachments

  • IMG_20160628_123442.jpg
    IMG_20160628_123442.jpg
    4.5 MB · Views: 126
Joined
May 23, 2015
Messages
31
Motherboard
HP ProBook 4530s
CPU
i3 2,1GHz
Graphics
Intel HD 3000
Mac
Classic Mac
Mobile Phone
Maybe your problem is related to USB3 and GenericUSBXHCI.kext. Remove it and test.

Hi ReHabman,

I deleted that kext from /S/L/E/ and everything was working fine (wake up after sleep), as soon as I migrate to the hotpatch setup (following your instructions carefully) my system hungs again. OS version is 10.11.4.

You think that maybe a kext is responsible for this?

My next step is to restore (again) and compare the kexts loaded looking in Kext Wizard. I will compare with the kexts loaded right now with the hotpatch setup.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,490
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi ReHabman,

I deleted that kext from /S/L/E/ and everything was working fine (wake up after sleep), as soon as I migrate to the hotpatch setup (following your instructions carefully) my system hungs again. OS version is 10.11.4.

You think that maybe a kext is responsible for this?

My next step is to restore (again) and compare the kexts loaded looking in Kext Wizard. I will compare with the kexts loaded right now with the hotpatch setup.

Why are you "migrating" to hotpatch? Do a fresh install directly of 10.11.5. Follow the guide exactly as written.
 
Joined
May 16, 2016
Messages
51
Motherboard
Dell Optiplex 9010
CPU
Intel Core i5 3470 @3,2Ghz
Graphics
Intel integrated GPU
hi Rehabman,
just two question on my triple boot 8460p:

- i'm installing an HP Laserjet Color M277, i can setup it on OSX with kext?
or i can download drivers stright from HP?

- can you tell me a safety system cleaner?
i have installed a cleaner , but after cleaning (too much) files and reboot , now my account is gone.
Blank username and blank password

on second point don't worry i have a full ghost of my system, it be useful know a good system cleaner/optimizer and how to setup printer

let me know.
Thanks
 
Joined
May 23, 2015
Messages
31
Motherboard
HP ProBook 4530s
CPU
i3 2,1GHz
Graphics
Intel HD 3000
Mac
Classic Mac
Mobile Phone
Why are you "migrating" to hotpatch? Do a fresh install directly of 10.11.5. Follow the guide exactly as written.

I'm migrating to hotpatch because it's the best way to get the latest kexts and install them on my system.

Before restore my Time Machine backup I did try a fresh install in my hard drive (two times, two different El Capitan versions downloaded from AppStore) and had the same problem (system hungs each time comes back from sleep).
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,490
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm migrating to hotpatch because it's the best way to get the latest kexts and install them on my system.

Before restore my Time Machine backup I did try a fresh install in my hard drive (two times, two different El Capitan versions downloaded from AppStore) and had the same problem (system hungs each time comes back from sleep).

Install 10.11.5 (current version), download from Mac App Store. Do not do any kind of TM restore. Follow guide in post #1.
 
Joined
May 23, 2015
Messages
31
Motherboard
HP ProBook 4530s
CPU
i3 2,1GHz
Graphics
Intel HD 3000
Mac
Classic Mac
Mobile Phone
hi Rehabman,
just two question on my triple boot 8460p:

- i'm installing an HP Laserjet Color M277, i can setup it on OSX with kext?
or i can download drivers stright from HP?

- can you tell me a safety system cleaner?
i have installed a cleaner , but after cleaning (too much) files and reboot , now my account is gone.
Blank username and blank password

on second point don't worry i have a full ghost of my system, it be useful know a good system cleaner/optimizer and how to setup printer

let me know.
Thanks

You just need to plug the printer in OS X, maybe you'll need Mac drivers (download it from hp.com). In my case the printer was installed just plugin the USB cable, later on an HP update came from AppStore. You can always check it in System Preferences/Printer.

To clean your system you can use CCleaner and Malwarebytes for Mac, with these two I clean a lot of systems with good results. Appcleaner is a great application to delete apps and all the files related (it's like a simple uninstaller).
 
Joined
Sep 9, 2014
Messages
4
Motherboard
Asus Prime B360 PLUS-1601
CPU
i7-8700
Graphics
UHD 630
Mac
  1. MacBook Pro
Hi Guys 10.11.5 has something diffrent with hdaaudio on hp probook 4540s I changed the to older version of hdaaudio not it work. But still have problem with wifi HP Atheors 9285 AR5B95 Wifi is dectect start scanning but not luck.

Dmesg say
143.130800: ath_chan_set: unable to reset channel 3 (2422Mhz) flags 0x10080 hal status 14
143.137264: ATHR: unknown locale: 60

so the probably problem with locale how to patch that ?

Card worked perfectly on 10.11.4
 
Status
Not open for further replies.
Top