Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch (10.11)

Status
Not open for further replies.
Joined
Aug 3, 2012
Messages
270
Motherboard
H270N-WIFI
CPU
7600K
Graphics
RX 570
The guide installs all those files for you. Read post #1, "Problem Reporting".

Well this is really weird. I got the bluetooth paired with a music device. The bluetooth connection is really really slow so that the sound shutters ... i am not able to use it correct. And now the system hard shutdown (twice) when i have bluetooth activated and paired.
Please find the attachment.

//EDIT: I tested the bluetooth module on windows and its quite stable and operates as it should.
 

Attachments

  • Rehabman.zip
    16.7 MB · Views: 76
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,968
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Well this is really weird. I got the bluetooth paired with a music device. The bluetooth connection is really really slow so that the sound shutters ... i am not able to use it correct. And now the system hard shutdown (twice) when i have bluetooth activated and paired.
Please find the attachment.

//EDIT: I tested the bluetooth module on windows and its quite stable and operates as it should.

I think there are widespread bluetooth audio problems in 10.11... on real Macs too. But it could also a firmware compatibility issue. All we can do is install the firmware that is the latest for the device and hope for the best.

Things look fine regarding BT in this ioreg, although you're not using the latest BrcmPatchRAM (released yesterday).
 
Joined
Aug 3, 2012
Messages
270
Motherboard
H270N-WIFI
CPU
7600K
Graphics
RX 570
Puh. And again, macOS shuts down ... while being paired with the audio device ... :banghead:
I have some range problems with my T430, but this uses an old bluetoothchip and maybe a bit related to 10.11.
But these immediate shutdowns seems to be like a driver issue ... I saw you have such a chip too. Do you encounter any problems with the BCM94352Z?


//EDIT: Does it maybe has to do with windows shutdown and restart option? Because windows does not really shutdown everything if i klick shutdown. it only shutdown everything if you klick on restart ... Maybe the device is still somehow in use???
Because i deactivated the bluetooth module and klicked restart. Now i can use BT as i wanted without shutdowns of macOS...
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,968
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Puh. And again, macOS shuts down ... while being paired with the audio device ... :banghead:
I have some range problems with my T430, but this uses an old bluetoothchip and maybe a bit related to 10.11.
But these immediate shutdowns seems to be like a driver issue ... I saw you have such a chip too. Do you encounter any problems with the BCM94352Z?


//EDIT: Does it maybe has to do with windows shutdown and restart option? Because windows does not really shutdown everything if i klick shutdown. it only shutdown everything if you klick on restart ... Maybe the device is still somehow in use???
Because i deactivated the bluetooth module and klicked restart. Now i can use BT as i wanted without shutdowns of macOS...

The problem you have might be caused by VoodooHDA.

Or even Boom.
 
Joined
Aug 3, 2012
Messages
270
Motherboard
H270N-WIFI
CPU
7600K
Graphics
RX 570
Well voodooHDA could the problem. Haven't thought of it. Boom is quite stable, because i used it on my current notebook with el capitan and BT and never experienced such weirdness....

//EDIT: Okay i will try some time with your AppleHDA and without voodoo.
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,968
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Well voodooHDA could the problem. Haven't thought of it. Boom is quite stable, because i used it on my current notebook with el capitan and BT and never experienced such weirdness....

//EDIT: Okay i will try some time with your AppleHDA and without voodoo.

Try also without Boom. I've seen numerous problems with it...

Fundamental to troubleshooting is isolation. You don't want to introduce variables unnecessarily.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,968
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks, will do!
Right now the adapter from displayport -> DVI/VGA/HDMI finally arrived.
So i can confirm that displayport works. But is there a patch for Displayport audio?

Would need to see ioreg.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,968
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
ioreg attached.

I notice you're using the 4x0_g3 files (config/install script/USB SSDT).

That is all working out ok? Did you verify all USB ports working with the 4x0_G3 SSDT for USB? Is KEY102 working ok, or should it be KEY87?

Part of the problem with DP audio using those files with your laptop is that the 4x0_G3 has HDMI, not DP. Requires a slightly different config.plist setup (no HDMI audio patch).
 
Status
Not open for further replies.
Top