Contribute
Register

[Guide] HP ProBook 440 G6 i5 8265u Big Sur 11.0.1 OpenCore

Joined
Nov 8, 2012
Messages
7
Motherboard
H97M Pro4
CPU
i7-4770
Graphics
GTX 970
Mac
  1. iMac
Mobile Phone
  1. iOS
I use the EFI from

enljm115 - page 3

Only "problem" The battery symbol turns red at 99%
thanks! it works for me, i haven't fully charged yet to see the problem but the EFI seems cluttered to my liking. will be cleaning this up and will post here for anyone else that might be running to this thread.

edit:
*no "problem" of red battery icon on 99%! (Maybe SMBIOS changed fixed it?)
*low battery warning at 10% and battery turned red properly.

FIX
*attached the EFI that i'm using (MLB/ROM/SMUUID/SN removed)
*iServices work (have been working before, values above are important!)
*added GUI to bootloader for cosmetics (opencanopy.efi)
*fixed my HDMI out (others may not be same fix as mine)

TODO
*need to fix the brightness hotkeys using SSDT(currently FN+W and FN+C)
*internal mic does not work tried all layout-id for ALC236, none worked (line in does work however)
*swap with broadcom card to enjoy all continuity features
 

Attachments

  • 440-G7-OC-0.6.4-EFI.zip
    31.2 MB · Views: 52
Last edited:
Joined
Dec 24, 2010
Messages
16
Motherboard
HP Probook 450 G7
CPU
i7-10510U
Graphics
UHD 620 / 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi @putra_naz94
Your EFI works for me too, thanks for sharing. My machine is a HP Probook 450 G7 and it seems that the camera is different. The paths however are exactly the same in the USB SSDT. It fits there HS02.WCAM as well as HS02.IRCM. Nevertheless, the camera does not activate..although it is recognized as "HP HD Camera".
Therefore, can you share me your IO registry or the XHC part with the individual specs of the cam? That would be wonderful.
Thank you.

A second question is, which SMBIOS model are you using? It is a MacBookAir9,1 in the config.plist. is that the appropriate model?

Thank you very much
 
Joined
Jan 21, 2021
Messages
20
Motherboard
HP Probook 450 G7 (OpenCore)
CPU
i5-10210U
Graphics
UHD620, 1920 x 1080 + GTX MX250
Hi @putra_naz94
Your EFI works for me too, thanks for sharing. My machine is a HP Probook 450 G7 and it seems that the camera is different. The paths however are exactly the same in the USB SSDT. It fits there HS02.WCAM as well as HS02.IRCM. Nevertheless, the camera does not activate..although it is recognized as "HP HD Camera".
Therefore, can you share me your IO registry or the XHC part with the individual specs of the cam? That would be wonderful.
Thank you.

A second question is, which SMBIOS model are you using? It is a MacBookAir9,1 in the config.plist. is that the appropriate model?

Thank you very much
Hi @Charly10000 i have same laptop, what is your average screen on time ? I'm getting only 2 hours 20 mins.
 
Joined
Dec 24, 2010
Messages
16
Motherboard
HP Probook 450 G7
CPU
i7-10510U
Graphics
UHD 620 / 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi @newmalikhack
Today I have optimized. now my battery is after about 3 hours with 100% backlight at about 50% in idle mode. Only desktop there and backlight 100%.
I created a github with my config.
I don't know if it's allowed to post a github link. So you could try my config.

Does your camera work in your device?
 
Last edited:
Joined
Jan 21, 2021
Messages
20
Motherboard
HP Probook 450 G7 (OpenCore)
CPU
i5-10210U
Graphics
UHD620, 1920 x 1080 + GTX MX250
@Charly10000 Yes GitHub link is allowed, please post it here. Yes my camera is working I can see myself in FaceTime lol.
Hi @newmalikhack
Today I have optimized. now my battery is after about 3 hours with 100% backlight at about 50% in idle mode. Only desktop there and backlight 100%.
I created a github with my config.
I don't know if it's allowed to post a github link. So you could try my config.

Does your camera work in your device?
 
Joined
Jan 21, 2021
Messages
20
Motherboard
HP Probook 450 G7 (OpenCore)
CPU
i5-10210U
Graphics
UHD620, 1920 x 1080 + GTX MX250
Hi @newmalikhack
Today I have optimized. now my battery is after about 3 hours with 100% backlight at about 50% in idle mode. Only desktop there and backlight 100%.
I created a github with my config.
I don't know if it's allowed to post a github link. So you could try my config.

Does your camera work in your device?
Can you please also elaborate little bit more the exact screen on time you're getting? On exact usage like brightness % , apps usage, Bluetooth and wifi on etc?
 
Joined
Dec 24, 2010
Messages
16
Motherboard
HP Probook 450 G7
CPU
i7-10510U
Graphics
UHD 620 / 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Okay. That's my Github Repo.
Can you share your IO Registry? Or the XHC part? My Cam is recognized as "HP HD Webcam" but only black screen in FaceTime or PhotoBooth
 
Joined
Dec 24, 2010
Messages
16
Motherboard
HP Probook 450 G7
CPU
i7-10510U
Graphics
UHD 620 / 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Okay. For testing Battery-life my brightness was 100%, WLAN Power ON, one SSD, one NVMe, one USB-Stick. All on but only Bluetooth off. So battery reduced after 3 hours to approx 50% and after 5 hours about 10%. Between hour 3 and hour 5 I used my device for surfing in internet, downloads, open tabs, used USB-Stick.. I think that's a very good battery life. Always On was "Intel Power Gadget" to see power consumption and clock ratio.
 
Joined
Jan 21, 2021
Messages
20
Motherboard
HP Probook 450 G7 (OpenCore)
CPU
i5-10210U
Graphics
UHD620, 1920 x 1080 + GTX MX250
Thanks @Charly10000 . sorry for the delay please check attached file form my IO Registry. i hope it is what you're looking for because i have no idea about these files.
 

Attachments

  • Malik’s MacBook Pro.ioreg
    18.7 MB · Views: 3
Joined
Jan 21, 2021
Messages
20
Motherboard
HP Probook 450 G7 (OpenCore)
CPU
i5-10210U
Graphics
UHD620, 1920 x 1080 + GTX MX250
@Charly10000 i have tried the both option but i'm facing "oc fail to load configuration" when i try to boot into macos while using your efi what could be the reason?
 
Top