Contribute
Register

[Guide] HP ProBook 430 G3 (SkyLake) - Mojave

Joined
May 7, 2017
Messages
12
Motherboard
HP Probook 450 G3 T1A14PA (Clover)
CPU
i5-6200U
Graphics
HD 520 + AMD, 1366x768
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
My HP 430G3 sleeps. There is no problem with return. Re-checking the BIOS screen may solve the problem. The attached BIOS screen is my BIOS setting.
Mitshuhiro san, thank you for your enthusiasm. I've forgotten to uncheck put hard disk to sleep at Energy saver. It's ok now.
 
Joined
Dec 23, 2011
Messages
172
Motherboard
HP ProBook 430 G6
CPU
i5-8265U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Does mac os support image output via vga (d-sub) port? Does it work with some special kexts for that?

It works out of the box for me. See screenshot attached to the original post.
 
Joined
Aug 1, 2016
Messages
184
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi guys and thank you Antonio765 for this thread and its "compactness". But unfortunately I need a helping hand. I used your clover folder for the thumb drive. With a felt eternity it let's me see and use the installer. Disk utility, the preparatory thingies. Installation works and prepares recovery partition. Round two. Another eternity but it does the trick and the installation works. Round three. Everything as expected. And here comes the "but". The very moment I desperately wait for the input cycle (name, country etc.) and the apple logo install bar reaches the right end this happens. (screenshot) I can move the mouse, hitting keys quickly/slightly flashes the screen. And that is the end of it? Please, can anybody help? I'm at a loss. TIA
P.S.: BIOS update only 2.38 as per guide although 1.39 is available. macOS 10.14.5
P.P.S.: BIOS update to 1.39 - no change, unfortunately
P.P.P.S.: (I know that my profile sounds misleading - but it's not my laptop)
P.P.P.P.S: "partly" succeeded. Tried out Rehabman's (I don't know where you are - but I hope everything is okay for you!) old 10.13.6 usb setup thumb drive and at least it got me a grey screen plus mouse. :roll2: But the mouse also disappears if you dare to click somewhere at the top screen. yikes
 

Attachments

  • nooooooooo.jpg
    nooooooooo.jpg
    193 KB · Views: 47
Last edited:
Joined
Feb 5, 2019
Messages
82
Motherboard
DELL Optiplex 7050 MT
CPU
i7-7700
Graphics
RX 560
Mobile Phone
  1. iOS
Hi guys and thank you Antonio765 for this thread and its "compactness". But unfortunately I need a helping hand. I used your clover folder for the thumb drive. With a felt eternity it let's me see and use the installer. Disk utility, the preparatory thingies. Installation works and prepares recovery partition. Round two. Another eternity but it does the trick and the installation works. Round three. Everything as expected. And here comes the "but". The very moment I desperately wait for the input cycle (name, country etc.) and the apple logo install bar reaches the right end this happens. (screenshot) I can move the mouse, hitting keys quickly/slightly flashes the screen. And that is the end of it? Please, can anybody help? I'm at a loss. TIA
P.S.: BIOS update only 2.38 as per guide although 1.39 is available. macOS 10.14.5
P.P.S.: BIOS update to 1.39 - no change, unfortunately
P.P.P.S.: (I know that my profile sounds misleading - but it's not my laptop)
P.P.P.P.S: "partly" succeeded. Tried out Rehabman's (I don't know where you are - but I hope everything is okay for you!) old 10.13.6 usb setup thumb drive and at least it got me a grey screen plus mouse. :roll2: But the mouse also disappears if you dare to click somewhere at the top screen. yikes
BIOS video memory setting of 64MB or more is required.
The default is 32MB.
32MB repeats the reboot.
There is nothing else I can think of.
 
Joined
Aug 1, 2016
Messages
184
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
BIOS video memory setting of 64MB or more is required.
The default is 32MB.
32MB repeats the reboot.
There is nothing else I can think of.

Has all been taken care of. Still can't explain why (not).
Fortunately, I had a backup of 10.14.0(!). Did everything again for the umpteenth time - et voila - it worked! Followed Rehabman again to the letter and everything works like a charm - just like in the good ol' 10.13.6-days. From 10.14.0 I used combo update 10.14.6 + supplemental. Had to do each time-consuming update procedure twice but everything still works.
Any guesses why?
But thank you for your help Mitsuhiro. Very kind of you.
 
Joined
Aug 1, 2016
Messages
184
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Me again - I was thinking that I might give it another try with 10.14.6 supplemental #2. Same problem again - why is it not able to boot trough the last time? Any guesses?
 
Joined
Mar 11, 2014
Messages
26
Motherboard
HP Probook 430 G3
CPU
I5-6200U
Graphics
HD 520
Mac
  1. Mac mini
  2. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
did you use the last version of clover ?
 
Joined
Aug 1, 2016
Messages
184
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
did you use the last version of clover ?
Hi samrice, yeah, I absolutely did. Here's the final result: With the help of oldmacharu's EFI folder I finally managed to get past that garbled screen in no time! Thank you guys so much! I was worried sick about me not being able to pull it off.
 
Joined
Aug 1, 2016
Messages
184
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi guys,
I've got problems with a 470 G2. As I cannot find a specific thread for this model and Rehabman's post worked for this model as far as High Sierra is concerned. But with Mojave 10.14.6 I cannot finish the installation's final step. before the screen appears when you type in your personal details, country settings etc the grey screen stops with the mouse cursor available which disappears on the first click. thx for any help
 
Last edited:
Joined
Nov 4, 2019
Messages
44
Motherboard
Probook 450 G3
CPU
i5-6200U
Graphics
HD 520
Guys,

Can we install Catalina as the same tutorial here and should that be work with everything like Mojave? Someone have tried that? I have probook 450 and it works now on mojave like a charm but i need to update it.
 
Top