Contribute
Register

[Guide] HP Pavilion 15-AB216TX Catalina using OpenCore

Joined
May 10, 2012
Messages
162
Motherboard
Lenovo Legion Y530
CPU
Core i7-8750H
Graphics
UHD 630 + GTX 1050Ti
Mobile Phone
  1. Android
@chilledHamza Hello, I am back again with a problem. Unfortunately I wasn't able to fix battery status. Can you please check my problem reporting files.
I learnt and applied all the patches as told by you and rehabman's guide, still no success though.
Hi, I thought last time you got it working. I checked the patched SSDT-BATT.aml, nice try but you missed some key points.
  • SSDT-EC-Laptop.aml (that injects a Fake EC device) this SSDT will fail to load because of ACPI binary patch "Rename Device EC0 -> EC (Required for macOS Catalina and above possilby)" ; the thing here is you either do the binary patch/rename or inject Fake EC device, not both at same time. So, EC Reame patch is more than enough and I removed SSDT-EC-Laptop.aml
  • SSDT-BATT.aml is based on EC0 device, with EC0 -> EC Rename applied patch should be using "EC" Device name.
  • SSDT-BATT.aml contains "Device" keyword for both EC0 and ACEL devices, it should be "Scope" along with External reference to both device (compare my SSDT-BATT with yours). Device keyword will define a new EC device (will fail again as an EC device already exist in DSDT), while Scope will extend existing EC Device with new injected code/content.
  • SSDT-BATT.aml contains same name "ERAM" for EC Region, while this is fine for static ACPI patch, name should be different here with Hotpatch SSDT (I renamed mine to ERM2).
  • SSDT-BATT.aml EC Region is missing Offsets (that are present in original DSDT.aml, compare with my SSDT-BATT for better understanding and also read Reahabman's guide it explains how to deal with Offsets)

if you fix above issues, your patch will possibly work, but I compared your DSDT.aml with one from AB216TX backup and both are almost identical. So, when you fix above issues, resultant SSDT will be same/similar to mine attached in OpenCore archive.
Try attached config, battery should work now. else you can try to fix your own and use that instead.
 

Attachments

  • EFI.zip
    2.5 MB · Views: 122
Last edited:
Joined
Nov 6, 2020
Messages
16
Motherboard
HP
CPU
Intel Core i7 5500U
Graphics
Intel HD Graphics 5500 + NVIDIA GeForce 840M
@chilledHamza Hi again, I am using big sur now and it works perfectly! Just wanted to know if you have any good recommendations for supported wifi / bt card. Can I use any wifi card I find? By the way, the kext you told me to use to fix low brightness on boot didn't fix the issue :/
 
Joined
May 10, 2012
Messages
162
Motherboard
Lenovo Legion Y530
CPU
Core i7-8750H
Graphics
UHD 630 + GTX 1050Ti
Mobile Phone
  1. Android
Just wanted to know if you have any good recommendations for supported wifi / bt card.
Which Wi-Fi module is currently installed?

Cheaper option is Intel Wi-Fi (with limited speed), should be fine if you don't need high bandwidth. Most recent Intel modules are supported, you can check detailed Compatibility list along with Device Ids in Itlwm Documentation

Broadcom Modules are proffered for better speed, I currently have Dell DW-1830 (BCM943602BAED), DW-1560 is also supported with some patches. Check AirportBrcmFixup for other Supported Device Ids.
Can I use any wifi card I find?
No.
By the way, the kext you told me to use to fix low brightness on boot didn't fix the issue :/
I'm not sure about the issue, or how to fix it.
 
Joined
Dec 27, 2020
Messages
13
Motherboard
HP Pavilion 17-g072nw
CPU
Intel Core i7 5500U Broadwell-U
Graphics
Intel Core i7 5500U + NVIDIA GeForce 940M
Hi, chilledHamza,
I tried to boot Catalina using your EFI (from downloaded OC RequiredFiles).
The attempt stops quickly, the screen is below. Could you please tell me what I have wrong.
Previous booting with your clover bootloader worked very well. Unfortunately, due to the disk failure
I lost all my previous copies of Catalina Clover EFI's. Can you give me the link to your last Catalina Clover
EFI so that I couls download it again. Thank you very much - Henryk

IMG_0126.JPG
 
Joined
May 10, 2012
Messages
162
Motherboard
Lenovo Legion Y530
CPU
Core i7-8750H
Graphics
UHD 630 + GTX 1050Ti
Mobile Phone
  1. Android
Hi, chilledHamza,
I tried to boot Catalina using your EFI (from downloaded OC RequiredFiles).
The attempt stops quickly, the screen is below. Could you please tell me what I have wrong.
Previous booting with your clover bootloader worked very well. Unfortunately, due to the disk failure
I lost all my previous copies of Catalina Clover EFI's. Can you give me the link to your last Catalina Clover
EFI so that I couls download it again. Thank you very much - Henryk

View attachment 529479
I do have Clover backup somewhere, I'll attach a copy (don't forget to generate new serials and replace those in config).

OpenCore: The issue in screenshot normally happens when "AppleCpuPmCfgLock" is not enabled in config.plist (workaround for CFG-Lock BIOS setting). There are a few other reasons but CFG-Lock is most common. You can check Dortania | Kernel Issues | Stuck on [EB|#LOG:EXITBS:START] for details.

I don't have that laptop anymore so i cannot update attached EFI but it used to work fine for my laptop. There have been many updates to OpenCore and kernel extensions, and i believe attached OpenCore build is not compatible with macOS Big Sur so it needs some modifications.
 

Attachments

  • EFI.zip
    4.2 MB · Views: 15
Joined
Dec 27, 2020
Messages
13
Motherboard
HP Pavilion 17-g072nw
CPU
Intel Core i7 5500U Broadwell-U
Graphics
Intel Core i7 5500U + NVIDIA GeForce 940M
I do have Clover backup somewhere, I'll attach a copy (don't forget to generate new serials and replace those in config).

OpenCore: The issue in screenshot normally happens when "AppleCpuPmCfgLock" is not enabled in config.plist (workaround for CFG-Lock BIOS setting). There are a few other reasons but CFG-Lock is most common. You can check Dortania | Kernel Issues | Stuck on [EB|#LOG:EXITBS:START] for details.

I don't have that laptop anymore so i cannot update attached EFI but it used to work fine for my laptop. There have been many updates to OpenCore and kernel extensions, and i believe attached OpenCore build is not compatible with macOS Big Sur so it needs some modifications.

I'd like to thank you very much for the prompt reply. I have to digest your hints, so it may take some time before I get some results.
Thank you very much again,
Henryk
 
Joined
Dec 27, 2020
Messages
13
Motherboard
HP Pavilion 17-g072nw
CPU
Intel Core i7 5500U Broadwell-U
Graphics
Intel Core i7 5500U + NVIDIA GeForce 940M
I do have Clover backup somewhere, I'll attach a copy (don't forget to generate new serials and replace those in config).

OpenCore: The issue in screenshot normally happens when "AppleCpuPmCfgLock" is not enabled in config.plist (workaround for CFG-Lock BIOS setting). There are a few other reasons but CFG-Lock is most common. You can check Dortania | Kernel Issues | Stuck on [EB|#LOG:EXITBS:START] for details.

I don't have that laptop anymore so i cannot update attached EFI but it used to work fine for my laptop. There have been many updates to OpenCore and kernel extensions, and i believe attached OpenCore build is not compatible with macOS Big Sur so it needs some modifications.

Hi again,
Thank you once more for your help. I did check mentioned by you Dostania guide and after changing only two Quirks I have successfully booted Catalina (I can also boot this Catalina with Clover). Unfortunately those changes are not enough to boot Big Sur 11.5.2.
Regards,
Henryk
 
Joined
May 10, 2012
Messages
162
Motherboard
Lenovo Legion Y530
CPU
Core i7-8750H
Graphics
UHD 630 + GTX 1050Ti
Mobile Phone
  1. Android
Unfortunately those changes are not enough to boot Big Sur
Basically you need to update OpenCore and kernel Extensions to make it work with Big Sur. kernel extensions are easy, just have to replace files in Kexts folder with newer version. OpenCore is little complicated have to replace OpenCore files with newer and also modify/update config.plist according to new configuration manual (you can use ocvalidate utility to check updated config for errors).

If above instructions are too complicated then Share your OpenCore EFI (or the quirks that worked for you), and i'll try to update it for macOS Big Sur.
 
Joined
Dec 27, 2020
Messages
13
Motherboard
HP Pavilion 17-g072nw
CPU
Intel Core i7 5500U Broadwell-U
Graphics
Intel Core i7 5500U + NVIDIA GeForce 940M
Basically you need to update OpenCore and kernel Extensions to make it work with Big Sur. kernel extensions are easy, just have to replace files in Kexts folder with newer version. OpenCore is little complicated have to replace OpenCore files with newer and also modify/update config.plist according to new configuration manual (you can use ocvalidate utility to check updated config for errors).

If above instructions are too complicated then Share your OpenCore EFI (or the quirks that worked for you), and i'll try to update it for macOS Big Sur.
Below I enclose the corrected EFI which works fine with Catalina but when booting Big Sur it stops at exactly the same error: Stuck on [EB|#LOG:EXITBS:START] despite the applied corrections.
I would be extremely grateful if you could try to update this EFI for macOS Big Sur.
Anyway, I will try to learn OC more and try to do it myself, although at the moment it looks a little bit intimidating.
Thank you very much for all your help.
Regards,
Henryk
 

Attachments

  • Changes_in_Config_plist.zip
    1.7 KB · Views: 12
  • EFI_corrected.zip
    2.6 MB · Views: 13
Joined
Dec 27, 2020
Messages
13
Motherboard
HP Pavilion 17-g072nw
CPU
Intel Core i7 5500U Broadwell-U
Graphics
Intel Core i7 5500U + NVIDIA GeForce 940M
chilledHamza said:
Basically you need to update OpenCore and kernel Extensions to make it work with Big Sur. kernel extensions are easy, just have to replace files in Kexts folder with newer version. OpenCore is little complicated have to replace OpenCore files with newer and also modify/update config.plist according to new configuration manual (you can use ocvalidate utility to check updated config for errors).

If above instructions are too complicated then Share your OpenCore EFI (or the quirks that worked for you), and i'll try to update it for macOS Big Sur.


Hello again, I have made a new EFI using OC 0.7.4. For ACPI I made essential SSDT's by SSDTTime and also I loaded the most recent kexts + I modified the necessary Quirks to correct the problems with EC lock.
The booting process of Big Sur starts but unfortunately after a number of steps stops due to a panic. I must have missed something important. Could you find a spare minute to look at the enclosed dump of the screen and my EFI directory. Thank you very much for any help, hints and suggestions. Regards, Henryk
 

Attachments

  • EFI.zip
    6.7 MB · Views: 11
  • OC074BigSur_Booting.jpg.zip
    115.7 KB · Views: 14
Top