Contribute
Register

[Guide] HP Envy Haswell series J/K using Clover UEFI

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I had just appended on the post above.. let me reattach,

Code:
$ kextstat|grep -y acpiplat
   13    2 0xffffff7f82c51000 0x66000    0x66000    com.apple.driver.AppleACPIPlatform (4.0) 295F7A91-2DF7-3FFE-9550-A0C1A6F9D575 <12 11 7 6 5 4 3 1>
$ kextstat|grep -y appleintelcpu
You neglected to update your config.plist to the latest in the repo.
 
Joined
Oct 10, 2012
Messages
57
Motherboard
HP Envy 15-J (Clover)
CPU
i7 4700MQ/HM87
Graphics
HD 4600, 1366x768
You neglected to update your config.plist to the latest in the repo.
The new config list applehda injectors worked....Thanks
 
Joined
Oct 10, 2012
Messages
57
Motherboard
HP Envy 15-J (Clover)
CPU
i7 4700MQ/HM87
Graphics
HD 4600, 1366x768
Bluetooth not available after wake from sleep...
I've attached the files
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Bluetooth not available after wake from sleep...
I've attached the files
According to the ioreg you provided, bluetooth is working.

But you did not follow the guide:
- ACPI is not patched correctly
- power management is not implemented correctly
- SMBIOS is wrong

Follow post #1 as written.
 
Joined
Oct 10, 2012
Messages
57
Motherboard
HP Envy 15-J (Clover)
CPU
i7 4700MQ/HM87
Graphics
HD 4600, 1366x768
According to the ioreg you provided, bluetooth is working.

But you did not follow the guide:
- ACPI is not patched correctly
- power management is not implemented correctly
- SMBIOS is wrong

Follow post #1 as written.
I've noticed that its working....its only in the icon in the menu bar that shows its not available....if i go to system preferences and uncheck 'show bluetooth in menu bar' then check it it appears okay....otherwise its still working
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I've noticed that its working....its only in the icon in the menu bar that shows its not available....if i go to system preferences and uncheck 'show bluetooth in menu bar' then check it it appears okay....otherwise its still working
Follow post #1 as written. Report back.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Please note future discussion for 10.11 should happen at the 10.11 guide (linked by post #1).

This thread should be used only if you're running 10.10.
 
Joined
Apr 8, 2012
Messages
44
Motherboard
HP Envy 15j-104sl - Clover
CPU
i7-4700MQ
Graphics
HD4600
Hi Rehabman,
I am checking in whether this is a known issue or not. I'm on Mavericks and my audio jack hotplug is not working. If I start without a jack plugged in, plugging one in when the system is up does not trigger the output. If I start with a jack plugged in, conversely, I get audio through the jack but unplugging it does not kick in the speakers (need another reboot). Had this problem forever, but if there's a fix it's good to know.
Also, any news about the new implementations for the trackpad you were referring to? (I mean the delayed tracking on touch to avoid accidental pointer motion on click).
Thank you as always, the system is still rock solid after a year of intense use and programs installs/uninstalls. Way more stable than windows 10 (which should be native, haha)
 
Top