Contribute
Register

[Guide] HP Envy Haswell series J/K/Q/N using Clover UEFI

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hai Rehabman.

is Posible to jump to Mojave without install High Sierra?
im from macOS sierra now.

Yes.
System updates are covered in post #1.
 
Joined
Jul 25, 2018
Messages
2
Motherboard
HP Envy 15-k019nr
CPU
i7-4510U
Graphics
HD 4400
Hi RehabMan!

I've been using your patch for about 3 months now and I've noticed that my laptop would sometimes completely hang when going to sleep, i.e. it would just stay on with a turned off screen until you hold the power button.

After playing around with config.plist flags I've come to a conclusion that this is happening due to the FixRTC flag being set to true. Removing it seems to have fixed this issue on multiple OS reinstalls and everything seems to work well without it. I'd like to suggest removing this flag from your repository unless it does something else that I'm not aware of.
 
Joined
Jun 4, 2015
Messages
58
Motherboard
HP Envy 15-k111nl (Clover)
CPU
Inte Core i7 - 4510U
Graphics
Intel HD 4400 (2 Ghz, 4MB cache, 2 core) / NVIDIA GTX 850M 4GB / 1920x1080
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Hi RehabMan!

I've been using your patch for about 3 months now and I've noticed that my laptop would sometimes completely hang when going to sleep, i.e. it would just stay on with a turned off screen until you hold the power button.

After playing around with config.plist flags I've come to a conclusion that this is happening due to the FixRTC flag being set to true. Removing it seems to have fixed this issue on multiple OS reinstalls and everything seems to work well without it. I'd like to suggest removing this flag from your repository unless it does something else that I'm not aware of.

Have you encountered this issue also on shutdowns? This happens also on latest Windows 10 versions?

I had the same exact issue on two different HP Envy k111nl models with macOS and windows 10 both affected and fixed both updating BIOS and IMEI to latest versions.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi RehabMan!

I've been using your patch for about 3 months now and I've noticed that my laptop would sometimes completely hang when going to sleep, i.e. it would just stay on with a turned off screen until you hold the power button.

After playing around with config.plist flags I've come to a conclusion that this is happening due to the FixRTC flag being set to true. Removing it seems to have fixed this issue on multiple OS reinstalls and everything seems to work well without it. I'd like to suggest removing this flag from your repository unless it does something else that I'm not aware of.

Your profile is not filled out correctly, therefore no idea which Envy you have...
Please fix as per FAQ:
https://www.tonymacx86.com/threads/...m-reporting-files.235953/page-29#post-1862814

You should also check that your BIOS is the latest.
 
Joined
Jul 25, 2018
Messages
2
Motherboard
HP Envy 15-k019nr
CPU
i7-4510U
Graphics
HD 4400
Have you encountered this issue also on shutdowns? This happens also on latest Windows 10 versions?

I had the same exact issue on two different HP Envy k111nl models with macOS and windows 10 both affected and fixed both updating BIOS and IMEI to latest versions.
No, I haven't, and I have no issues with Windows 10 either.

Your profile is not filled out correctly, therefore no idea which Envy you have...
Please fix as per FAQ:
https://www.tonymacx86.com/threads/...m-reporting-files.235953/page-29#post-1862814

You should also check that your BIOS is the latest.
Right, sorry about that, added laptop model as per FAQ.

I updated the BIOS to F.56 and I don't seem to have this issue anymore. I'll let you know if it comes up again, along with problem report files. Thanks!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I updated the BIOS to F.56 and I don't seem to have this issue anymore. I'll let you know if it comes up again, along with problem report files. Thanks!

OK.
 
Joined
Oct 8, 2018
Messages
2
Motherboard
HP Envy 15T-J000
CPU
i7-4700MQ/HM87
Graphics
HD 4600, 1920x1080
Hello, i can't active my integrated wifi card net. the bluetooth works with same buttom. but bluetooth works. wifi card: wireless-N 2230 model: 2230BNHMW i dont know if this model of card is compatible or if i need do something more to activate it. actually i use a wifi usb adapter and i boot my laptop from clover usb. test1: i copyed FakePCIID_Broadcom_WiFi.kext inside clover usb: clover/kexts/others (but nothing) test 2: i installed same kext inside: /Library/Extensions/ (but nothing) Someone can help me please. thank you very much.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,853
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello, i can't active my integrated wifi card net. the bluetooth works with same buttom. but bluetooth works. wifi card: wireless-N 2230 model: 2230BNHMW i dont know if this model of card is compatible or if i need do something more to activate it. actually i use a wifi usb adapter and i boot my laptop from clover usb. test1: i copyed FakePCIID_Broadcom_WiFi.kext inside clover usb: clover/kexts/others (but nothing) test 2: i installed same kext inside: /Library/Extensions/ (but nothing) Someone can help me please. thank you very much.
the faq has a list of compatible cards:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Jan 30, 2019
Messages
9
Motherboard
HP Envy 15 2014
CPU
i7
Graphics
HD 4600 + GTX 850m
Hi Rehabman
I am new to Hackintosh, and I just installed Mojave into my HP Envy 15 q010tx, and I followed all your instructions and everything works just fine as the document described.
But my audio part doesn't work and nothing shows in the system prep/audio with our any audio in/out device.
Could you please help me to solved this problem?

Benny
New Hackintoshian
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi Rehabman
I am new to Hackintosh, and I just installed Mojave into my HP Envy 15 q010tx, and I followed all your instructions and everything works just fine as the document described.
But my audio part doesn't work and nothing shows in the system prep/audio with our any audio in/out device.
Could you please help me to solved this problem?

Benny
New Hackintoshian

Read post #1, "Problem Reporting".
 
Top