Contribute
Register

[Guide] HP Envy Haswell series J/K/Q/N using Clover UEFI

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
its an hp envy 15 j100ns but i can't attach any files because i can't boot it

"Problem Reporting" instructions are very clear regarding the files required in the case you can't boot.
Read it carefully.
 
Joined
May 20, 2016
Messages
55
CPU
i5-4340M
Graphics
HD 4600/GTX840M
No idea.
As mentioned in post #1, I don't have this laptop anymore.
But all applicable changes that I know about have been made in the github.
Thank you. I will try to update this weekend. Hope that it work well :)
 
Joined
Jun 5, 2014
Messages
75
Motherboard
Plex HD79
CPU
xeon e5-2689
Graphics
Radeon RX 570 4GB
Mobile Phone
  1. Android
  2. iOS
okay, my problem was fixed by adding the apfs.efi file :rolleyes:

But one more question. How can I install windows 10 with macOS high sierra already installed?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
thanks man!!! you're the best, one more thing hehe

is it possible to use the subwoffer of the speaker?? if its, how?

There are reports of using VoodooHDA and a composite audio device (SoundFlower), but then you lose native volume controls.
 
Joined
Aug 19, 2017
Messages
7
Motherboard
HP Envy 15-j007eo - Clover
CPU
i7-4702MQ
Graphics
HD4600 - 1920x1080
@RehabMan Congratulations for the awesome work!

My computer is working flawlessly after following each step and considerations of your tutorial.

Thank you!
 
Joined
Aug 8, 2014
Messages
55
Motherboard
HP Omen 15-ax250wm
CPU
i7-7700HQ/HM175
Graphics
HD 630+GTX 1050 Ti (1920x1080)
Mobile Phone
  1. Android
Just wanted to confirm that I have been able to upgrade to High Sierra on my Envy Q.
Everything works as expected, even after the supplemental update.

There was no audio after upgrade and I wasn't able to find the option to boot without caches in Clover's spacebar menu (I think it's specific to the new versions of Clover). I rebuilt cache anyway (using the terminal) and rebooted, I then fidgeted with the output volume slider in System Preferences/Audio until sound came back. I did not experience subsequent issues of this nature.

I did not upgrade using the new file system (APFS), so I can't report if there are any issues there might be using it.

Notes on the supplemental High Sierra update:
  • After downloading from AppStore and initially reboot, I had to select a new entry in Clover (Install macOS from...) before the update could start. Booting back into the original macOS boot drive skips the update.
  • After the update, I had to reinstall my kexts by running install_downloads.sh (just like the steps for a major update in the guide).
  • Make sure to disable hibernation as detailed in the guide. Good luck

Much thanks to RehabMan.
 
Joined
Jan 4, 2017
Messages
6
Motherboard
HP ENVY 15 j150nr [CLOVER EFI]
CPU
Core i7 4700MQ
Graphics
Intel HD Graphics 4600 / NVIDIA GeForce GTX 850M (1920x1080)
Mobile Phone
  1. Android
Boot from USB with success, but my HDD not showing in Disk Utility
Putting SATA-100-series-unsupported.kext or SATA-200-series-unsupported.kext.zip to /EFI/Clover/kexts/Other didn't help.

Upd: [SOLVED] My solution is to use kexts finded on reddit
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Status
Not open for further replies.
Top