Contribute
Register

[Guide] HP Elite X2 1012 G1 / G2, Clover UEFI, VirtualSMC, Hot Patch

Joined
May 12, 2019
Messages
40
Motherboard
ThinkPad T530
CPU
M3 6Y30
Graphics
HD 515
Mac
MacBook, MacBook Air, MacBook Pro
Classic Mac
Apple, iMac, Performa, Power Mac
Mobile Phone
Android, Other
So I managed to get everything to install and boot. I installed all of the kexts in L/E and the touchscreen works. What does not work and need help with getting fixed.

IGPU doesnt work right. Shows I have 9 MB of VRAM
Sound doesnt work/show up. Even after kext install
Every time I use Clover Config and change it to the right MacBook. It KPs on boot.

I will upload my clover folder and will film a video if needed.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,546
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
So I managed to get everything to install and boot. I installed all of the kexts in L/E and the touchscreen works. What does not work and need help with getting fixed.

IGPU doesnt work right. Shows I have 9 MB of VRAM
Sound doesnt work/show up. Even after kext install
Every time I use Clover Config and change it to the right MacBook. It KPs on boot.

I will upload my clover folder and will film a video if needed.
As per rules, please update your hardware profile to allow others to help you easier

please read the faq for proper hardware profile setup:
 
Joined
Dec 3, 2011
Messages
439
Motherboard
HP Elite X2
CPU
i5-7600U
Graphics
HD 620 2736 x 1834
Mac
MacBook Pro, Mac Pro
Classic Mac
128K, 512K
Mobile Phone
iOS
So I managed to get everything to install and boot. I installed all of the kexts in L/E and the touchscreen works. What does not work and need help with getting fixed.

IGPU doesnt work right. Shows I have 9 MB of VRAM
Sound doesnt work/show up. Even after kext install
Every time I use Clover Config and change it to the right MacBook. It KPs on boot.

I will upload my clover folder and will film a video if needed.
Yeah, upload the clover folder that you're booting with. The sound is an easy fix, the attached config.plist is set up for the G2 and the inject audio flag under the 'Devices' section is set to 21, change it to 3.
 
Joined
May 12, 2019
Messages
40
Motherboard
ThinkPad T530
CPU
M3 6Y30
Graphics
HD 515
Mac
MacBook, MacBook Air, MacBook Pro
Classic Mac
Apple, iMac, Performa, Power Mac
Mobile Phone
Android, Other
Yeah, upload the clover folder that you're booting with. The sound is an easy fix, the attached config.plist is set up for the G2 and the inject audio flag under the 'Devices' section is set to 21, change it to 3.

Hahaha, I got everything working after hours of research. I learned the 9,1 SMBIOS will KP the system. I had to use the 10,1 SMBIOS. I also changed and fixed all of the IGPU and the audio!

I am using a USB wifi card. I cant seem to get iMessage and FaceTime working. Unless Im missing something.
 
Joined
Dec 3, 2011
Messages
439
Motherboard
HP Elite X2
CPU
i5-7600U
Graphics
HD 620 2736 x 1834
Mac
MacBook Pro, Mac Pro
Classic Mac
128K, 512K
Mobile Phone
iOS
Hahaha, I got everything working after hours of research. I learned the 9,1 SMBIOS will KP the system. I had to use the 10,1 SMBIOS. I also changed and fixed all of the IGPU and the audio!

I am using a USB wifi card. I cant seem to get iMessage and FaceTime working. Unless Im missing something.
That's very strange, I used the MacBook9,1 SMBIOS when I had the G1, it's skylake core M. Anyway, none of that will work with a USB wifi card. The problem is you are not getting a network device on en0. You can try the null ethernet kext from Rehabman's github repo tho.
 
Joined
May 12, 2019
Messages
40
Motherboard
ThinkPad T530
CPU
M3 6Y30
Graphics
HD 515
Mac
MacBook, MacBook Air, MacBook Pro
Classic Mac
Apple, iMac, Performa, Power Mac
Mobile Phone
Android, Other
That's very strange, I used the MacBook9,1 SMBIOS when I had the G1, it's skylake core M. Anyway, none of that will work with a USB wifi card. The problem is you are not getting a network device on en0. You can try the null ethernet kext from Rehabman's github repo tho.

I have downloaded it but I havent found a useable guide for installing the kext and setting everything up.

I installed the kext with Kext Utility. I found a guide on how to get it working but I followed it and ran into a error wall. I used MaciASL and I added the patch.txt and got errors that wouldn't let me compile it together.

EDIT: I found a guide on RehabMan's github.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,546
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I have downloaded it but I havent found a useable guide for installing the kext and setting everything up.

I installed the kext with Kext Utility. I found a guide on how to get it working but I followed it and ran into a error wall. I used MaciASL and I added the patch.txt and got errors that wouldn't let me compile it together.

EDIT: I found a guide on RehabMan's github.
As per rules, please update your hardware profile to allow others to help you easier

please read the faq for proper hardware profile setup:
 
Joined
Dec 3, 2011
Messages
439
Motherboard
HP Elite X2
CPU
i5-7600U
Graphics
HD 620 2736 x 1834
Mac
MacBook Pro, Mac Pro
Classic Mac
128K, 512K
Mobile Phone
iOS
As per rules, please update your hardware profile to allow others to help you easier

please read the faq for proper hardware profile setup:
His details were in his profile yesterday, and then disappeared today. Although if I had to guess, you deleted them for not being in the right places.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,546
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
His details were in his profile yesterday, and then disappeared today. Although if I had to guess, you deleted them for not being in the right places.
i'm just a moderator, I have no power in removing hardware profiles.
 
Joined
Dec 3, 2011
Messages
439
Motherboard
HP Elite X2
CPU
i5-7600U
Graphics
HD 620 2736 x 1834
Mac
MacBook Pro, Mac Pro
Classic Mac
128K, 512K
Mobile Phone
iOS
i'm just a moderator, I have no power in removing hardware profiles.
Fair enough, but somebody deleted the reply in which he explained that he had set his profile but it kept disappearing. I can verify that he did because I saw it yesterday. Now his messages are deleted and he's suspended. Rules are rules, etc, fine, but he explained that there was a problem occurring. And AFAIK he wasn't looking for help in the main support section where someone might not know anything about his device, he was seeking it here and I don't need that info to know how to help him. Not to mention that he already demonstrated the will to find/research solutions on his own. I've been in the hackintosh scene for the better part of 12 years, and this is one of the only places where I see beginners dealt with in this fashion instead of some patience and an attempt to bring them into the fold of the hobby. </highhorse>
 
Top