Contribute
Register

[Guide] HP Elite X2 1012 G1 / G2, Clover UEFI, VirtualSMC, Hot Patch

Joined
Jan 3, 2017
Messages
9
Motherboard
HP Elite X2 1012
CPU
Skylake M3
Graphics
Intel HD 515
Ive tried to use your EFI and it boot into the installer and all of that all fine. When I try and boot into the OS after the final installs stuff it gets stuck at an issue about something GPU related. I did add some kexts to get the keyboard working.

Exact same issue
 
Joined
Aug 19, 2011
Messages
19
Motherboard
HP X2 1012 G2
CPU
i5-7200U
Graphics
Intel HD 620
The problem in BIOS 1.32 - with it you can't boot you MacOS :( I've rolled back to 1.31, then reinstalled 10.15.2 and now it is ok with Clover 5058
Do you have old bios for G2 model? I just update mine to 1.45 and everything stopped working. thanks.
 
Joined
Sep 14, 2020
Messages
3
Motherboard
X2 1012 G1
CPU
M5-6Y57
Graphics
515
Hello, I newly purchased X2 1012 G1, the computer configuration is as follows:

CPU: M5-6Y57

Graphics: Intel HD Graphics 515

Memory: 8G

Solid State Drive: SanDisk 256G

wifi card: DW1560

BIOS: 01.49 Rev.A

I plan to install macOS Mojave 10.14.6 18G103, can you share your EFI? Thanks
 
Joined
Sep 14, 2020
Messages
3
Motherboard
X2 1012 G1
CPU
M5-6Y57
Graphics
515
Hi. Thank you for your guidance and the attachments files given. I had successfully done fresh install Mojave to my newly refurbished HP Elite G1 by made some changes in the config.plist regarding to display card to be suit to G1. I had format SSD. Everything ok and i can boot from internal storage which has single macOS. After i made windows installation in additional partition, I cant't boot to macos from clover internal ssd. It always quit/reset half-way after macos was selected. But if i'm using usb drive to boot clover and select the installed mac it will run perfect as usual.

Could you please assist me and thanks in advance.

Regards
Hello, I newly purchased X2 1012 G1
I plan to install macOS Mojave 10.14.6 18G103, can you share your EFI? Thanks
 
Joined
Sep 14, 2020
Messages
3
Motherboard
X2 1012 G1
CPU
M5-6Y57
Graphics
515
Hi, Thanks again, I did reinstall everything, do not go for 10.15.4, I did upgrade to 10.14.6, everything is fine, all function is working. I still think 10.14 still the best OS for this table!
[/引用]

Hello, I newly purchased X2 1012 G1, the computer configuration is as follows:

CPU: M5-6Y57

Graphics: Intel HD Graphics 515

Memory: 8G

Solid State Drive: SanDisk 256G

wifi card: DW1560

BIOS: 01.49 Rev.A

I plan to install macOS Mojave 10.14.6 18G103, can you share your EFI? Thanks

Is it because of the BIOS version update (1.49), the EFI installation I use here always crashes in the last 2 minutes
 
Joined
Jan 31, 2011
Messages
11
Motherboard
Clevo NL40CU
CPU
i7-10510U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi @jhax01 , Thank you very much for your efforts. I have a hp X2 1012 G1. I've adapted your Clover EFI configuration to Opencore. Everything works except the touchscreen and trackpad (trackpad simple movements works but no multi touch).
Can something be done to solve this? I attached the Efi file. Thank you very much.
 

Attachments

  • X2_1012G1_EFI.zip
    21.2 MB · Views: 53
Joined
Jul 7, 2020
Messages
4
Motherboard
hp elite x2 1012 g1
CPU
m7
Graphics
intel 515
Hi @jhax01 , Thank you very much for your efforts. I have a hp X2 1012 G1. I've adapted your Clover EFI configuration to Opencore. Everything works except the touchscreen and trackpad (trackpad simple movements works but no multi touch).
Can something be done to solve this? I attached the Efi file. Thank you very much.
I will try to do something tomorrow, ok?) It's not a big deal to fix touchscreen)
 
Joined
Oct 1, 2012
Messages
40
Motherboard
Gigabyte EP45-UD3R
CPU
QX9775
Graphics
HD5770
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
Hi @jhax01 , Thank you very much for your efforts. I have a hp X2 1012 G1. I've adapted your Clover EFI configuration to Opencore. Everything works except the touchscreen and trackpad (trackpad simple movements works but no multi touch).
Can something be done to solve this? I attached the Efi file. Thank you very much.


My 1012G1 couldn't boot in your EFI.

The touch panel of my EFI works.
There is also a sound.
WIFI is not possible
USB LAN works.
Siri is not possible.
I'm still experimenting and there are other problems, but I hope it helps.
 

Attachments

  • EFI 1012G1 OC60 BigSur .zip
    6.3 MB · Views: 26
Top