Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

Joined
Nov 2, 2018
Messages
278
Motherboard
HP 8300, MacMini6,1
CPU
i5-3570K, i5-3470, i5-3210, G5
Graphics
RX570, RX560, GT730K, HD4000
Mac
  1. Mac mini
Classic Mac
  1. Power Mac
@LisaAlterEgo Amazing.
Thank you for all of that work.

So in short words:
1. Shikigva=144 is the one we should use for DGPU users as the default one whether it is MacPro6,1 or iMacPro1,1.
Am i correct ?

2. Big Sur still broken, no perfect solution, right ?

3. What about IGPU users only, what do you suggest as the best option ?

4. Do you have a Github account ?
1. shikigva=144 for AMD, 256+32+shiki-id for Nvidia
2. AppleTV on Big Sur will only first download, then play m4v video, no HLS
3. I haven't tested IGPU only
4. No
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
1. shikigva=144 for AMD, 256+32+shiki-id for Nvidia
2. AppleTV on Big Sur will only first download, then play m4v video, no HLS
3. I haven't tested IGPU only
4. No
Thanks,

  • Will add the notes regarding DRM content on the Readme.
  • Will test the IGPU and see if i can manage to make it work.
 
Joined
May 25, 2020
Messages
2
Motherboard
HP800 G1 Big Sur 11.0.1
CPU
I3 4130
Graphics
Intel HD 4400
iGPU only i3-3225 with SMBIOS iMAC 14.4 has full VDA Decoder
 
Joined
Feb 1, 2011
Messages
99
Motherboard
8300 SFF iMac15,1
CPU
3.4 GHz Quad-Core Intel Core i7
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. iOS
Big Sur (Some issues I noticed)
*ODD - Bluetooth no longer connects or see my Soundbar and original Airpod (1st). I had to add my airpods to my phone and now it shows up as a option to connect.

-Rebooting fails - It goes through the process, kills everything but power stays on. Have to hit button to turn off.
-Applewatch unlock worked the first and only time.
-Music cant connect to cloud music - is this DRM related?

These are some of the issues im experiencing using the beta sniki has on git.
 
Joined
Nov 27, 2016
Messages
155
Motherboard
HP 8300 Q77
CPU
i5-3570
Graphics
GT710
Mac
  1. iMac
Mobile Phone
  1. Android
In a totally unrelated note, I have a question about my 8300 SFF. This morning when it woke from sleep it was extremely loud. Clearly a mechanical noise. It almost sounded like an unbalanced optical disk, but there was no disk in the drive. I restarted and the noise went away.

This is the second time this has happened (in about 3 years, so quite rare.) I opened the case to figure out where the noise was coming from, and my best guess is the power supply fan. I don't think it was the front fan or the optical drive. Anyone have any other suggestions for things to look at? No HDDs in the case, just SSDs.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,515
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
It almost sounded like an unbalanced optical disk, but there was no disk in the drive. I restarted and the noise went away.
Try disconnecting all the fans one by one till you have nothing left connected but the PSU fan. Start it up each time to see if you can recreate the noise again. In isolation you can tell how noisy that PSU fan is. Even the CPU fan can be disconnected short term. It won't do any harm.

I would also consider having a good backup PSU on hand if you ever need it. They are dirt cheap on Ebay so have a backup around in case you need it at some point. Getting one labeled HF or High Efficiency is best.

Screen Shot 4.jpg


 
Last edited:
D

Deleted member 2151140

Guest
@LisaAlterEgo

Shikivga=144 seems to work, Sky Go App and Amazon in Firefox are running SMBIOS MacPro6,1 - CPU I5-3570 Internal Grafic deactivated - AMD WX 4100

SSDT.aml had to be generated ( 17.1 not Beta ) on Catalina, with option -b to Select MacPro6,1 and runs now on BigSur / Catalina with full 3,8 GHZ and down to 1,6 to.
No luck to generate it on BigSur, did not Boot with ACPI - Delete - True 0 and 1.

Have now one EFI OC 0.6.3 for Both Systems ( Catalina / BigSur )

Do not forget to Pick ClearNVRAM on first Boot ! Maybe To Restart also after the First Boot Try, had that....
But then runs through.

Option to CTRL Enter making a default Boot Entry while in Picker.

Boot arg is -v Shikivga=144 also

Only for dGPU

Base OC is the Sniki Version.

Generate New Serial to Config.plist in EFI with GenSMBIOS-master MacPro6,1

@Sniki

SSDT.aml for I5-3570 can be providet in your Distro if wanted, and correct.....
 

Attachments

  • ssdt.aml.zip
    1.1 KB · Views: 18
  • Bildschirmfoto 2020-11-25 um 22.46.51.jpg
    Bildschirmfoto 2020-11-25 um 22.46.51.jpg
    57.3 KB · Views: 27
  • GenSMBIOS-master.zip
    22.8 KB · Views: 14
  • EFI-BigSur-CatalinaMacPro6,1-OC063-SSDT-EFI.zip
    58.1 MB · Views: 21
  • Bildschirmfoto 2020-11-25 um 23.17.09.jpg
    Bildschirmfoto 2020-11-25 um 23.17.09.jpg
    72.9 KB · Views: 26
Last edited by a moderator:

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Big Sur (Some issues I noticed)
*ODD - Bluetooth no longer connects or see my Soundbar and original Airpod (1st). I had to add my airpods to my phone and now it shows up as a option to connect.

-Rebooting fails - It goes through the process, kills everything but power stays on. Have to hit button to turn off.
-Applewatch unlock worked the first and only time.
-Music cant connect to cloud music - is this DRM related?

These are some of the issues im experiencing using the beta sniki has on git.
Depends on the Wireless and Bluetooth card that you have/use. Which one do you have ?

No issues with rebooting, i have this EFI on my 8300 SFF and never had rebooting issues.

Weird.
In a totally unrelated note, I have a question about my 8300 SFF. This morning when it woke from sleep it was extremely loud. Clearly a mechanical noise. It almost sounded like an unbalanced optical disk, but there was no disk in the drive. I restarted and the noise went away.

This is the second time this has happened (in about 3 years, so quite rare.) I opened the case to figure out where the noise was coming from, and my best guess is the power supply fan. I don't think it was the front fan or the optical drive. Anyone have any other suggestions for things to look at? No HDDs in the case, just SSDs.
Happened to me once only (last year), but never repeated, no clue but since it's so rare, i wouldn't worry much about that.
@LisaAlterEgo

Shikivga=144 seems to work, Sky Go App and Amazon in Firefox are running SMBIOS MacPro6,1 - CPU I5-3570 Internal Grafic deactivated - AMD WX 4100

SSDT.aml had to be generated ( 17.1 not Beta ) on Catalina, with option -b to Select MacPro6,1 and runs now on BigSur / Catalina with full 3,8 GHZ and down to 1,6 to.
No luck to generate it on BigSur, did not Boot with ACPI - Delete - True 0 and 1.

Have now one EFI OC 0.6.3 for Both Systems ( Catalina / BigSur )

Do not forget to Pick ClearNVRAM on first Boot ! Maybe To Restart also after the First Boot Try, had that....
But then runs through.

Option to CTRL Enter making a default Boot Entry while in Picker.

Boot arg is -v Shikivga=144 also

Only for dGPU

Base OC is the Sniki Version.

@Sniki

SSDT.aml for I5-3570 can be providet in your Distro if wanted, and correct.....
Thanks,

I will make a collection of Power Management SSDTs and upload them on the repository so when a user wants to install, he/she can simply grab the correct one for his/her CPU and have no trouble to go generate one.

Makes life much easier for new users.
 
Joined
Dec 2, 2019
Messages
60
Motherboard
HP Elite 8300 SFF, HD2500 Graphics
CPU
i5-3470
Graphics
GT 710
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Depends on the Wireless and Bluetooth card that you have/use. Which one do you have ?

No issues with rebooting, i have this EFI on my 8300 SFF and never had rebooting issues.

Weird.

Happened to me once only (last year), but never repeated, no clue but since it's so rare, i wouldn't worry much about that.

Thanks,

I will make a collection of Power Management SSDTs and upload them on the repository so when a user wants to install, he/she can simply grab the correct one for his/her CPU and have no trouble to go generate one.

Makes life much easier for new users.
Please include/mention any changes needed for i5-3470 with HD2500 internal (Nvidia Gt710 external). Thanks.
 
D

Deleted member 2151140

Guest
@Sniki

ssdt.aml - that's what I thought, cause I endet waiting while installing USB Stick to New SSD Fresh Install the Prozessor runs at 1,1GHZ.

I Upgraded my System Complete to BigSur, after I figured out the ssdt.aml thing, ( changed name in config from SSDT.aml to ssdt.aml (attached file) Upgrade from Catalina was very fast....)
Works Perfect Now, as Catalina did ;-)

Pretty fast and Responsy, no Flaws so far

thanx again to all of your help, and the shikivga=144 ;-)


But, the SSDT-EC-Desktop.aml from the OC Guide in the Ivy Section to Download wors as well, there are more CPU´s inside from the Ivy Series....
 

Attachments

  • SSDT-EC-DESKTOP.aml
    6.3 KB · Views: 14
  • Fixing Embedded Controllers- Prebuilt.pdf
    36.1 KB · Views: 15
  • Bildschirmfoto 2020-11-25 um 22.46.51.jpg
    Bildschirmfoto 2020-11-25 um 22.46.51.jpg
    57.3 KB · Views: 27
  • Bildschirmfoto 2020-11-25 um 23.17.09.jpg
    Bildschirmfoto 2020-11-25 um 23.17.09.jpg
    72.9 KB · Views: 26
  • ssdt.aml
    1.8 KB · Views: 12
Last edited by a moderator:
Top