Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

Joined
Mar 7, 2014
Messages
4
Motherboard
HP 657094-001
CPU
i7 3770
Graphics
RX560
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi LisaAlterEgo,

I have the similar hardware like @MasterAmp and I'm also stuck on upgrading Big Sur from 10.15.7. I just can't boot to the MacOS Installer. The interesting part is there is no kernel panic and the apple logo shows, that means the graphics driver works well. But soon the logo and progress bar disappears and messages begin to show on screen:

AppleActuatorDeviceUserClient::stop entered

Then it enters into 'shutdown' process somehow.

I've captured serial logs but I can't figure out the root cause from them.

Mon Nov 16 05:51:10 2020 iMac.local com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.storagekitd.210) <Error>: Failed to bootstrap path: path = /System/Library/PrivateFrameworks/InstallerDiagnostics.framework/Versions/A/InstallerDiagnostics, error = 2: No such file or directory
Mon Nov 16 05:51:10 2020 iMac.local com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.storagekitd.210) <Error>: Failed to bootstrap path: path = /System/Library/PrivateFrameworks/DataDetectorsCore.framework/Versions/A/DataDetectorsCore, error = 2: No such file or directory
Mon Nov 16 05:51:10 2020 iMac.local com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.storagekitd.210) <Error>: Failed to bootstrap path: path = /System/Library/Frameworks/MediaToolbox.framework/Versions/A/MediaToolbox, error = 2: No such file or directory
RTC: setGMTTimeOfDay 1605505871
Kext loading now disabled.
Mon Nov 16 05:51:13 2020 HPE8300SFF.lan com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.system) <Notice>: System shutdown initiated by: shutdown.216<-macOS Update As.208<-Language Choose.190<-recoveryos_agen.186<-launchd.1
Mon Nov 16 05:51:13 2020 HPE8300SFF.lan com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.system) <Notice>: committing to system shutdown
Kext unloading now disabled.
Kext autounloading now disabled.
Kernel requests now disabled.
ASP: System is shutting down, preventing further ASP upcalls
ASP: ASP: shutting down, drained

Any comments about what I should do next? I'm using OC0.6.3 and all drivers and kexts are updated. And the SMBIOS is iMac17,1. I've also tried MacPro6,1, but the result was same.

Thank you very much.

@MasterAmp I think you could try out my configurations, which may give you some hint then.
 

Attachments

  • config.plist
    27.5 KB · Views: 13
  • DSDT.aml
    43.3 KB · Views: 11
Joined
Mar 16, 2015
Messages
340
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
  1. MacBook Air
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. Quadra
  3. SE/30
Any comments about what I should do next? I'm using OC0.6.3 and all drivers and kexts are updated. And the SMBIOS is iMac17,1. I've also tried MacPro6,1, but the result was same.
Do not use the sample as it is.

It seems that it was possible to install with the attached file here.
Try SMBIOS with MacPro6.1 or iMacPro1.1.
 
D

Deleted member 2151140

Guest
@alohacn

thanx for your config, reminds me to get lilu ;-)

did i over read that ?

so makes no difference wether i take your .plist, or my with that, as you mentioned, boots into grafics, and shows:

grey
then apple logo on black, short mouse blink, then mouse pointer gone progress bar on and is stucking there.......

i removed boot args -v and so on, caused my clover to boot with that......
is dart=0 still working ?

some steps more on the way to heaven ;-)


but, reading your log, reminds me that happened on a real mac years ago.... but can not remember why.........
looks like file system error, the apfs driver is built in now....... but.......
hfs still present in drivers ?! maybe there is part of the problem ?

make sense, trying to set up mouse pointer, no place to store position data, gone, and nothing to read anymore, loose of file system............


thanx also goes to @Asural
,

it seems the major difference is the kernel patch parameters.............
both had the same results........

all other config params are the same.......
like the manual told us........

except, we havend exchanged .aml files


P.S.: i am booting usb stick to install, no upgrade ;-)
 
Last edited by a moderator:
D

Deleted member 2151140

Guest
Well ive got now Clover 5126 Up and running with parts of OC, only thing left is Power Management of Grafic card is not Optimal......

But i am sure, as reported, from there the Update and install works.

System is even faster....... a bit ;-)
 
Joined
Aug 1, 2016
Messages
175
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm a little reluctant to hand out complete EFI's because I think the user should
learn about OC and craft their EFI to their machine. If you have a specific question
or problem I might be able to help. Otherwise many of us are awaiting Sniki's new
OC guide. I have posted some info on Sniki's Catalina guide, you might check that.
I can understand that but I have to admit that I could never figure out how to come up with settings like the ones I had see in the Dell Optiplex 9030 thread to get the card reader ready. The OC guide is nice to follow step-by-step. But everything else is nothing I could figure out myself. Where and how could I learn all that?
 
Joined
Mar 7, 2014
Messages
4
Motherboard
HP 657094-001
CPU
i7 3770
Graphics
RX560
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Do not use the sample as it is.

It seems that it was possible to install with the attached file here.
Try SMBIOS with MacPro6.1 or iMacPro1.1.
Thank you for the answer. I've managed to run Big Sur successfully! There was no big problem with my previous configurations. I just newly installed from beginning then everything worked fine... Perhaps some corrupt files caused my previous failure.

My final config attached with serial number cleared. @MasterAmp
 

Attachments

  • config.plist
    19.9 KB · Views: 30
D

Deleted member 2151140

Guest
Thanx for your try, but had no USBport.kext, use USBinjectall,

No luck here, no change in behavier, allways run through -v part, show grey, then again black with Logo , progress bar appears, nothing happens......

mybe i did not wait long enough.......

same with Clover 5126......


will wait for Sniki Guide.

Clover 5126 with Catalina runs perfect, as allways.........
 
Joined
Mar 16, 2015
Messages
340
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
  1. MacBook Air
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. Quadra
  3. SE/30
Thanx for your try, but had no USBport.kext, use USBinjectall,

No luck here, no change in behavier, allways run through -v part, show grey, then again black with Logo , progress bar appears, nothing happens......

mybe i did not wait long enough.......

same with Clover 5126......


will wait for Sniki Guide.

Clover 5126 with Catalina runs perfect, as allways.........
If Catalina is running on Clover r5126, Big Sur can be installed on Clover r5126.
Try with SMNIOS = MacPro6.1.

If you are using a USB2.0 USB Stick, you do not need USBport.kext.
 
Joined
Oct 29, 2020
Messages
7
Motherboard
Dell Inspiron 7348
CPU
Core i5 5200
Graphics
Intel HD Graphics 5500
Mac
  1. Mac mini
Mobile Phone
  1. Android
Hi LisaAlterEgo,

I have the similar hardware like @MasterAmp and I'm also stuck on upgrading Big Sur from 10.15.7. I just can't boot to the MacOS Installer. The interesting part is there is no kernel panic and the apple logo shows, that means the graphics driver works well. But soon the logo and progress bar disappears and messages begin to show on screen:

AppleActuatorDeviceUserClient::stop entered

Then it enters into 'shutdown' process somehow.

I've captured serial logs but I can't figure out the root cause from them.

Mon Nov 16 05:51:10 2020 iMac.local com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.storagekitd.210) <Error>: Failed to bootstrap path: path = /System/Library/PrivateFrameworks/InstallerDiagnostics.framework/Versions/A/InstallerDiagnostics, error = 2: No such file or directory
Mon Nov 16 05:51:10 2020 iMac.local com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.storagekitd.210) <Error>: Failed to bootstrap path: path = /System/Library/PrivateFrameworks/DataDetectorsCore.framework/Versions/A/DataDetectorsCore, error = 2: No such file or directory
Mon Nov 16 05:51:10 2020 iMac.local com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.storagekitd.210) <Error>: Failed to bootstrap path: path = /System/Library/Frameworks/MediaToolbox.framework/Versions/A/MediaToolbox, error = 2: No such file or directory
RTC: setGMTTimeOfDay 1605505871
Kext loading now disabled.
Mon Nov 16 05:51:13 2020 HPE8300SFF.lan com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.system) <Notice>: System shutdown initiated by: shutdown.216<-macOS Update As.208<-Language Choose.190<-recoveryos_agen.186<-launchd.1
Mon Nov 16 05:51:13 2020 HPE8300SFF.lan com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.system) <Notice>: committing to system shutdown
Kext unloading now disabled.
Kext autounloading now disabled.
Kernel requests now disabled.
ASP: System is shutting down, preventing further ASP upcalls
ASP: ASP: shutting down, drained

Any comments about what I should do next? I'm using OC0.6.3 and all drivers and kexts are updated. And the SMBIOS is iMac17,1. I've also tried MacPro6,1, but the result was same.

Thank you very much.

@MasterAmp I think you could try out my configurations, which may give you some hint then.

Got this same error here during Big Sur install.

AppleActuatorDeviceUserClient::stop entered

The install process stops at 12 minutes remaining, reboots and returns wiith this error.
 
Joined
May 25, 2020
Messages
2
Motherboard
HP800 G1 Big Sur 11.0.1
CPU
I3 4130
Graphics
Intel HD 4400
Dear all, I installed successful Big Sur on HP8300 i3-3225 8Gb SSD128, iGPU HD4000. Here is my Config if you need
Need kext: VoodooHDA, Lulu, whatevergreen, intelmausi, usbinjectall, virtualsmc, CtlnaAHCIPort
 

Attachments

  • config.plist
    18.6 KB · Views: 27
Last edited:
Top