Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

Joined
Dec 7, 2019
Messages
11
Motherboard
HP
CPU
i7-3770
Graphics
HD 4000
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
First thing to do, go into BIOS and disable the Serial Port. Then try again. All 8300s have the Serial port. It's of no use to use and can cause problems.

View attachment 439199
I have disabled the Serial Port but I have the same problem so I'm attaching all the BIOS configuration.

Thank you in advance.
 

Attachments

  • IMG_1383.jpg
    IMG_1383.jpg
    3.1 MB · Views: 70
  • IMG_1384.jpg
    IMG_1384.jpg
    2.7 MB · Views: 60
  • IMG_1385.jpg
    IMG_1385.jpg
    2.2 MB · Views: 59
  • IMG_1386.jpg
    IMG_1386.jpg
    2.3 MB · Views: 55
  • IMG_1387.jpg
    IMG_1387.jpg
    2.3 MB · Views: 56
  • IMG_1388.jpg
    IMG_1388.jpg
    1.8 MB · Views: 59
  • IMG_1389.jpg
    IMG_1389.jpg
    3 MB · Views: 54
  • IMG_1390.jpg
    IMG_1390.jpg
    3.9 MB · Views: 59
  • IMG_1391.jpg
    IMG_1391.jpg
    3.5 MB · Views: 52
  • IMG_1392.jpg
    IMG_1392.jpg
    3.3 MB · Views: 54
  • IMG_1393.jpg
    IMG_1393.jpg
    2.5 MB · Views: 52

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,304
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
The BIOS settings look good. I usually disabled Fast boot but I don't think that is the problem. What happens after the loading bar goes all the way across ? How are you connecting to your monitor ? Using the DisplayPort output ?

1575810203552.png
 
Joined
May 13, 2019
Messages
52
Motherboard
Gigabyte GA-Z97X-UD3H
CPU
i7-4790
Graphics
RX 580
Mobile Phone
  1. Android
Hi,
in the post installation got these in terminal:
"
sudo rm /var/vm/sleepimage

rm: /var/vm/sleepimage: No such file or directory



cd desktop/tools

sudo cp iasl /usr/local/bin

sudo cp patchmatic /usr/local/bin

sudo cp hda-verb /usr/local/bin

cd: no such file or directory: desktop/tools

cp: iasl: No such file or directory

cp: patchmatic: No such file or directory

cp: hda-verb: No such file or directory"



I can only boot when the installation usb stick is in.
Sleep doesn't work either.
Attached EFI/CLOVER
 

Attachments

  • CLOVER.zip
    1.4 MB · Views: 46
Joined
Dec 7, 2019
Messages
11
Motherboard
HP
CPU
i7-3770
Graphics
HD 4000
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
The BIOS settings look good. I usually disabled Fast boot but I don't think that is the problem. What happens after the loading bar goes all the way across ? How are you connecting to your monitor ? Using the DisplayPort output ?


Yes I'm using the Display Port output. After the loading, the screen becomes dark and after that the returns me the Apple's logo with the empty loading bar and the mouse icon and if I click it disappears and if I type the keyboard does a flash.

What you think can be the problem?, maybe you can share the EFI folder maybe there is something wrong with that.

But now I'll share mine.
 

Attachments

  • EFI.zip
    5.7 MB · Views: 52
Joined
Dec 7, 2019
Messages
11
Motherboard
HP
CPU
i7-3770
Graphics
HD 4000
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Hi,
in the post installation got these in terminal:
"
sudo rm /var/vm/sleepimage

rm: /var/vm/sleepimage: No such file or directory



cd desktop/tools

sudo cp iasl /usr/local/bin

sudo cp patchmatic /usr/local/bin

sudo cp hda-verb /usr/local/bin

cd: no such file or directory: desktop/tools

cp: iasl: No such file or directory

cp: patchmatic: No such file or directory

cp: hda-verb: No such file or directory"



I can only boot when the installation usb stick is in.
Sleep doesn't work either.
Attached EFI/CLOVER
It is how I can fix my problem?
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,304
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
What you think can be the problem?,
You've still got required drivers in drivers64UEFI when they should be in driversUEFI. Fix that first.

Screen Shot 28.jpg

I'm also not sure whether you want to inject all your kexts via Clover or not but you've got your config.plist set to detect kexts instead of inject kexts.
 
Joined
Dec 7, 2019
Messages
11
Motherboard
HP
CPU
i7-3770
Graphics
HD 4000
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
You've still got required drivers in drivers64UEFI when they should be in driversUEFI. Fix that first.

View attachment 439430
I'm also not sure whether you want to inject all your kexts via Clover or not but you've got your config.plist set to detect kexts instead of inject kexts.

This is the EFI folder with your correction. If is it wrong can you correct it cuz I'm very confused? Please cuz with this modifications gives me always the same thing.
 

Attachments

  • EFI.zip
    5.8 MB · Views: 40

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,304
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
This is the EFI folder with your correction. If is it wrong can you correct it cuz I'm very confused? Please cuz with this modifications gives me always the same thing.

Sniki will be completely revising this guide sometime next week so a lot will change.

For now you can simply delete the drivers64UEFI folder as it's not needed. Keep driversUEFI. Also, remove VboxHfs.

Screen_Shot_35.png


Looking at your ACPI/patched folder where are all the other SSDTs ? Doesn't the guide recommend others too ?

Screen Shot 36.jpg
 
Joined
Dec 7, 2019
Messages
11
Motherboard
HP
CPU
i7-3770
Graphics
HD 4000
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Sniki will be completely revising this guide sometime next week so a lot will change.

For now you can simply delete the drivers64UEFI folder as it's not needed. Keep driversUEFI. Also, remove VboxHfs.

View attachment 439479

Looking at your ACPI/patched folder where are all the other SSDTs ? Doesn't the guide recommend others too ?

View attachment 439478

My ACPI/patched folder was empty I've added the SSDT-HP.aml like in the guide, which other files I need?

This is what I got when I have deleted the drivers64UEFI folder.
 

Attachments

  • IMG_1406.jpg
    IMG_1406.jpg
    3.8 MB · Views: 44
Last edited:
Joined
Dec 7, 2019
Messages
11
Motherboard
HP
CPU
i7-3770
Graphics
HD 4000
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Sniki will be completely revising this guide sometime next week so a lot will change.

For now you can simply delete the drivers64UEFI folder as it's not needed. Keep driversUEFI. Also, remove VboxHfs.

View attachment 439479

Looking at your ACPI/patched folder where are all the other SSDTs ? Doesn't the guide recommend others too ?

View attachment 439478
I want just tell you thank you for your time, I've figured out now It's perfectly working.
 
Top