Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

Joined
Aug 30, 2019
Messages
6
Motherboard
HP 8300
CPU
i7 3770
Graphics
MSI RX 560
Hi all,
Wasn't sure whether to post in this thread or in the Mojave one.
Currently running Mojave (10.14.6) on my 8300 but wish to upgrade to Catalina.
Also, became aware that hardware acceleration is not enabled in apps like OBS.
From my research, it appears I might need later versions of Lilu and Whatevergreen.

So my question is should I upgrade to Catalina and then resolve HW acceleration issues? Or should I fix HW accel first and then let the built-in update upgrade me to Catalina ?
If fix HW accel first, is it simply a case of replacing the kext in /EFI/CLOVER/kexts/other with the later versions?
Or there other settings that need amending in SMBIOS or else in Clover configurator ?

For reference, previous kext versions are:
Lilu 1.3.8
VirtualSMC 1.0.7
WhateverGreen 1.3.1
AppleALC 1.4.0
IntelMausi 1.0.1


Please let me know if further info would help answer these questions.
Many Thanks.
Anthony
 

Attachments

Joined
May 5, 2017
Messages
369
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
MacBook Pro
@Sniki thanks for the comprehensive answer. I look forward to the Opencore guide - and please let us know if you need any help testing, I have one of each of the 8300.

I will try the SSDT from @trs96 thread. Of course also thanks to @trs96 who has been instrumental in working with these machines as well.

I think the lack of VGA port should be a non issue. The last Mac that had a VGA port was ancient, and apart from the occasional projector, I don't ever see VGA ports any more.
 
Joined
May 5, 2017
Messages
369
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
MacBook Pro
Hi all,
Wasn't sure whether to post in this thread or in the Mojave one.
Currently running Mojave (10.14.6) on my 8300 but wish to upgrade to Catalina.
Also, became aware that hardware acceleration is not enabled in apps like OBS.
From my research, it appears I might need later versions of Lilu and Whatevergreen.

So my question is should I upgrade to Catalina and then resolve HW acceleration issues? Or should I fix HW accel first and then let the built-in update upgrade me to Catalina ?
If fix HW accel first, is it simply a case of replacing the kext in /EFI/CLOVER/kexts/other with the later versions?
Or there other settings that need amending in SMBIOS or else in Clover configurator ?

For reference, previous kext versions are:
Lilu 1.3.8
VirtualSMC 1.0.7
WhateverGreen 1.3.1
AppleALC 1.4.0
IntelMausi 1.0.1


Please let me know if further info would help answer these questions.
Many Thanks.
Anthony
What is the OBS app?
 
Joined
Aug 30, 2019
Messages
6
Motherboard
HP 8300
CPU
i7 3770
Graphics
MSI RX 560
What is the OBS app?
Open Broadcast Studio (Project)
Video recording / live streaming - that kind of thing. Obviously would work better with HW accellerated GPU encoder functions!
 
Joined
May 5, 2017
Messages
369
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
MacBook Pro
@taster do you have onboard graphics enabled in the BIOS?
You should "just" be able to update the kexts I think, but I am not the expert...
 
Joined
Mar 16, 2015
Messages
213
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
Also, became aware that hardware acceleration is not enabled in apps like OBS.
It should work from Mojave 10.14.5.
Does set to BIOS-> Advaced-> Devide Option-> Integrated Video = Dsiable?
 
Joined
May 5, 2017
Messages
369
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
MacBook Pro
To be honest i have a SSDT.aml that i did generate for my 8300SFF, i will collect those SSDTs from @trs96 guide and upload them on the github project so everyone can pick his SSDT according to his CPU, those SSDTs are previously generated before that Power Management problem showed up so i assume that they should work fine.
FYI @Sniki I tried the one from the @trs96 guide, and it matches my CPU, but it doesn't work. I presume this might be because @trs96 is using a different system definition (iMac) and he notes they will only work if you are using the same as that (and I'm using MacMini as per this guide). They both appear to hang at the same point when booting; I have not done a verbose boot yet.
 
Joined
Aug 30, 2019
Messages
6
Motherboard
HP 8300
CPU
i7 3770
Graphics
MSI RX 560
It should work from Mojave 10.14.5.
Does set to BIOS-> Advaced-> Devide Option-> Integrated Video = Dsiable?
Yep, Integrated Video is set to Disabled

Any other thoughts ?
 

Attachments

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,970
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
Intel HD3000
Mac
MacBook Pro
Mobile Phone
iOS
FYI @Sniki I tried the one from the @trs96 guide, and it matches my CPU, but it doesn't work. I presume this might be because @trs96 is using a different system definition (iMac) and he notes they will only work if you are using the same as that (and I'm using MacMini as per this guide). They both appear to hang at the same point when booting; I have not done a verbose boot yet.
Thnx for letting me know.
I will edit them to match macmini 6,1
 
Top