Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,311
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Unfortunately the Low Profile GPUs are becoming quite rare and expensive.
There is no store or online shopping site in my country or countries around me that i didn’t check and i just never found any listing of the MSI Radeon RX 560 LP.
There was the Yeston RX 550 GPU but due to Covid-19 situation last year, China wasn’t shipping here.
The only available LP GPUs were the Nvidia ones like:
- 710 / 730
- 1030 and 1050 and 1050 TI
- 1650

The only option available and maybe the most expensive and the most powerful was the MSI GeForce GTX 1650 LP OC that i purchased.

It is a beast low profile GPU and works excellent on Windows and Linux for Small Form Factors but for macOS unfortunately Nvidia GPUs are a no go (aside the older ones that are still yet natively supported).

As for hackintosh, past Big Sur, i am not sure if these machines will be supported or even work, i guess all of us will have to accept the fact that we may have to upgrade our hardware after 2-3 years as Big Sur and Catalina will be still fine for like 2-3 years unless major security flaws hit us.
 
Joined
Dec 2, 2019
Messages
54
Motherboard
HP Elite 8300 SFF, HD2500 Graphics
CPU
i5-3470
Graphics
GT 710
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
any of you able to get the bluetooth on fenvi Hb-1200 to work. I have the bluetooth adapter cable connected to the "Media" jumper on the motherboard. This same setup has bluetooth working on my windows 10 boot. Am I missing something?
I even tried adding the AirportFixup and BrcmFixup kexts

Nevermind: I needed to connect the bluetooth adapter to one of the front USB jumper (sacrifice two front USBs). AirDrop is working as well.
 
Last edited:
Joined
Feb 1, 2011
Messages
98
Motherboard
8300 SFF iMac15,1
CPU
3.4 GHz Quad-Core Intel Core i7
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. iOS
any of you able to get the bluetooth on fenvi Hb-1200 to work. I have the bluetooth adapter cable connected to the "Media" jumper on the motherboard. This same setup has bluetooth working on my windows 10 boot. Am I missing something?
I even tried adding the AirportFixup and BrcmFixup kexts

Nevermind: I needed to connect the bluetooth adapter to one of the front USB jumper (sacrifice two front USBs). AirDrop is working as well.
No its something to do with using a different power.aml file then the one @LisaAlterEgo supplied. It seems it will only work with everything as is in her EFI folder. I finally figured out that was my issue with the bluetooth not working. Im not sure what to do now because I'm using her EFI-AMD but I have a i3770.
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,311
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
No its something to do with using a different power.aml file then the one @LisaAlterEgo supplied. It seems it will only work with everything as is in her EFI folder. I finally figured out that was my issue with the bluetooth not working. Im not sure what to do now because I'm using her EFI-AMD but I have a i3770.
I think most likely the choice with SMBIOS and USBPorts.kext, use her USBPorts.kext and you should be fine.

Open it with a plist editor file and change/rename one of the SMBIOS listings to yours and it should work.
 
Joined
Feb 1, 2011
Messages
98
Motherboard
8300 SFF iMac15,1
CPU
3.4 GHz Quad-Core Intel Core i7
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. iOS
I think most likely the choice with SMBIOS and USBPorts.kext, use her USBPorts.kext and you should be fine.

Open it with a plist editor file and change/rename one of the SMBIOS listings to yours and it should work.

managed to get it working somehow. I checked everything like you said. All seemed in order, must have just been a fluke on my end.

Looks like everything for me is now working including unlock from apple watch. I used Lisa amd setup with my power management i made following the first post. The only thing i did different is rename the new ssdt file as what Lisa had hers named. For whatever reason when I rename it the way I want and do a clean snap shot with proper tree it didnt properly. But thank you to all invovled, Big Sur runs great. One thing I did noticed though, in Windows 10 Night Shift works fine. If i was using Clover night shift works fine. But for some reason I cant get it to work in Big Sur with OC. Not a big deal but just wondering if anyone else had this issue?
 
Last edited:
Joined
Apr 2, 2011
Messages
22
Motherboard
HP 8300 CMT iMacPro1,1
CPU
i7-3770
Graphics
Radeon RX 560 4 GB
Mac
  1. iMac
Mobile Phone
  1. iOS

I've put together a beginner's video guide for making the OpenCore USB installer with Big Sur. Catalina can be used as well but the video only shows Big Sur. Make your USB installer to have it ready to go when Sniki posts the full install guide. If you already have your hardware set and working you can skip the first two minutes and go to the Big Sur download part at 2:01. If you do proceed with the install, remember to take out the Catalina/Clover or OC SSD you have been using. Install to a clean 2.5" SSD or format that if you have data you no longer need on it.

View attachment 506636

as previously booting Clover on the same HP can cause conflicts with what it has left stored in NVRAM. This way you can try out Big Sur but still go back to Catalina Clover or OC if you'd like to. You older install will still continue to work just as it did before.






Buying a new SSD to try the install ? $22.99 at Amazon for a new PNY 120GB.
Good deals on 240GB drives if you need more storage. $29.99.

https://www.amazon.com/dp/B0722XPTL6/?tag=tonymacx86com-20

Followed the steps in the video above and the readme file in the HP6300-HP8300 zip. It worked like a charm. My new install appears to be mostly functional. Should I complete any of the remaining steps in the "Post Installation" found on page 1 of this thread? I have not signed into my Apple ID yet so I still need to complete the iServices configuration.

Thanks

 

trs96

Moderator
Joined
Jul 31, 2012
Messages
19,629
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Joined
Apr 2, 2011
Messages
22
Motherboard
HP 8300 CMT iMacPro1,1
CPU
i7-3770
Graphics
Radeon RX 560 4 GB
Mac
  1. iMac
Mobile Phone
  1. iOS

trs96

Moderator
Joined
Jul 31, 2012
Messages
19,629
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
What about the step # 3 "Disable Hibernation" or step # 4 "patchmatic and iasl" ? Can they be omitted in Big Sur?
Disable Hibernation is optional, you don't have to do that. Patchmatic and iasl is used for problem reporting files so if everything is working those are not needed.
 
Joined
Dec 12, 2018
Messages
36
Motherboard
Q77
CPU
I5 3570
Graphics
WX 4100
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. 20th Anniv. Mac
  2. Centris
  3. Classic
  4. Color Classic
  5. iBook
  6. iMac
  7. LC
  8. Performa
  9. Plus
  10. Power Mac
  11. Quadra
  12. SE/30
Mobile Phone
  1. Android
@Sniki

there is the often forgotten AMD WX4100 it is a RX560 with less Power Drawing ( 50W max. ),
and a faster Driver ?! at least for Polygons......

Working OOB and i bought it at the Time NVIDIA WEB Drivers where taken down.
Mojave.......

For a short Time i had a GT740 ( OOB ) with Kepler, hard to find, cause there are Plenty with Pascal, but it was Passiv and working OOB.

But since the WX 4100 i have Hardware Coding from Photoshop to Blender to Video H264 HVEC and the SFF is still dead Silent and Cool, low Energy everyday Working Horse !

So for me, it was worth the 200 Bucks Used i had to Pay 2 Years ago........
( i was searching for the MSI LP 560 long time, but it was not available in Europe )

Now i have Open Core 0.6.3 and Big Sur 11.2.3
Updates are just running through.

Love it.

EFI to be found @


and thank you Guys, this Thread was the beginning of it all........
 
Top