Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,518
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I am using a DP to DVI adaptr and a DVI to HDMI Cable
Won't work as the i5-3570 has HD2500 integrated. So wait for your GT 7010 to do the install.
 
Joined
Jun 19, 2019
Messages
38
Motherboard
H61M
CPU
i5-3570K
Graphics
GT 740
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Just update Clover Bootloader to latest version and kexts (which you can by clicking them listed on the guide as the links will send you directly to release link of each kext).
After Clover Bootloader update and kext update, reboot and then lunch system update from the software update and you can update like on a real mac.

That is wrong, instead before updating copy AptioMemoryFix.efi into desktop and then after clover update place it back into EFI/Clover/Drivers/UEFI (do the same for HFSplus.efi and virtualsmc.efi if they are not present anymore after clover update)

Thank you for your reply.
First of all, I did a backup.
Secondly, I tried to update the clover boot loader via the clover configurator but I get an error message that it cannot connect to the stable and beta servers of the app... In any way, I found and downloaded the package of clover r.5018 and I can install it manually.
The problem is that the boxes in r5018 are different than the guide in the 1st post. So I don't really know what exact boxes to tick.

My last problem is the following. I tried to make the update (without updating clover, I just updated the kexts), and I destroyed my system... :D I had to wipe the disk and time machine my way back to the desktop.
One problem that I faced was, I think, the GPU rx480. I think that I have to remove it from the motherboard, and them connect the monitor directly to the Display port of the tower (not the DP of the GPU), and use the integrated intel GPU. Otherwise I get to a completely black screen.

Sniki is that correct? Do I have to remove the GPU before proceeding to update?
 
Joined
Mar 16, 2015
Messages
340
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
  1. MacBook Air
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. Quadra
  3. SE/30
Just update Clover Bootloader to latest version and kexts (which you can by clicking them listed on the guide as the links will send you directly to release link of each kext).
After Clover Bootloader update and kext update, reboot and then lunch system update from the software update and you can update like on a real mac.

That is wrong, instead before updating copy AptioMemoryFix.efi into desktop and then after clover update place it back into EFI/Clover/Drivers/UEFI (do the same for HFSplus.efi and virtualsmc.efi if they are not present anymore after clover update)
It is working with r5018, but please check. (Succeeded without virtualsmc.efi but added now)

Clover r5018
( Thinking, "Why is Action is Install?"I confirmed the wrong, I will post a revised version.)
Upper.png

LOWER.png


USB EFI : r5018EFI
Mac disk EFI : HP8300EFI


Delete:
The attachment was deleted because it fulfilled its purpose.
 
Last edited:
Joined
Mar 16, 2015
Messages
340
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
  1. MacBook Air
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. Quadra
  3. SE/30
Thank you for your reply.
First of all, I did a backup.
Secondly, I tried to update the clover boot loader via the clover configurator but I get an error message that it cannot connect to the stable and beta servers of the app... In any way, I found and downloaded the package of clover r.5018 and I can install it manually.
The problem is that the boxes in r5018 are different than the guide in the 1st post. So I don't really know what exact boxes to tick.

My last problem is the following. I tried to make the update (without updating clover, I just updated the kexts), and I destroyed my system... :D I had to wipe the disk and time machine my way back to the desktop.
One problem that I faced was, I think, the GPU rx480. I think that I have to remove it from the motherboard, and them connect the monitor directly to the Display port of the tower (not the DP of the GPU), and use the integrated intel GPU. Otherwise I get to a completely black screen.

Sniki is that correct? Do I have to remove the GPU before proceeding to update?
Is it possible to update MacOS in "Multi Booting" environment? (Does the update program not be recognized in order to secure the update area at the time of update?)
When changing "Bootloader" Is redefinition unnecessary in "Multi Booting" environment?
I do not know.

Prepare another disk, install it as you first created MacOS, and if you're good at it, try redefining the "Multi Booting" environment.
 
Joined
Jun 19, 2019
Messages
38
Motherboard
H61M
CPU
i5-3570K
Graphics
GT 740
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Thanx for your replies!

One last question. Do I need to change anything in clover configurator or add any kexts (apart from Lilu and whatevergreen which are already installed) due to the RX480?
I am asking because I cannot watch netflix in Safari. I get an error message that html5 is not supported and I need to install silverlight etc.
From a quick search I did, I understand you need intel graphics to have html5, and unfortunately in hackintosh machines, the change between intel integrated graphics and dedicated radeon graphics is not done automatically. My RX480 is natively supported (I just plugged it in the motherboard and booted up), but maybe I need to do some clover configurator tinkering to get even these small bugs fixed.
Any assistance to solve this problem will be appreciated.
Thank you.
 
Joined
Mar 16, 2015
Messages
340
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
  1. MacBook Air
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. Quadra
  3. SE/30
Thanx for your replies!

One last question. Do I need to change anything in clover configurator or add any kexts (apart from Lilu and whatevergreen which are already installed) due to the RX480?
I am asking because I cannot watch netflix in Safari. I get an error message that html5 is not supported and I need to install silverlight etc.
From a quick search I did, I understand you need intel graphics to have html5, and unfortunately in hackintosh machines, the change between intel integrated graphics and dedicated radeon graphics is not done automatically. My RX480 is natively supported (I just plugged it in the motherboard and booted up), but maybe I need to do some clover configurator tinkering to get even these small bugs fixed.
Any assistance to solve this problem will be appreciated.
Thank you.
Please search for "html5 safari".
Apple saprt shows how to use the internet plug-in.


About RX480, I think that "Apple's driver can be used for" Lilu and whatevergreen ".
Every time I change from MacOS to Win10, I am warned that I have returned the settings of the RX570, but I don't care.

Edit :
Apple saport says that Safari supports HTML5.
I don't use NETFLIX myself, so see #614.
 
Last edited:
Joined
Mar 16, 2015
Messages
340
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
  1. MacBook Air
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. Quadra
  3. SE/30
We verified the operation by replacing the backup SSD with HP6300SFF.
I do not want to do USB installation test because it is slow.
スクリーンショット 2019-07-29 14.07.05.png
 
Joined
Oct 3, 2018
Messages
48
Motherboard
HP 6300 Pro
CPU
i5-3570/Q77
Graphics
GT 710
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Color Classic
Mobile Phone
  1. iOS
It is working with r5018, but please check. (Succeeded without virtualsmc.efi but added now)
View attachment 418656
View attachment 418657

Thanks Asural, I also found that the latest Clover didn't match the instructions. I tried it but couldn't boot off the usb installer, so downloaded both your EFI folders and it's now working well. Appreciate it.
 
Last edited:
Joined
Nov 2, 2018
Messages
278
Motherboard
HP 8300, MacMini6,1
CPU
i5-3570K, i5-3470, i5-3210, G5
Graphics
RX570, RX560, GT730K, HD4000
Mac
  1. Mac mini
Classic Mac
  1. Power Mac
Today, I updated three i5 8300 machines from MacOS 10.14.6 to install
the 10.14.6 Supplemental update, build 18G87. Two of the machines
have a RX560 4G graphics card, the other has a GT730 2G Kepler graphics
card. All machines have Clover r5033 with updated drivers, and I am using
VirtualSMC.

At first, the updates seemed like they were hanging on the first reboot.
I restarted in verbose mode, and I could see a long stall before IntelMausi
brought interface en0 up, and then three 4 minute stalls with AppleACPICPU.
After about 15-20 minutes, it completed a boot to a Mojave install graphic,
where it said it would take 28 minutes at first, but it completed in just a few
minutes. There was another reboot after that, and now everything seems to work
normally with the update installed and no booting delays. I ran Geekbench and
did not see any appreciable difference in scores for CPU or metal graphics.

So in summary, if you install the supplementary update, you might consider
making a cup of coffee, booting the install in verbose mode, and being prepared
for several long stalls, but all of mine ended up working just fine.
 
Last edited:
Joined
Oct 3, 2018
Messages
48
Motherboard
HP 6300 Pro
CPU
i5-3570/Q77
Graphics
GT 710
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Color Classic
Mobile Phone
  1. iOS
Edit: I swapped out my i3 for an i5 3570 - no other changes - and I’m now in a world of pain. I think I need to learn more about this instead of shooting in the dark.
 
Last edited:
Top