Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,724
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
If you can zip up your USB installer's Clover folder attach that for review.
It's not uncommon to get those "unsupported" messages. How long does
it stay stuck at that point ? How long are you waiting ?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
21,745
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,724
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
The OS installed and booting with USB to set up the OS, but now I'm getting "busy timeout (240s): AppleACPICPU"
That happen sometimes on the 8300. Just have to wait it out and it eventually gets there, very slowly. Once awhile ago when I had an 8300 it was caused by AppleALC kext and went away if I removed that. Can have other causes too.
 
Joined
Nov 3, 2018
Messages
48
Motherboard
HP SFF 8300 Elite
CPU
i5-3570
Graphics
GT 710
Mobile Phone
Android, iOS
That happen sometimes on the 8300. Just have to wait it out and it eventually gets there, very slowly. Once awhile ago when I had an 8300 it was caused by AppleALC kext and went away if I removed that. Can have other causes too.
So are you recommending removing AppleALC?
 
Joined
Mar 16, 2015
Messages
71
Motherboard
HP 8300 SFF-V3.08
CPU
i5-3470
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
Trying to install latest Mojave on HP 8300 sff with core i5 3570. I am stuck at: Unsupported CPU, Unsupported PCH, Kextd stall [0], (240s): 'AppleACPICPU'
Any help will be greatly appreciated. Thank you.
I'm having trouble with the same phenomenon with the backup HP8300CMT, but it seems that some versions of Clover will not work.

In my case, the installation was successful when using Clover 4910 or 4920 as described in # 391 by trs96 in Creating USB Installer.

The Pre Installation uses 4972, but the behavior that can not be started when setting the SMBIOS with Clover Configurator has occurred in any version, but it is left as it is in the original Config.prist.
 
Last edited:

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,680
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
Guide is outdated and shall be updated soon, main problem is that Clover bootloader fork of Rehabman is outdated and not supported anymore on latest versions of macOS Mojave.

Serial Port works OOB, latest AppleALC versions are fine but as @trs96 said some i5 Models with HD2500 graphics seem to stall for some time.

I have updated files on my Xcode project but haven't pushed them yet on Github.

With latest optimizations installation completed in 20 min like on a real mac, without a single problem.

I believe that that stall problem with i5 versions has been fixed as well.

I will let you all know when i update guide and files.

For now everyone use latest clover versions, not Rehabman fork
 
Joined
Nov 3, 2018
Messages
48
Motherboard
HP SFF 8300 Elite
CPU
i5-3570
Graphics
GT 710
Mobile Phone
Android, iOS
Guide is outdated and shall be updated soon, main problem is that Clover bootloader fork of Rehabman is outdated and not supported anymore on latest versions of macOS Mojave.

Serial Port works OOB, latest AppleALC versions are fine but as @trs96 said some i5 Models with HD2500 graphics seem to stall for some time.

I have updated files on my Xcode project but haven't pushed them yet on Github.

With latest optimizations installation completed in 20 min like on a real mac, without a single problem.

I believe that that stall problem with i5 versions has been fixed as well.

I will let you all know when i update guide and files.

For now everyone use latest clover versions, not Rehabman fork
I have hp sff 8300 with i5 3570 and Intel Q77 Express. I followed your guide but could not get it to work. It would install but cannot set up the HDD. The setup screen is just grey and can't see anything. However, the Unibeast for Mojave worked just fine. I re-made the USB installer with Unibeast to setup the Mojave. I did not need to use any of the kexts either. The kexts caused kernel panic.
Now the issue that I'm having is the graphics. I have Palit GeForce GT 730 2048 MB. It is working, but not 100%. No transparency, minor lag, and minor screen tear. Is there a way to fix this? Right now I have installed "WhateverGreen and Lilu."
Thank you very much for your help and any help will be greatly appreciated.
.
 

Attachments

Last edited:
Joined
Jul 12, 2019
Messages
1
Guide is outdated and shall be updated soon, main problem is that Clover bootloader fork of Rehabman is outdated and not supported anymore on latest versions of macOS Mojave.

Serial Port works OOB, latest AppleALC versions are fine but as @trs96 said some i5 Models with HD2500 graphics seem to stall for some time.

I have updated files on my Xcode project but haven't pushed them yet on Github.

With latest optimizations installation completed in 20 min like on a real mac, without a single problem.

I believe that that stall problem with i5 versions has been fixed as well.

I will let you all know when i update guide and files.

For now everyone use latest clover versions, not Rehabman fork
Hi I'm new to the scene and setting up my first hackintosh with a HP 6300.
Since 3 days I'm trying hard to get it running.
First success was until the completion of the installation progress bar with the apple icon above....and not further.
Then I read you saying that this guide is not gonna work any more :(
So I used the current Clover_v2.5k_r5018 and see that there is no AppleImageLoader-64 option any more.
But when I still continue the current guide I do still use the
EFI/Clover/ and delete config.plist, copy the config.plist that you downloaded from my repo and paste it there.
Into EFI/Clover/ACPI/Patched, add the SSDT-HP.aml from my repo
Into EFI/Clover/Drivers64UEFI, make sure to add HFSPlus.efi (click on it to download it).
Into EFI/Clover/kexts/Other, make sure to add the following kexts listed down below:

FakeSMC.kext
USBInjectAll.kext
EFICheckDisabler.kext (attached at the end of the guide)
Lilu.kext
WhateverGreen.kext
AppleALC.kext
IntelMausiEthernet.kext
https://bitbucket.org/RehabMan/os-x-intel-network/downloads/

With these files Clover does not boot, so I went back to the original config.plist and Clover does boot...sadly I can´t continue much further. After selecting the install mojave boot device it's still not taking me anywhere.

Would you please provide a updated config.plist, SSDT-HP.aml, HFSPlus.efi and EFICheckDisabler.kext? (and maybe "AppleImageLoader-64"?)
I do ask only for these files because the rest of the links in the guide are targeting repos with updated versions of the files(kexts)

Wow...look at what I am writing. I had no clue about all this 3 days ago :)
Hope I´ll get my first hackintosh running soon :)
 
Top