Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,777
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
If you think that's part of the problem, though, I can for sure move them along to /Library/Extensions.
As that's what the guide suggests I would install them to /L/E and see what happens on a reboot. Remember to rebuild caches too.
 
Joined
Jun 28, 2017
Messages
15
Motherboard
HP 8300 SFF
CPU
i7-3770
Graphics
GTX 1050 TI
Mac
MacBook Pro
Classic Mac
128K, iBook, iMac
Mobile Phone
iOS
I tried to do that, but rebuilding my kexts cache caused the attached error and booting without those kexts in Clover/Kexts/Other make me unbootable.

I pulled the drive and used another Mac to put the kexts back in C/K/O, leaving them in /L/E, but that didn't fix my Bluetooth issue, either.
 

Attachments

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,777
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
I tried to do that, but rebuilding my kexts cache caused the attached error and booting without those kexts in Clover/Kexts/Other make me unbootable.
Let's wait till @Sniki signs in and see what he advises you to do.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,777
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Here's what RehabMan has to say about injecting kexts:
With config.plist/SystemParameters/InjectKexts=Detect, Clover will inject all applicable (depending on version) kexts in EFI/Clover/kexts only if FakeSMC.kext is NOT in kernel cache.

If FakeSMC.kext is in kernel cache and InjectKexts=Detect, Clover will inject nothing from EFI/Clover/kexts.
So this implies that you should keep at least FakeSMC kext in the kexts/other folder when you install kexts to the system volume.
If you can't boot, just select boot ignore caches and it should boot normally.

From this thread: https://www.tonymacx86.com/threads/injecting-kexts-via-clover.200575/
 
Last edited:

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,696
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
I'm still on High Sierra because I need my 1050 Ti to drive both my monitors since the 8300 SFF only has the one DisplayPort.

and EDIT for the sake of clarity, since my Desktop apparently uses a different account on here than my Laptop. Sorry about the confusion. I'm also Supertrain.

I've attached the output from the gen_debug tool! I'm using this Broadcom BCM943602CS, which should be natively supported without kexts. I don't have any kexts installed beyond the Nvidia web drivers and the ones in the tutorial. Thanks for your help!
Remove SSDT-HP.aml from EFI/Clover/ACPI/Patched and add those SSDTs that i attached (all of them).

Remove everything from EFI/Clover/kexts/other

Put only these kexts:
- FakeSMC.kext
- IntelMausiEthernet.kext
- EFICheckDisabler.kext
- USBInjectAll.kext
- Lilu.kext
- WhateverGreen.kext
- AppleALC.kext

Create a folder on desktop called: kext

Add/copy these kexts into that folder:
- FakeSMC.kext
- IntelMausiEthernet.kext
- EFICheckDisabler.kext
- USBInjectAll.kext
- Lilu.kext
- WhateverGreen.kext
- AppleALC.kext
- CodecCommander.kext

Open terminal and write following commands:
Code:
cd desktop/kext
sudo cp -R *.kext /Library/Extensions/
After this you need to rebuild caches with:
Code:
sudo kextcache -i /
Reboot and attach new problem reporting files.

Do all the described steps from above, so i can see where does the bluetooth controller assign, if it does assign on EH01 controller then we might need to adjust the USB Injector (will make the changes to adjust it accordingly.)

Will publish final changes with the fix and upload files for you.
 
Joined
Jun 28, 2017
Messages
15
Motherboard
HP 8300 SFF
CPU
i7-3770
Graphics
GTX 1050 TI
Mac
MacBook Pro
Classic Mac
128K, iBook, iMac
Mobile Phone
iOS
Hey, thanks so much for your help! Did you mean to attach files to your post? I did everything you said except for the first line just because I didn't know what you meant by it.
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,696
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
Hey, thanks so much for your help! Did you mean to attach files to your post? I did everything you said except for the first line just because I didn't know what you meant by it.
Sorry..
i guess i didn't wait for the upload to finish and immediately pressed "Post Reply" without waiting for the files to upload.

Here you have them
Remove SSDT-HP.aml from EFI/Clover/ACPI/Patched/ and add the ones that i attached.
 

Attachments

Joined
Jun 28, 2017
Messages
15
Motherboard
HP 8300 SFF
CPU
i7-3770
Graphics
GTX 1050 TI
Mac
MacBook Pro
Classic Mac
128K, iBook, iMac
Mobile Phone
iOS
Test files attached. Anecdotally Bluetooth and Continuity are working now.
 

Attachments

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,777
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Hey, thanks so much for your help! Did you mean to attach files to your post? I did everything you said except for the first line just because I didn't know what you meant by it.
Anecdotally Bluetooth and Continuity are working now.
So have you found audio and USB all to be working in High Sierra using this guide ? Does your HDMI audio work too ?
 
Joined
Jun 28, 2017
Messages
15
Motherboard
HP 8300 SFF
CPU
i7-3770
Graphics
GTX 1050 TI
Mac
MacBook Pro
Classic Mac
128K, iBook, iMac
Mobile Phone
iOS
Haven't tested my HDMI audio because I'm only using DisplayPort and my monitors don't have speakers, but for what it's worth DisplayPort audio is an assignable audio device in the sound control panel and shows up in system profiler just fine.

As for everything else, USB seems to be working just dandy, though I haven't rigorously tested every port, and sound works fine from the analogue out. It's a pretty solid system overall, too.

(This is sorta incidental, but I figured out a decent way to make UEFI-exclusive booting work with dual monitors and a 1050 Ti that might help out your guide. If you just set the integrated GPU as the primary device and plug one monitor in there and one monitor into the 1050 Ti, the system'll show Clover and everything after it in glorious 1080p on the monitor connected to the GPU, switching on the monitor connected to the iGPU only when the computer is booted. It works really well except for a whacked-out HP splash screen, but even the BIOS shows up just fine. I'll trade the boot screen for 1080p FileVault any day. Might be worth adding to your guide for the little bit between now and when everyone gets fed up with Nvidia and goes AMD only for their hacks.)
 
Top