Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,667
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
I Cant thank you enough for the guide its just so perfect, I've been using the HP 8300 for a year but have never found a build to be working this great, all thanks to your time and efforts put into this.

My hp 8300 has memory card slots and a additional USB slot next to the CD/DVD Disk Drive, would it be possible to get it working too? All these are slots are connected via a SATA cable. Any suggestions would be appreciated.
Yes it is possible, if you are using my files from this guide, all you have to do is add this kernel flag: -uia_ignore_rmcf
and reboot, open ioreg and while keeping ioreg open plug a usb 2.0 device (mouse or keyboard) and unplug it and then plug a usb 3.0 device into that port (like an external 3.0 hdd or usb 3.0 flash drive, etc).
unplug the usb 3 device as well and save the ioreg and upload it here.
i will update the SSDT-HP.aml to include that additional port for usb.
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,667
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
@Sniki , I have followed this guide and now need your help.

I have an HP Compaq 8300 Elite Ultra-Slim PC (USDT) model, and I apparently have all of the external USB ports working using your guide, however, it seems as if the internal header is not active.
I have attached IOReg zipped output after plugging in USB 2.0 Dell Multimedia Pro Keyboard into every external port, followed by Sandisk UltraFit 3.0 32G thumbdrive into every external port.

I've also checked the BIOS, under the Security tab, under USB Security, and it shows 4 front-side ports Enabled, 6 rear-side ports Enabled, and 4 Accessory ports Enabled (it doesn't call these last 4 Internal; HP Compaq Business PC Maintenance and Service Guide matches the BIOS nomenclature).

Would you help build a specific USDT USB solution that includes the internal USB header? This will enable Bluetooth connected miniPCIe adapter cards for full Airdrop, Continuity & Handoff functionality. I'd be happy to be a tester.
i will take a look at the files later and see what is happening, sorry for not responding everyone, for some reasons im not getting notifications about this thread.
 
Joined
Dec 20, 2018
Messages
148
Motherboard
NUC7
CPU
i5
Graphics
HD 620
Mac
iMac
Mobile Phone
iOS
i will take a look at the files later and see what is happening, sorry for not responding everyone, for some reasons im not getting notifications about this thread.
Interestingly, and not shown in the Hackintool images I uploaded earlier, HP16 and HP18 show up as type ExpressCa on ports 0x06, 0x08 respectively. And ExpressCa is not even on the Hackintool's drop-down menu for Connector type. If these the two USB ports on the internal header, should they be type USB 2.0 (type 0 in the dot-dsl, and not type 2)? I'm way out of my knowledge level on this one.
 
Last edited:
Joined
Dec 20, 2018
Messages
148
Motherboard
NUC7
CPU
i5
Graphics
HD 620
Mac
iMac
Mobile Phone
iOS
I got it sorted. I stayed up way way past my bedtime :)

I decided to try the USB Port Patching guide inside of the Hackintool v2.4.9. It may not be the *best* way, and I am open to trying a different approach. This DOES work, and all ports, including the internal header, are now working.

To see the guide, open Hackintool v2.4.9 and go to the USB tab. Select the info-icon in the lower center left icon. Up will pop a Hackintool Help window titled "USB Port Patching".

To use the steps, I first grabbed the SSDT-HP.aml file for THIS guide in this thread provided by Sniki. I opened it in MaciASL (Rehabman fork), found and deleted the USB section, and saved the file to a new name, SSDT-USDT.aml. I then placed that file into /EFI/CLOVER/ACPI/patched and removed SSDT-HP.aml from the same folder. That should have the same SSDT content minus all USB stuff. I did this so that I would be starting the USB port patching steps "clean."

Because the USDT DOES have a USB Controller id 8086:1E31 (for XHC), I followed the instructions and installed Rehabman's FakePCIID.kext and FakePCIID_XHCIMux.kext in /L/E and rebuilt the cache. I then followed remainder of the steps exactly and finally installed the USBPorts.kext into /EFI/CLOVER/kexts/Other and removed USBInjectAll.kext.
Images of the Hackintool USB tab post the fix are attached.
Screen Shot 2019-05-15 at 1.57.40 AM.pngScreen Shot 2019-05-15 at 1.58.02 AM.png
 
Joined
Sep 5, 2017
Messages
2
Motherboard
HP Compaq Pro 6300
CPU
i5-3550
Graphics
RX 550
Mac
MacBook Pro
Mobile Phone
iOS
i'm having a problem on my hp 6300, i would really appreciate help!:) my system installed, boots, but then once its 100% it stays there indefinitely. i'm running bios ver. 3.07 and followed all the steps in the guide, but i did turn on the filevault drivers. also i am using a usb 3 in a usb 2 slot.. any help would be amazing
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,389
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
i'm having a problem on my hp 6300, i would really appreciate help!:) my system installed, boots, but then once its 100% it stays there indefinitely. i'm running bios ver. 3.07 and followed all the steps in the guide, but i did turn on the filevault drivers. also i am using a usb 3 in a usb 2 slot.. any help would be amazing
405853
You don't have any supported graphics. HD2500 and RX 550 are not good choices.
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,667
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
I got it sorted. I stayed up way way past my bedtime :)

I decided to try the USB Port Patching guide inside of the Hackintool v2.4.9. It may not be the *best* way, and I am open to trying a different approach. This DOES work, and all ports, including the internal header, are now working.

To see the guide, open Hackintool v2.4.9 and go to the USB tab. Select the info-icon in the lower center left icon. Up will pop a Hackintool Help window titled "USB Port Patching".

To use the steps, I first grabbed the SSDT-HP.aml file for THIS guide in this thread provided by Sniki. I opened it in MaciASL (Rehabman fork), found and deleted the USB section, and saved the file to a new name, SSDT-USDT.aml. I then placed that file into /EFI/CLOVER/ACPI/patched and removed SSDT-HP.aml from the same folder. That should have the same SSDT content minus all USB stuff. I did this so that I would be starting the USB port patching steps "clean."

Because the USDT DOES have a USB Controller id 8086:1E31 (for XHC), I followed the instructions and installed Rehabman's FakePCIID.kext and FakePCIID_XHCIMux.kext in /L/E and rebuilt the cache. I then followed remainder of the steps exactly and finally installed the USBPorts.kext into /EFI/CLOVER/kexts/Other and removed USBInjectAll.kext.
Images of the Hackintool USB tab post the fix are attached.
View attachment 405812View attachment 405813
Ok thanks for this, i see that i need to add HP17, but what about HP11,HP12,HP13,HP14 ?
Do you have an additional USB Hub or something ?
FakePCIID_XHCIMux.kext is not needed.

I see that HP17 is where your Bluetooth is assigned which my SSDT-USB doesn't have, i will add that.
But what about HP11,HP12,HP13,HP14 ?
Did you connect another dongle with ports into header or something ?
 
Joined
Dec 20, 2018
Messages
148
Motherboard
NUC7
CPU
i5
Graphics
HD 620
Mac
iMac
Mobile Phone
iOS
Ok thanks for this, i see that i need to add HP17, but what about HP11,HP12,HP13,HP14 ?
Do you have an additional USB Hub or something ?
FakePCIID_XHCIMux.kext is not needed.

I see that HP17 is where your Bluetooth is assigned which my SSDT-USB doesn't have, i will add that.
But what about HP11,HP12,HP13,HP14 ?
Did you connect another dongle with ports into header or something ?
HP11-14 appeared as a result of using FakePCIID_XHCIMux.kext. Those are the redirected ports away from the XHC bus. If I didn't use it, then those ports would be HS01-04, on the XHC bus.
You are probably right, that I don't need it. If I count up ports, XHC will have the 4 USB 3 "ports", the 4 USB 2 "ports" on the same physical port, and the internal header of ports of HP17 & HP18 (the left 5 and right 5 pins on the header, respectively, as seen looking from the front of the USDT case).
So, if you are building a new USB section, include HP17 & HP18 for the internal header, and make sure the type is USB 2.0, and you should be all good. I will be happy to test.
 
Joined
May 31, 2019
Messages
4
Motherboard
HP 8300 SFF
CPU
i5 3470
Graphics
Palit GT640
This guide is great, it helped me get my system up and running a few months ago and has been running smoothly. However, last night I let Mac OS update to 10.14.5 and everything went pear shape!

The update completed, but got stuck on first boot at about 20% of the loading bar. Eventually I power cycled the machine and now it won't even POST. I'm getting five beeps and then 10 seconds later the fans start accelerating and until they reach maximum and stay that way until I turn the machine off. The lights on the front remain green throughout all of this, no red lights.

So, far I have:
1) Reseated RAM
2) Tried each stick of RAM separately
3) Pressed CMOS reset button
4) Taken out motherboard battery and replaced
5) Tried booting without video card

All of the above still resulted in five beeps with green lights.

Any ideas? Could this be connected to the Mac OS update or just coincidental hardware failure?
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,389
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Any ideas? Could this be connected to the Mac OS update or just coincidental hardware failure?
@Sniki has already figured this out. Changes to the config.plist are required for updates to go normally.
He should be updating the guide to reflect the changes. Go back to the .4 version for now if you can.
If you didn't make a clone of your previous install you'l just have to be patient till he posts this fix.

wise suggestion for any hackintosh owner

1. Once everything works 100%, make a bootable clone of your system drive !
2. Keep a working macOS USB Installer handy for situations where you can't boot normally.
 
Last edited:
Top