Contribute
Register

[Guide] HP 6300 Pro / HP 8300 Elite - A 100 percent Working and Easily Affordable CustoMac

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,305
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I'm having an issue with my USB ports dying every few minutes. My Sabrent USB audio adapter and IO Gear Bluetooth 4.0 adapter both go undetected, so I manually have to unplug and replug the bluetooth adapter to get my magic mouse and wireless keyboard to get recognized. I heard something about USB changes in El Capitan and Sierra that may cause USB issues, since this does not happen on my Yosemite ssd.

Can you help point me in the right direction please?

I've changed the guide. Step 8 now makes the two DSDT patches required for everyone, not just those that install the Fenvi Wifi/BT card. So if you haven't made that change give it a try and see if it helps with these problems.

Change EHC1 .png
 
Last edited:
Joined
Jun 29, 2017
Messages
21
Motherboard
HP 6300 SFF
CPU
i5 3470
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
That's not the typical "black screen" that hackintoshes encounter, for example, with iMac17,1 or MacPro6,1 system definitions.

My guess is that your video card might be on the fritz... For GT 630, the Nvidia web drivers are entirely optional because it works with Apple's built-in drivers. Have you tried booting in to Windows with that GT 630? Does it have issues?

In a worse case scenario, try getting everything up and running with the Intel graphics first.

Yes, it could be that the graphics card is not working. I don't have a windows machine or any other machine to try this out on.

The 1050 is coming on Wednesday, so that will definitely be insightful, if it works.

You said get it working on intel graphics? It's my understanding from trs96's guide that onboard is not supported for the i5 3470 on the 6300 SFF.

So, I cannot try to get it set up that way, either?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,361
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Oh... Sorry, neglected the fact that you are on a 6300. I don't know if the Intel graphics works on that.

Since you will be receiving a GTX 1050, hopefully that will resolve your problems.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,305
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
The HD4000 will work on both the Elite 8300 or 6300 Pro. Most of these come with a CPU like the I5-3470 or I3-3220 which has only HD2500 and not HD4000 integrated graphics. Some of the Ivy Bridge Intel CPUs with HD4000 are the I7-3770, I5-3475s
and the I3-3225 or I3-3245. That's about it for options with HD4000 graphics from Intel that you could use in either of the 8300 or 6300 models.

HD2500 integrated graphics had a short period of support back in Mountain Lion but it was quickly removed for some reason. :think:
 
Last edited:
Joined
May 16, 2017
Messages
4
CPU
i7 3770k
Graphics
nvidia
Just finished my build following this guide
Here is specs and prices
H/W : HP Compaq Pro 6300 SFF = $135
OS: Sierra 10.12.5
CPU: I5-3570 - 3.4 Ghz (included)
Ram DDR 3: 16GB . = $65
Disk: Boot EFI on Fusion Drive 1TB WD (included) + new SSD 120GB Kington ($52)
Graphic Card: Used ASUS EAH5450(LP) 1GB ATI HD 5450 ($13)
2x15-Pin Female Power Adapter Extension Cable Cord ($3.5)
Total Cost: $268.5

Issues and How to fix
- Display color blinking or dark screen problems on HD5450 needs SwitchResX to fix color (Change Billion to Million Color) ,FakeID and FB= Shrike
- Sound bump and noise on Front/Rare Audio Output used VoodooHDA and VoodooHDA.prePane (Input Gain = 0)

Fusion Drive DIY - tricks
- You must have 2 HDDs disks and 1 SSD disk
- Install macOS on the first HDD (rotating disk) with your Hackintosh method preference
- Then prepare 1 SSD + 1 HDD following this video guide
- install SuperDuper! Clone the first HDD to Fusion Drive
- After finish cloning then use Cover Configurator mount EFI of The first and EFI of Fusion Drive (Fusion Drive contains 2 EFI partitions one on SSD and another one on HDD - choose whatever you want)
- Copy EFI folder from the first HDD(MacOS) to Fusion Drive EFI
- Shut down remove the first disk - boot from Fusion Drive then enjoy Sierra!


Good luck and thanks to this guide . It made my day.
 

Attachments

  • Screen Shot 2017-07-03 at 8.29.18 PM.png
    Screen Shot 2017-07-03 at 8.29.18 PM.png
    367.4 KB · Views: 189
  • Screen Shot 2017-07-03 at 8.28.37 PM.png
    Screen Shot 2017-07-03 at 8.28.37 PM.png
    148.3 KB · Views: 187
  • Screen Shot 2017-07-03 at 8.32.25 PM.png
    Screen Shot 2017-07-03 at 8.32.25 PM.png
    244.1 KB · Views: 172

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,305
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
@neosign A complete build with 16 gigs of ram and a fusion drive for $268 is an amazing job. Congratulations on your new Customac. Which version of VoodooHDA did you use for audio ? I'm using v.2.9.0 because it works perfectly for HDMI audio. Unfortunately analog audio via the onboard jacks is not functional all of the time. Sometimes after a reboot it works at others it doesn't. Still not sure why.

EDIT: Analog audio would stop working because the Apple HDA Disabler kext also needs to be installed with the 2.9.0 kext to prevent the AppleHDA kext from loading at boot up. The HDA disabler kext is attached at the end of Post #1.
 
Last edited:
Joined
May 16, 2017
Messages
4
CPU
i7 3770k
Graphics
nvidia
@trs96
First,I've tried VoodHDA-2.8.8.pkg but no sound on rare audio output and bumping noise sound.

Then I changed to Kextbeast and install
Voodoo.kext-2.9.0d10 - bumping sound audio is still there , removed by config input gain by using VooDooHDA.prePane 289


Edited : Analog speaker on board also works well
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,305
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
@trs96
First,I've tried VoodHDA-2.8.8.pkg but no sound on rare audio output and bumping noise sound.

Then I changed to Kextbeast and install
Voodoo.kext-2.9.0d10 - bumping sound audio is still there , removed by config input gain by using VooDooHDA.prePane 289
Any options show up for HDMI audio in System Prefs -- Sound ?
 
Joined
May 16, 2017
Messages
4
CPU
i7 3770k
Graphics
nvidia
@trs96
Pls find attached pictures. is that what you're looking for?
 

Attachments

  • Screen Shot 2017-07-03 at 9.42.51 PM.png
    Screen Shot 2017-07-03 at 9.42.51 PM.png
    46.1 KB · Views: 147
  • Screen Shot 2017-07-03 at 9.43.42 PM.png
    Screen Shot 2017-07-03 at 9.43.42 PM.png
    68.4 KB · Views: 147

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,305
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Have you tested HDMI audio to see if it works ? With my Nvidia graphics cards the analog audio works after first reboot after installing VDHDA kext. On the next reboot it stops working but HDMI still works.
 
Top