Contribute
Register

[Guide] HP 6300 Pro / HP 8300 Elite - A 100 percent Working and Easily Affordable CustoMac

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,851
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I've run 1440p with no issues from HD4000 displayport and have driven ultrawide displays with no issues as well.
Does your ultrawide have DP input or is it HDMI only ? I think that could be part of the problem for lapslide2010. The DP to HDMI adapter could be at issue here. Most CustoMac's I've seen require an active adapter when used with DP on Macs. Even higher end GPUs like an RX580 need the active Club3D adapter when going from DP to HDMI on a TV monitor with HDMI 2.0.
 
Last edited:
Joined
May 5, 2017
Messages
376
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
  1. MacBook Pro
Does your ultrawide have DP input or is it HDMI only ? I think that could be part of the problem for lapslide2010. The DP to HDMI adapter could be at issue here. Many of them I've seen only do up to 1200p and not 1440p.
All my monitors are running displayport with proper cables.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,851
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Joined
May 5, 2017
Messages
376
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
  1. MacBook Pro
That's one reason I don't suggest replacing those. The 24 to 6 pin adapters are also questionable in my opinion. Many of them are low quality products and can even damage your system when used with a replacement PSU. If anyone wants a higher wattage PSU I usually say, build a new custom PC or get the Optiplex 7010/9010 MT instead.
I did consider this. If I recall their are differences with fan pinouts which makes it harder to run quiet fans. Do you know do they run a standard cooler / can you upgrade the cooler easily?
Also what is the difference between the 7010 and the 9010?
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,851
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Do you know do they run a standard cooler / can you upgrade the cooler easily?
There is a Thermaltake model that fits perfectly. The problem is that the fan is 4 pin PWM and the Dell CPU fan header is 5 pin. The adapters don't really enable PWM control. So it is quieter but fan speed stays constantly high. Not certain at exactly what RPM though. Probably close to 2,000 RPM is my guess. https://www.ebay.com/itm/Thermaltake-CLP0556-B-CPU-Fan-for-Intel-Core-i7-i5-i3/191605523339 Someone with some technical skill could figure out the wiring to make it work. I don't own the MT version so I just use the stock Dell fans in my USFF and SFF.
Also what is the difference between the 7010 and the 9010?
None other than that the 9010s have a raid option in their BIOS that the 7010's don't.
 
Last edited:
Joined
Dec 21, 2012
Messages
61
Motherboard
HP 8300
CPU
I7-3770
Graphics
GTX 1030
Mac
  1. MacBook Pro
Classic Mac
  1. iBook
  2. iMac
  3. Plus
  4. Power Mac
Mobile Phone
  1. Android
@trs96, once again your dedication and knowledge of the Hackintosh project is amazing and appreciated
 
Joined
Dec 17, 2010
Messages
23
Motherboard
HP Compaq Elite 8300 SFF
CPU
i7-3770S
Graphics
HD4000
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
The LG ultrawide in question doesn't have DP input only HDMI inputs.
Thank you for your responses, it's good to know that you have yours working. As the image I get is repeating (and unclear) I'm assuming it may be a timing issue, so will try the suggestions I've found elsewhere and report back. Sorry for the lack of clarity on the description of what I'm seeing, I'll try taking a screen shot today when I'm back at my client's location - not sure it will capture it but I'll give it a go. Cheers all!!
 
Joined
Jul 15, 2012
Messages
38
Motherboard
HP 8300 SFF
CPU
i7-3770
Graphics
HD4000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
My i7 HP 8300 SFF is up and running now. Works great so far with Mojave 10.14.4.

Didnt attempt to get iMessage and FaceTime working yet. Also didn't test any sound outputs because I use a Sonos One as a speaker. Airplay to the Sonos (airpaly2 support) works perfectly.

So far my HD4000 runs my 1440p display great without any lag on animations so far.

Specs:

i7 3770 (Geekbench 4: 4000 Single core, 14000 multi core)
iGPU: HD4000
16GB RAM 4x4GB Hynix HMT351U6CFR8C-PB-N0-AA
500 GB Crucial MX500

Still waiting for a new PSU from Ebay the current one makes some weird noise. (Could be a simple fan replacement but I don't mess with PSU's)

Thank you for a great guide TRS96! By the way I think the reason my USB drive didn't show up in the Boot Menu was because I didn't choose guid partition when I created the drive. In Mojave you have to remember to select "Show all drives" in disk utility or you will miss the option to select correctly and get the guid partition option.



401795
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,851
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
For some reason iMessage works without any configuration? Is that normal?
No, that's a stroke of good luck. You are living a charmed life. Even so I would still create new serials and test them against Apple's data base of registered Macs so there is no conflict.
 
Top