Contribute
Register

[GUIDE] HOW TO FIX AUDIO FOR Mojave after layout ID change

Status
Not open for further replies.
Joined
Jan 3, 2019
Messages
26
Motherboard
Gigabyte Z170X-UD5 TH
CPU
i7-6700K
Graphics
Radeon VII
Inject fake device-id (on HDEF) that does not match the Info.plist of AppleHDAGFX.kext.

@RehabMan do you mind breaking it down how to do that? I just want to disable AppleGFXHDA.kext via Clover.
 
Joined
Feb 23, 2011
Messages
14
Motherboard
ga-z68ma-d2h-b3
CPU
I7 2600
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
Try disabling AppleGFXHDA.kext:
Code:
cd /System/Library/Extensions
sudo mv AppleGFXHDA.kext AppleGFXHDA.kext.bak
sudo kextcache -i /

Then reboot.

If that helps, there are better ways to disable that kext that can be implemented (eg. InfoPlistPatch via Clover KextsToPatch).
This worked for me! Thanks!
But now I don't have the HDMI audio anymore. For now it will not be a problem, I prefer having the mobo audio.
 
Joined
Nov 3, 2017
Messages
13
Motherboard
GA-Z97N-WiFi
CPU
I5
Graphics
RX 560
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hello
I am working on an HP ProBook 450 G3
Processor I7-6500U CPU
HD Graphics 520 (Skylake GT2)
Sound CX20724

I just move from 10.14.4 to 10.14.6 and I cant get back sound as in 10.14.4
I checked carefully all items from first post,
tested several combinations no sound ever

I followed this full discussion
inserted CodecCommander.kext
disabled AppleGFXHDA
no sound ever

So I will be glad to read some advices about what to try next.

all requested files are attached
 

Attachments

  • requested zip.zip
    4.3 MB · Views: 45

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,031
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello
I am working on an HP ProBook 450 G3
Processor I7-6500U CPU
HD Graphics 520 (Skylake GT2)
Sound CX20724

I just move from 10.14.4 to 10.14.6 and I cant get back sound as in 10.14.4
I checked carefully all items from first post,
tested several combinations no sound ever

I followed this full discussion
inserted CodecCommander.kext
disabled AppleGFXHDA
no sound ever

So I will be glad to read some advices about what to try next.

all requested files are attached
remove :
HDAEnabler13.kext

remove all references to AppleHDA in KextsToPatch section

you will also want to update your config.plist to latest one from the laptop guide:
as it has new properties for enabling audio
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,031
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Waoouh
Thank you for your fast and valuable answer
Sound is fixed now

Thank's again
also noticed you have kexts in /s/l/e and /l/e

they should only be in /l/e

check your kextcache output
 
Status
Not open for further replies.
Top