Contribute
Register

[Guide] How to configure your system's SMBIOS correctly?

Status
Not open for further replies.
Joined
Dec 10, 2010
Messages
210
Motherboard
Gigabyte GA-Z270X Designare
CPU
i7-7770K
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Hi.
Has anyone has problems using a newer version of Clover Configurator then the EFI folder was originally built with?
Mine was built with V4920. I'm running Mojave 10.14.6 (18G2022).
 
Joined
Oct 10, 2015
Messages
1,097
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
The first post is outdated because the procedure is now simpler. You could do every step on Clover Configurator without downloading files or opening Terminal, and that ‘Magic Ward’ is replaced with a dropdown menu.
 
Joined
Dec 10, 2018
Messages
51
Motherboard
Z370 AORUS Gaming 7
CPU
i7-8700K
Graphics
Vega 56
Classic Mac
  1. Portable
Mobile Phone
  1. Android
The first post is outdated because the procedure is now simpler. You could do every step on Clover Configurator without downloading files or opening Terminal, and that ‘Magic Ward’ is replaced with a dropdown menu.
Hi! I would also like to change the SMBIOS and bring my configuration from 14.2 to 19.2. I don't know how to proceed. I have just installed the version of Catalina 10.15.4 and the latest version of Clover Configurator. How do I get the values to be entered in the SMBIOS to have a 19.2 configuration?
 
Joined
Oct 10, 2015
Messages
1,097
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi! I would also like to change the SMBIOS and bring my configuration from 14.2 to 19.2. I don't know how to proceed. I have just installed the version of Catalina 10.15.4 and the latest version of Clover Configurator. How do I get the values to be entered in the SMBIOS to have a 19.2 configuration?
Just click on the dropdown menu on the right-hand side and you will see all available options including iMac19,2. Select it and it will automatically fill all values. You can generate a different serial number and UUID on the same page for yourself.
 
Joined
Dec 10, 2018
Messages
51
Motherboard
Z370 AORUS Gaming 7
CPU
i7-8700K
Graphics
Vega 56
Classic Mac
  1. Portable
Mobile Phone
  1. Android
Just click on the dropdown menu on the right-hand side and you will see all available options including iMac19,2. Select it and it will automatically fill all values. You can generate a different serial number and UUID on the same page for yourself.
Yess!!!! it was really simple! Thanks
 
Joined
Apr 12, 2020
Messages
66
Motherboard
Dell OptiPlex 380 vA07
CPU
Core 2 Duo E7500
Graphics
Quadro 410
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
I tried this, just to see if it was possible and was totally bricked, kernel panics every time the graphics system started up. Had to go into single user mode and restore Clover's config.plist from a backup.
 
Joined
Apr 23, 2020
Messages
1
Motherboard
Gigabyte Z390 I Aorus PRO WIFI
CPU
i7-9700KF
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
thank you, solved the jpg Mojave problem by setting iMac Pro !!
.....and now bluetooth is working too with intelbluetoothfirmware kext!!!!
 
Joined
Dec 1, 2020
Messages
16
Motherboard
Gigabyte GA-X79-UP4
CPU
i7-3930K
Graphics
GTX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
**Ok, mild freak out over. Repairing permissions/reinstalling clover 5119/ emptying trash / Replacing old EFI folder has fixed it. I had already tried switching out the EFI folder once, but second time worked out... :crazy: **

Can anyone help? I've managed to brick my config whilst following the lilu headless guide....I'm using clover 5119 as I've found it to be the most stable for my build, 5127 would crash everytime I tried to clear the NVRAM.

This has happened to me once before and I ended up fixing it by doing a clean reinstall but there's got to be a better way...?! I had my machine set to SMBIOS MacPro 7,1 in order to solve a problem but it was giving me a maximum memory warning (I only have 32gb installed but was telling me not to go over 768gb or something crazy). So I duplicated my config and set it to the Sandybridge Headless SMBIOS. On boot I got the warning that the version of OS was not supported on the machine, so had to manually restart.

Now, no matter what config I use, I just hit either the no entry sign, or in -v it stalls and becomes scrambled... then gives me the no entry. I've tried booting in safe, single user, clearing the NVRAM, and resetting the BIOS onboard (thought it might help....).

Is there a better way to come back from this? I've noticed this has happened to a few people on this thread but haven't found a proposed resolution. Haven't found anything in google land yet either.

Bit frustrating as I'd literally just got power management, USB and the graphics all sorted and had one final hurdle to jump...! o_O

TIA people x

p.s I have another machine that I'm going to hook the SSD up to, going to try emptying the trash folder and repairing permissions next.
 
Last edited:
Joined
Jan 26, 2021
Messages
1
Motherboard
Aorus PRO
CPU
Core i9 9900K
Graphics
Radeon RX5700 XT
Mac
  1. iMac
Back one year ago I generated my Serial Number. I also checked it and it was an INVALID serial number. I've checked it today and now I got "Valid purchase date". Can somebody tell me why it's like that and should I change it?
 
Joined
Apr 21, 2016
Messages
65
Motherboard
Gigabyte Z170X UD5
CPU
i7 6700K
Graphics
RX480
Hi, is this part of the instructions important?

Set BooterConfig to 0x28
Set CsrActiveConfig to 0x67

I just set up Catalina using the Unibeast Catalina from this site, and by defauilt these vars are

BooterConfig to 0x28
CsrActiveConfig to 0x3

thanks
 
Status
Not open for further replies.
Top