Contribute
Register

[Guide] High Sierra / Mojave on Dell 5570

Joined
Dec 28, 2018
Messages
23
Motherboard
DELL VOSTRO 3578
CPU
i5-8250U
Graphics
UHD 630 + HD 520
Probably your's touchpad is different.
Delete SSDT-I2C.aml and SSDT-Usb.aml from patched folder.
You will eventually make a patch for your touchpad.
do you mind sharing your recent clover configs with eveything working will help me
 
Joined
Aug 5, 2018
Messages
413
Motherboard
Dell 5570 (clover)
CPU
Intel i5-8250U
Graphics
Intel UHD 620 , 1920x1080
Here you are.
 

Attachments

Joined
Dec 28, 2018
Messages
23
Motherboard
DELL VOSTRO 3578
CPU
i5-8250U
Graphics
UHD 630 + HD 520
the clover file you gave me it have no SSDT-I2C.aml
and it got 5 SSDT-Usb.aml file

any idea how should i go through?sorry it got only 1 not 5 my mistake should i delete?
 
Joined
Aug 5, 2018
Messages
413
Motherboard
Dell 5570 (clover)
CPU
Intel i5-8250U
Graphics
Intel UHD 620 , 1920x1080
Don't know what you mean.
They are in clover/acpi/patched folder.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,719
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Trying to make my hackintosh as close a it gets to real MacBook.
Not having any problem (as far as I can see) , just optimising it).

@RehabMan , can you take a look ?

Ioreg shows :
1) lpcb loaded. Thought that it was not working with newest systems.
Not necessary with your hardware.
But it is loading because you're injecting a compatible LPC device-id/compatible string.

2) sbus (with fixsbus at clover) loaded.
With your hardware, not needed either.
 
Joined
Aug 5, 2018
Messages
413
Motherboard
Dell 5570 (clover)
CPU
Intel i5-8250U
Graphics
Intel UHD 620 , 1920x1080
@RehabMan , Good to see you back.
I have some other questions , too.

1) At my ioreg I have a BOD4@4 device. Is this HDMI Audio?

2) Maybe a stupid question , but here it is . Would be better to have my blueetooth (which connects to usb) as internal or usb3 ?

3) Looking at my kernel log I see some persistent errors.
For example , many errors about audio :

2019-01-09 09:27:44.283345+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
2019-01-09 09:27:44.291761+0200 localhost coreaudiod[134]: <coreaudiod> [com.apple.coreaudio:AudioHAL_Server] HALS_IOA1Engine.cpp:365:EndWriting: HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
2019-01-09 09:27:44.397821+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
2019-01-09 09:27:56.454546+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
2019-01-09 09:27:56.459285+0200 localhost coreaudiod[134]: <coreaudiod> [com.apple.coreaudio:AudioHAL_Server] HALS_IOA1Engine.cpp:365:EndWriting: HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
2019-01-09 09:27:56.464907+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
2019-01-09 09:33:49.492987+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0




acpi errors :

2019-01-09 09:23:08.215336+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.215337+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.215368+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.215369+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.216076+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.216077+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.216106+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.216107+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:


graphics errors :
2019-01-09 07:50:54.053287+0200 localhost kernel[0]: (AppleIntelKBLGraphicsFramebuffer) <AppleIntelKBLGraphicsFramebuffer`AppleIntelFramebuffer::getAttribute(unsigned int, unsigned long*)> [IGFB][ERROR ] getAttribute called when FB0 is in a sleep state - attribute: 'gnps'
2019-01-09 07:50:54.053299+0200 localhost kernel[0]: (AppleIntelKBLGraphicsFramebuffer) <AppleIntelKBLGraphicsFramebuffer`AppleIntelFramebuffer::setAttribute(unsigned int, unsigned long)> [IGFB][ERROR ] setAttribute called when FB0 is in a sleep state - attribute: ' par'
2019-01-09 08:06:53.637753+0200 localhost kernel[0]: (AppleIntelKBLGraphicsFramebuffer) <AppleIntelKBLGraphicsFramebuffer`AppleIntelFramebufferController::hwSetCursorState(AppleIntelFramebuffer*, int, int, bool, bool)> [IGFB][ERROR ] Framebuffer 0 is not enabled yet!


and an error about ssd ?
DiskManagement 0x00007fff456ed518 -[DMManager(Info) wholeDiskSupportsLowLevelFormat:error:] + 262

How can I fix them ?
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,719
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
@RehabMan , Good to see you back.
I have some other questions , too.

1) At my ioreg I have a BOD4@4 device. Is this HDMI Audio?
No.

2) Maybe a stupid question , but here it is . Would be better to have my blueetooth (which connects to usb) as internal or usb3 ?
Your BT controller is likely an internal USB2 device.

3) Looking at my kernel log I see some persistent errors.
For example , many errors about audio :

2019-01-09 09:27:44.283345+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
2019-01-09 09:27:44.291761+0200 localhost coreaudiod[134]: <coreaudiod> [com.apple.coreaudio:AudioHAL_Server] HALS_IOA1Engine.cpp:365:EndWriting: HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
2019-01-09 09:27:44.397821+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
2019-01-09 09:27:56.454546+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
2019-01-09 09:27:56.459285+0200 localhost coreaudiod[134]: <coreaudiod> [com.apple.coreaudio:AudioHAL_Server] HALS_IOA1Engine.cpp:365:EndWriting: HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
2019-01-09 09:27:56.464907+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
2019-01-09 09:33:49.492987+0200 localhost kernel[0]: (IOAudioFamily) <IOAudioFamily`IOAudioStream::safeLogError(int, unsigned long, unsigned long, unsigned long, unsigned long, void*, void*)> +-IOAudioStream[<private>]::safeLogError kErrorLogDumpCounters mStreamErrorCountsUpdated=0
Probably not something to be concerned with.
You could check a real Mac to see if the same logs happen...

acpi errors :

2019-01-09 09:23:08.215336+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.215337+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.215368+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.215369+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.216076+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.216077+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.216106+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
2019-01-09 09:23:08.216107+0200 localhost kernel[0]: (AppleACPIPlatform) <AppleACPIPlatform`AcpiOsVprintf> ACPI Error:
Same.

graphics errors :
2019-01-09 07:50:54.053287+0200 localhost kernel[0]: (AppleIntelKBLGraphicsFramebuffer) <AppleIntelKBLGraphicsFramebuffer`AppleIntelFramebuffer::getAttribute(unsigned int, unsigned long*)> [IGFB][ERROR ] getAttribute called when FB0 is in a sleep state - attribute: 'gnps'
2019-01-09 07:50:54.053299+0200 localhost kernel[0]: (AppleIntelKBLGraphicsFramebuffer) <AppleIntelKBLGraphicsFramebuffer`AppleIntelFramebuffer::setAttribute(unsigned int, unsigned long)> [IGFB][ERROR ] setAttribute called when FB0 is in a sleep state - attribute: ' par'
2019-01-09 08:06:53.637753+0200 localhost kernel[0]: (AppleIntelKBLGraphicsFramebuffer) <AppleIntelKBLGraphicsFramebuffer`AppleIntelFramebufferController::hwSetCursorState(AppleIntelFramebuffer*, int, int, bool, bool)> [IGFB][ERROR ] Framebuffer 0 is not enabled yet!
Same.

and an error about ssd ?
DiskManagement 0x00007fff456ed518 -[DMManager(Info) wholeDiskSupportsLowLevelFormat:error:] + 262
Same.
 
Joined
Mar 6, 2019
Messages
6
Motherboard
Dell 5570
CPU
I7-8550U
Graphics
UHD620
First of all, thank you very much for sharing. My notebook is also dell inspiron 15 5570, the configuration is not the same, i7-8550u & 12G RAM and DVD-RW. Can I use your efi folder?
 
Joined
Aug 5, 2018
Messages
413
Motherboard
Dell 5570 (clover)
CPU
Intel i5-8250U
Graphics
Intel UHD 620 , 1920x1080
You could. Just follow the guide on 1st post and post back results if you need help.
 
Joined
Nov 28, 2012
Messages
29
Motherboard
Gigabyte Z97
CPU
i7-4790K
Graphics
4600
Mac
MacBook Air
Mobile Phone
iOS
I have the same laptop; Dell 5570 with i5-8250u except for touchscreen. With your setup, I could easily install MacOS. Two things happened.

Instant Wake after sleep.

It goes sleep but wakes up again if there is an USB mouse receiver. Putting SSDT-GPRW.aml in Clover/ACPI/Patched solved the issue. I also applied a clover DSDT patch; Method(GPRW,2,N) to XPRW.

Trackpad sensitivity issue.

Trackpad work but not smooth. The cursor was jumping or stopping. The trackpad device ID is 0x9D60 and name is TPD0.

  1. Deleted VoodooPS2Mouse.kext and VoodooPS2Trackpad.kext in VoodooPS2Controller.kext/Contents/PlugIns/
  2. Updated SSDT-XOSI.aml to the latest version, which includes Windows 2018,2. (Windows 10 1809).

Now it works fine. Moving pointer, inertia scrolling, zooming in/out, touch screen with multitouch, all works. It worked with or without SSDT-I2CX.aml.

Thanks.
 
Last edited:
Top