Contribute
Register

[Guide] Gigabyte Z68MA-D2H-B3+EVGA GTX650

Joined
Aug 17, 2011
Messages
309
Motherboard
GA-Z270MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
This worked for me for upgrades ( will make a guide on full install later in new thread for high sierra)

Firstly, I had to delete my old EFI folder and install the newest clover setup the smbios in config.plist to 14'2 imac and if you have a SSD you wil need to add apfs.efi Copy apfs.efi to /EFI/CLOVER/drivers64UEFI/
Also make sure you update to the latest FAKESMC.kext /EFI/ClOVER/Kexts/Other
Secondly, setup the SIP settings 0x28 and 0x67
For more info if you dont want apfs etc. check out tonys thread
https://www.tonymacx86.com/threads/update-directly-to-macos-high-sierra.232707/


-I updated clover used the following settings for sip 0x28 0x67
-updated to 10.13
-added clover new commands for loading nvidia driver
1. Mount EFI Partition
2. Open /Volumes/EFI/EFI/CLOVER/config.plist with text edit, Xcode, or Plist Editor Pro
3. Edit as shown below:

Code (Text):
<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>YES</string>
<key>InjectSystemID</key>
<true/>
<key>NvidiaWeb</key>
<true/>
</dict>

4. Remove Boot/Arguments/nvda_drv=1 (does not work for High sierra)
5. Save and reboot

-boom everything worked fine

P.S. note that you must install nvidia driver only if you need it. If your system has a supported video card it will work out of the box for example on my gtx 640 and 650 both worked out of the box didn't need anything



Very good explanation. How much of this is relevant now that Mulitibeast 10.1 is out?
 
Joined
Aug 17, 2011
Messages
309
Motherboard
GA-Z270MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
I am up to the point now where I have installed the.u1c UEFI BIOS and installed High Sierra on a SSD using unibeast 8.1 and configured it with multibeast 10.1. The problem now is that the SSD will only boot if the installer USB is plugged in. Without the USB the High Sierra installation begins to boot, but quickly has, what I think is called, a kernel panic. Verbose mode spits out a lengthy log, most of which I have been unable to capture. I look forward to seeing what developments unfold for this venerable old mainboard.

In the meantime, an older installation of El Capitan that I have on a hard disk drive is working remarkably well under the new UEFI bios
 
Joined
Oct 23, 2010
Messages
321
Motherboard
z68a-d3-b3
CPU
i7-3770k
Graphics
GTX 650
Currently, High Sierra has too many issues. Sierra works perfectly. I recommend using that just till more bugs are smoothed and ironed out. More people have issues than stability atm. I myself went back to Sierra.
 
Joined
Aug 17, 2011
Messages
309
Motherboard
GA-Z270MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
Currently, High Sierra has too many issues. Sierra works perfectly. I recommend using that just till more bugs are smoothed and ironed out. More people have issues than stability atm. I myself went back to Sierra.
I have Sierra working well now. Aside from artifacts in the HD 3000 graphic output I am pretty happy. I'm looking for a video card. I'm also wondering how much benefit I would get out of upgrading to a 3rd generation processor. A core i 3570 or 3770 perhaps.
 
Last edited:
Joined
Aug 17, 2011
Messages
309
Motherboard
GA-Z270MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
Perhaps I spoke too soon. Got Sierra working pretty well, except when it doesn't. By which I mean to say, that I'm experiencing crashes/freezes on the order of one every hour or two.
 
Joined
Aug 17, 2011
Messages
309
Motherboard
GA-Z270MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
The graphical output has gotten much better. Seeing very little in the way of artifacts, lines and so forth. Another little glitch I've noticed is that it loses sound from time to time. Sometimes I have to restart Safari and others I have to restart the computer to regain the sound.
 
Joined
Oct 23, 2010
Messages
321
Motherboard
z68a-d3-b3
CPU
i7-3770k
Graphics
GTX 650
The graphical output has gotten much better. Seeing very little in the way of artifacts, lines and so forth. Another little glitch I've noticed is that it loses sound from time to time. Sometimes I have to restart Safari and others I have to restart the computer to regain the sound.

Many of my machines are core i3.. in fact, i do not purchase i5 or i7 unless it's required. I only use the computer based on my needs. Firstly, I do not game. Secondly, I use my computer for university stuff, homework, youtube music/videos etc.
with that being said you can play almost any game on a i3 the video card is the most important requirement. Also to fix your issues buy a new video card nvidia gtx 700 series if your on a budget / usb audio card it works 100x better then onboard no more broken audio after sleep or youtube stuff. Just add these two items and you will be very surprised at how things will become like vanilla oem mac!! they just work better.
 
Joined
Aug 17, 2011
Messages
309
Motherboard
GA-Z270MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
...Just add these two items and you will be very surprised at how things will become like vanilla oem mac!! they just work better.
My uses are similar to yours. I recently sold my i3 processor and bought a used i5 2500K. I have already purchased an nvidia video card. I'm hoping it will arrive a few days. I think I've noticed that you have some computers with third-generation processors. Do you have any experience using them with this motherboard? If so what do you think about them?
 
Joined
Oct 23, 2010
Messages
321
Motherboard
z68a-d3-b3
CPU
i7-3770k
Graphics
GTX 650
My uses are similar to yours. I recently sold my i3 processor and bought a used i5 2500K. I have already purchased an nvidia video card. I'm hoping it will arrive a few days. I think I've noticed that you have some computers with third-generation processors. Do you have any experience using them with this motherboard? If so what do you think about them?
I just buy CPU's that are that have the build in GPU that has built-in osx drivers in case i ever need to use a computer without internal video card. ie intel hd 3000, intel hd 4000. etc..
 
Joined
Aug 17, 2011
Messages
309
Motherboard
GA-Z270MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
I just buy CPU's that are that have the build in GPU that has built-in osx drivers in case i ever need to use a computer without internal video card. ie intel hd 3000, intel hd 4000. etc..
I paid $25 for an NVIDIA GeForce GTS 450 video card with 1 GB DDR5 VRAM. I used MultiBeast to make the machine ready for the NVIDIA card, restarted, and the video card began working flawlessly. After I upgraded to Sierra, but before I installed the Video card, my computer was crashing three or four times a day. Now with the video card, it has not crashed once. I also fixed Messages with the help of the tonymacx86 iDiot's guide and now iTunes, Messages, and FaceTime are working perfectly. At this point, my six-year-old custom Mac leaves me with very little to complain about. My next task is to try to find a 2560 x 1440 2K Monitor for as close to $0 as possible see if it will work with my computer and my $25 video card.
 
Top