Contribute
Register

[GUIDE] Gigabyte X99 GA-X99-Designare EX i7-6950X

Joined
Sep 15, 2012
Messages
195
Motherboard
Gigabyte LGA2011-3 Intel X99 GA-X99-Designare EX
CPU
i7-6950X
Graphics
GTX 750 Ti
Mac
MacBook Pro
Screen Shot 2017-02-08 at 12.45.45 PM.png


Here is my build...


Gigabyte LGA2011-3 Intel X99 GA-X99-Designare EX
https://www.amazon.com/dp/B01FY8CC4E/?tag=tonymacx86com-20

Intel Core i7-6950X Processor Extreme Edition) 3.0
https://www.amazon.com/dp/B01FJLA9IM/?tag=tonymacx86com-20

Corsair LPX 32GB DRAM 3000MHz DDR4
https://www.amazon.com/dp/B014UYPEXE/?tag=tonymacx86com-20

Intel 600p Series 256GB M.2 80mm SSD
https://www.amazon.com/gp/product/B01K375Q6C/?tag=tonymacx86com-20

Corsair Enthusiast Series TX 750 PSU
http://www.amazon.com/dp/B005E98FVS/?tag=tonymacx86com-20

Inateck PCI-E to USB 3.0 5-Port PCI Express Card
https://www.amazon.com/dp/B00FPIMJEW/?tag=tonymacx86com-20

Gigabyte GV-N75TOC2-2GI GTX 750 Ti OC Graphics Card
https://www.amazon.com/gp/product/B015E9VDC0/?tag=tonymacx86com-20

Intel I210-T1 Network Adapter E0X95AA
https://www.amazon.com/gp/product/B00ESFF2JC/?tag=tonymacx86com-20

What is working…
Both monitors
Both ethernet ports
USB ports
M.2 SSD

What is not working...
Audio (I am running a firewire interface for audio)
Intel I210-T1 Network Adapter


Motherboard
Update Bios to F4c
http://www.gigabyte.com/Motherboard/GA-X99-Designare-EX-rev-10#support-dl

Go into bios, use "load optimized defaults"
Save

USB
1. Download 10.12.3 version or later of Apple software by performing the following:

Delete the current version of MacOS Sierra from Applications folder, if it exists.

Go to App Store, and download Sierra. This downloads the latest version.

While you are waiting for the download, go to step 2.

2. Prepare a thumb drive as follows with Disk Utility:

GUID Partition Table

Mac OS Extended (Journaled)

Use the name “USB”

3. When the MacOS download completes, pop up a Terminal, and type the following:

sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app --no interaction

Note: This will take a few minutes….

When this step is completed, the USB drive will change names to Install macOS Sierra

4. Download latest versions of Clover Configurator and Clover.

5. Use Clover Configurator to Mount the EFI partition of the USB drive.

6. Run Clover

Click Continue Twice

Click “Change Install Location” & select the USB drive

Click Continue

Click Customize

Install for UEFI booting only

Install Clover in the ESP

Click Install

Clover will automatically mount the EFI drive.

When Clover Installation completes, move the entire contents of the EFI Master folder into to the EFI Partition EFI folder

Eject EFI Partition

Restart computer with USB drive and follow the prompts to install Sierra

Restart computer and once you are at the desktop…

Use Clover Configurator to Mount the EFI partition of the USB drive.

Copy the entire EFI folder to the desktop

Run Clover

Click Continue Twice

Click “Change Install Location” & select the Macintosh Hard Drive

Click Continue

Click Customize

Install for UEFI booting only

Install Clover in the ESP

Click Install

Clover will automatically mount the EFI drive.

When Clover Installation completes, move the entire contents of the EFI folder from the desktop into to the Macintosh EFI Partition EFI folder

Eject EFI Partition

Download and install the nvida driver for 10.12.3
http://www.nvidia.com/download/driverResults.aspx/114669/en-us

Download and apply
AGDPfix

Restart computer

F12 at BIOS and choose UEFI partition of new hard drive as primary drive..

Follow the link to generate your own serial number (please do not use mine)
https://www.tonymacx86.com/threads/spares-box-htpc-poc-build-ga-b85m-ds3h-a-i3-4330-geforce-gt640-10-11-4.189452/

USB speeds have not been tested, but all are working with 2.0/3.0 devices so far...
That should be it. Change any part of this at your own risk.
This took 2 months of digging thru forums to find what will work on this board and cpu combo...
i am no genius...just got lucky on this one


 

Attachments

Last edited:
Joined
Jul 26, 2013
Messages
48
Motherboard
GA-X99P-Designare-EX
CPU
Xeon E5-2697v4
Graphics
GTX 780
Mac
MacBook
Mobile Phone
Android
Thank you for the guide! This is a big help. When I try to install from the USB drive I get stuck at +++++. (See attached image)

Any Ideas?

GA-Designare EX
e5-2697v4
nvidia GTX 780
 

Attachments

Joined
Sep 15, 2012
Messages
195
Motherboard
Gigabyte LGA2011-3 Intel X99 GA-X99-Designare EX
CPU
i7-6950X
Graphics
GTX 750 Ti
Mac
MacBook Pro
Thank you for the guide! This is a big help. When I try to install from the USB drive I get stuck at +++++. (See attached image)
Double check your installation on your USB.
Wipe it clean and reinstall with the instructions above.
Basically you are copying the EFI folder in place of the one created by Clover.
It will boot to the Clover screen if it is installed correctly.
 
Joined
Jul 26, 2013
Messages
48
Motherboard
GA-X99P-Designare-EX
CPU
Xeon E5-2697v4
Graphics
GTX 780
Mac
MacBook
Mobile Phone
Android
Double check your installation on your USB.
Wipe it clean and reinstall with the instructions above.
Basically you are copying the EFI folder in place of the one created by Clover.
It will boot to the Clover screen if it is installed correctly.
Thank you Michaiel! That is exactly what I did and thank you for compiling that BTW! Would have taken me days to do all that... Actually, I figured it out and the main problem I had was that I didn't set the "nv_disable" boot argument. Once I did that, I was able to install no problem and add the nvidia web driver.
 
Joined
Sep 15, 2012
Messages
195
Motherboard
Gigabyte LGA2011-3 Intel X99 GA-X99-Designare EX
CPU
i7-6950X
Graphics
GTX 750 Ti
Mac
MacBook Pro
Excellent...make sure to YOUR version for the nvidia driver by opening the same image
I have at the top and click on the 10.12.3.
It will show you the current nvidia driver (mine was 16D32) number you need to download.
Run the AGDPfix BEFORE restarting the computer or you will have no graphics on the monitor screen
 
Joined
Jul 26, 2013
Messages
48
Motherboard
GA-X99P-Designare-EX
CPU
Xeon E5-2697v4
Graphics
GTX 780
Mac
MacBook
Mobile Phone
Android
@michaiel, thanks for all your help so far! Did you by chance test the thunderbolt 3 on your build? I can't seem to get it working. Tried with the startech TB3-TB2 adapter to a G-raid. This setup works perfectly on my GA-170X-UD5-TH. On that build I had to update the TB3 firmware via a Windows 10 install before it would work in macos. However, there is no furmware update for the x99 designare on the Gigabyte site. Any ideas? Thanks again!
 
Joined
Sep 15, 2012
Messages
195
Motherboard
Gigabyte LGA2011-3 Intel X99 GA-X99-Designare EX
CPU
i7-6950X
Graphics
GTX 750 Ti
Mac
MacBook Pro
I have not tested thunderbolt 3 yet. Glad to here most of it is working for you so far....
 
Joined
Feb 1, 2017
Messages
15
Motherboard
GA-X99 Designaire EX (rev 1)
CPU
Intel i7 6950X
Graphics
GTX 1060 Xtreme Gaming 6GB
@michaiel, thanks for all your help so far! Did you by chance test the thunderbolt 3 on your build? I can't seem to get it working. Tried with the startech TB3-TB2 adapter to a G-raid. This setup works perfectly on my GA-170X-UD5-TH. On that build I had to update the TB3 firmware via a Windows 10 install before it would work in macos. However, there is no furmware update for the x99 designare on the Gigabyte site. Any ideas? Thanks again!
Hey Apples2Oranges, just wondering if you've had any luck with your startech TB3-TB2 and the X99 designaire?

I followed this guide in an attempt to get TB visible in OSX- basically install windows and update firmware https://www.tonymacx86.com/threads/thunderbolt-3-success-ga-z170x-ud5-th-startech-thunderbolt-3-to-thunderbolt-adapter.200902/
The changes to Intel(R)Thunderbolt in BIOS described in the guide results in a boot hang at [PCI Configuration begin] and to get back into Sierra I have to go back to BIOS and hit F7 to load optimised results, then on Chipset screen change Intel Virtualization Technology VT-x to Enabled (from Rocket88's awesome guide which I followed for my build https://www.tonymacx86.com/threads/rocket-88-i7-6950x-gigabyte-ga-x99-designare-ex-sierra-10-12-2.210140/).
Once back in OSX my Thunderbolt devices don't seem to be detected, probably because I changed the thunderbolt BIOS settings back to normal- I've tried playing around with those settings but any changes mean I cant boot OSX.

It actually took me 2 weeks of despair to get OS X to boot at all after installing win10 - thanks to RehabMan and GoingBald for helping figure this out

I'm now trying to get my uad apollo To connect to OSX via the startech adaptor again and was curious as to your progress!
Many thanks!
 
Joined
Aug 25, 2013
Messages
1
Motherboard
Gigabyte X99-Phoenix SLI-CF (F6c)
CPU
i7-5950X
Graphics
GTX960
Mac
MacBook Air
Mobile Phone
iOS
Super thank you, michaiel!!!
I just followed your steps, and I just had a workable macOS Sierra on my PC.
 
Joined
Mar 7, 2017
Messages
31
Motherboard
Gigabyte X99 Designaire
CPU
i7-6900k
Graphics
Nvida (2) 1080 ti
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
I also cannot figure out how to get the Thunderbolt 3 port to work on this motherboard in windows or in Sierra 12.2.3. Its driving me crazy.

Hopefully we can get some help here. Continuing to search for solutions both windows/mac. Will update if any info is found.
 
Top