Contribute
Register

[Guide] Gigabyte BRIX using Clover UEFI (GB-BXi5H-4200/GB-BXi5-4570R/GB-BXi7-4770R)

Joined
Aug 11, 2011
Messages
1
Motherboard
Mac OS X Lion 10.7.5 (11G63)
CPU
3.39 GHz Intel Core i5
Graphics
Intel HD Graphics 3000, 512 MB
Mac
Classic Mac
Mobile Phone
Android, iOS
Thank you very much for your work on the Brix! I now have my 4200 as a perfect Hackintosh.
Thanks!
Nicolas
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Jun 7, 2013
Messages
40
Motherboard
Alienware Aurora R7
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
1x HDMI and 1x DP.

I updated the plist, and used iMac 16,2
It gets to the Apple loading screen and then just black screen. Safe boot seems to work.
I'm having the same model as yours Brix i7-5775R, I can get the miniDisplay port to output 3440x1440p in Windows, but I can't get it with Hackintosh, Did you eventually get it to display 4k ? if yes, would you mind share what you have done to fix it ? thank you.
 
Joined
Mar 7, 2019
Messages
2
Motherboard
Gigabyte Brix GB-BRi7H-8550
CPU
i7-8550U
Graphics
HD620
Mac
MacBook Pro
Hey guys, first of all thanks for all the great work to make hackintoshing as easy as possible for noobs like me! I'm in IT since 25 years and using Macs since 5 years only, but I've already learned a lot ... although not enough yet it seems ... Anyways, given the soldered-or-glued-in-everything approach of Apple nowadays, Hackintoshing seems the only way forward.

Ok, now I'm looking for help with this cute litlle GB-BRi7H-8550 because wifi simply won't turn on. I've got 3 pcs of the BCM94360CS2 and none could be turned on. It also doesn't work in Windows with the Bootcamp drivers (it seems it can be turned on but doesn't find any SSIDs)

Bluetooth is working fine all the time though. Wifi never did whatever I tried.

The only true root cause I can imagine right now is that the adapter isn't working. I bought it from Aliexpress:
And this is how the card looks like: (antennas had been attached of course)

View attachment 397454

There are lots of coredumps from the broadcom driver in Konsole. I'm also attaching one of them.

When the BRIX is booted I can see that the wifi is turning on briefly for 1 or 2 seconds and then it shuts off.

i followed this guide ([Guide] Gigabyte BRIX using Clover UEFI (GB-BXi5H-4200/GB-BXi5-4570R/GB-BXi7-4770R))

Currently graphics are not accelerated and sound also isn't working with this config but I had these working fine already. The performance of this little box is incredible BTW, just the fan is a little annoying. I hope the fan can be controlled using iStat menu once the sensors are functional...

So what do you think about the wifi issue?
 

Attachments

Joined
Nov 5, 2018
Messages
9
Motherboard
Asrock Deskmini 310
CPU
I7-8700
Graphics
UHD 630
You're welcome. Enjoy!
Hi RehabMan

I followed your guide, everything worked but bluetooth, my wifi card is bcm943224hmp.

I though it was because the card issue, so I switched this card to my HP 8470p, which is also a hackintosh build thanks to your guide, and the bluetooth worked!

Why bluetooth does not work on Brix-i5-4200?

Is there anything I need to do or modify on my brix-i5-4200?

Thank you.
 
Joined
May 28, 2010
Messages
47
Motherboard
Dell Chromebox 3010
CPU
i3-4030U
Graphics
HD 4400
Mac
MacBook, MacBook Air
Mobile Phone
Android, iOS
Hi RehabMan,

Does X86PlatformPlugin load in your configuration? I have a similar mini-desktop with an i3-4030U and HD 4400 that seems very much aligned with your config.plist's Clover patches.

There is some speed stepping and power fluctuation apparent from Intel Power Gadget and OpenCL works, but only ACPI_SMC_PlatformPlugin loads. I do inject plugin-type=1. I'm wondering if perhaps the unsupported CPU / PCH errors I get at boot mean that I still need to spoof the CPU device ID or make some DSDT modifications. I am using an iMac 14,1 SMBIOS.

Just wondering if you encountered anything similar to what I'm working through as you built out the configs for the Brix.

Thanks!
 
Joined
Sep 16, 2019
Messages
1
Hi RehabMan,

your Clover configuration works like a charm on my old Brix Pro. You helped me a lot. Thank You very much!
 
Joined
Mar 5, 2016
Messages
23
Motherboard
LEGION Y530
CPU
i7
Graphics
UHD 630
Mobile Phone
Android, iOS
Hi RehabMan,

I have an old brix (no pro). == BRIX GB-BSi7-6500

i tried your tutorial but it seems it doesnt work for my model.

Install works fine using the config_install_broadwell.plist but system keeps rebooting after trying to run it from SSD
if i try the config.plist (non broadwell) it simply freezes.

Any idea's for this model ?? thank you

Edit : i was able to install and boot Mojave.. everything works except for audio / hdmi audio

Edit2 : everything working now after.... Updating my bios to 2019 revision
 
Last edited:
Joined
Apr 1, 2017
Messages
101
Motherboard
Asus Strix Z370-G Gaming (Wifi AC)
CPU
i7-8700K
Graphics
580
Mobile Phone
iOS
I have a Brix i3-4010U (bios 9), 256gb msata, and 16gb, running 10.15, 19A603. 14,1 iMac SMBIOS.

I have in EFI\EFI\Clover\Drivers\UEFI the following:
apfsdriverloader.efi, aptioinputfix.efi, aptiomemoryfix.efi, audiodxe.efi, datahubdxe.efi, fsinject.efi, hfsplus.efi, smchelper.efi.

I have in EFI\EFI\Clover\kexts\other the following:
applealc.kext, fakesmc.kext, lilu.kext, realtekrtl8111.kext, usbinjectall.kext, and whatevergreen.kext. I also added rtwlanu.kext and rtwlanu1827.kext for a usb wireless card, as I do not have the Broadcom PCIe card in place (yet).

I also notice, after running the RehabMan install scripts, that I have (mostly) the same files (same version, too) in bootdisk\Library\Extensions\.

I think I can thus safely remove one of these two sources, right? I don't need both? Which one "wins" if I have a later version in one place but an earlier version in the other?

I use Kext Updater to keep my Kexts up to date, and so I think I should focus on what's in EFI\EFI\.... location, but ... what's best?
 
Top