Contribute
Register

[GUIDE] Getting R9 290/390 (non-X) to work on Sierra (10.12) AND High Sierra (10.13)

Joined
Oct 21, 2017
Messages
9
Motherboard
ASRock H97 Anniversary
CPU
i5-4440
Graphics
R9 290
Mobile Phone
Android
Hi all :)
I've tried patching my kexts to get my R9 290 working on Mojave. However, I seem to get "Kext signature validation error code -67030" despite me having SIP disabled. I also tried this on HS on a separate install but get the same error :/ Any clues? I've done this before on Sierra in the same way so I don't see why it's changed upwards.

I've only modified the 3 kexts I wrote some posts above following the procedure in the 1st post (so, using those terminal commands, but without touching clover and BIOS settings), and my 290 works perfectly on Mojave (yesterday I reinstalled all the OS, and GPU works fine). Why don't you try?
 
Joined
Feb 14, 2016
Messages
39
Motherboard
ASRock Z77 Fatal!ty Professional
CPU
i5
Graphics
R9 290
Mac
iMac
Mobile Phone
Android
I've only modified the 3 kexts I wrote some posts above following the procedure in the 1st post (so, using those terminal commands, but without touching clover and BIOS settings), and my 290 works perfectly on Mojave (yesterday I reinstalled all the OS, and GPU works fine). Why don't you try?
Working! :D :D

Thank you for your help
 
Joined
Dec 14, 2011
Messages
4
Mac
Classic Mac
Mobile Phone
In order to make work my R9 290, I've modified the following kexts:
- AMD8000Controller.kext (twice, as said in this guide);
- AMDRadeonX4000.kext (as said in this guide);
- AMDRadeonX4000HWServices.kext (adding GPU id, 0x67B11002, in the right place, but now I can't verify exactly the line where I've added it).

I've installed whatevergreen, lilu and all required kexts. Now all works natively, WITHOUT any clover inject and setting external GPU (R9 290) as primary in the BIOS, so screen is visible during boot. Displayed name in system info is "Radeon 8xxx" (or something similar), but GPU acceleration works without any problem. I hope this can help.

My Sapphire R9 390 Working Perfectly with your guide on Mojave as primary in the Bios with visible screen during boot.
THANKS!!!!
 
Joined
Oct 29, 2013
Messages
17
Motherboard
ASUS ROG STRIX Z270F GAMING
CPU
i7-7700K
Graphics
RX 570
Mac
iMac
Classic Mac
iBook, iMac, PowerBook
Mobile Phone
iOS
I finally managed to get it to work by following l1nkdna's tutorial and everything works fine, except it only works on Sierra. HS & Mojave immediately Kernel Panics if you try to boot it with the custom HEX. I'm now stuck on this version until i buy a different and compatible gpu :D (ASUS R9 290)
 
Last edited:
Joined
Jul 23, 2014
Messages
90
Motherboard
GA-Z270X-Gaming 7 Aorus
CPU
i7 7700K
Graphics
HD 630 + GTX 1050 T
Mac
iMac
Mobile Phone
iOS
hey guys,

I managed to get my R9 390 8GB to be recognised by Mojave using the method francescobabbaro suggested however I can only boot from my IGPU and if I switch I just get a black screen. Im trying to use DP. Could that be the issue?

In system report it shows up as AMD Radeon HD 8xxx at 8192mb which is correct from what I've read.

Any ideas would be appreciated,

Thanks
 
Joined
Oct 10, 2011
Messages
25
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700
Graphics
GTX 1060
Mac
MacBook Pro
Mobile Phone
iOS
This post was originally put up in Dec 2016, then says it will be updated in "about a week" for High Sierra. Two Years later, is this necessary to get a RX 290 working with High Sierra? Is there a more updated guide somewhere else?
 
Joined
Dec 1, 2014
Messages
12
Motherboard
gigabyte z97x gaming 5
CPU
intel i7 4790k
Graphics
sapphire vapor-x r9 290
Mac
Classic Mac
Mobile Phone

Attachments

Top