Contribute
Register

[Guide] Getting Nvidia cards to work on Thinkpad P71

Status
Not open for further replies.
Joined
Aug 9, 2019
Messages
29
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
I got to the installer and when I install from the USB drive I get the clover boot loader and I select install OS X and then an apple with a black screen loads and it then hangs 3/4 of the way through- I followed all the steps you listed and the faq you pointed to. What do you think it might be?
 

Attachments

  • F5AC0846-F267-44BB-8F82-F6F13375B867.jpeg
    F5AC0846-F267-44BB-8F82-F6F13375B867.jpeg
    1.7 MB · Views: 59
Joined
Oct 10, 2018
Messages
32
Motherboard
Supermicro X11DPH-i
CPU
ES-6149
Graphics
GTX 760
Mac
  1. MacBook Pro
I got to the installer and when I install from the USB drive I get the clover boot loader and I select install OS X and then an apple with a black screen loads and it then hangs 3/4 of the way through- I followed all the steps you listed and the faq you pointed to. What do you think it might be?
try with usb2.0 or just try a few more times. It's always like that the first few times around. It will be fine once you installed it.
 
Joined
Aug 9, 2019
Messages
29
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
Ok I got it partial installed then at 2 minute mark installing OS X gave me errors. Did you install OS X on your solid state drive or on you 7200 rpm sata drive?
 
Joined
Aug 9, 2019
Messages
29
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
I have done multiple installs and have problem getting clover to boot from my pc after installed the operating system. I have reinstalled it multiple ways. I followed the step by step you link too. I used Unibeast. I used Unibeast and put in your kexts replacing the entire Unibeast EFI file with your default one. So I have successfully installed osx but it does not boot from my hard drive with out the usb drive. I am confused can I reach out to you on discord. I am so close to completing this cause I have had a full working Hackintosh but I can't boot it again without using the installation usb. I have erased and reinstalled my install usb multiple times too.
 
Last edited:
Joined
Oct 10, 2018
Messages
32
Motherboard
Supermicro X11DPH-i
CPU
ES-6149
Graphics
GTX 760
Mac
  1. MacBook Pro
I have done multiple installs and have problem getting clover to boot from my pc after installed the operating system. I have reinstalled it multiple ways. I followed the step by step you link too. I used Unibeast. I used Unibeast and put in your kexts replacing the entire Unibeast EFI file with your default one. So I have successfully installed osx but it does not boot from my hard drive with out the usb drive. I am confused can I reach out to you on discord. I am so close to completing this cause I have had a full working Hackintosh but I can't boot it again without using the installation usb. I have erased and reinstalled my install usb multiple times too.
Can you check if you have secure boot disabled? Turn on csm as well. You need to replace efi on your harddrive. Go into windows, download
https://www.diskgenius.com
And load EFI sector on your macos drive. There will be a EFI folder, replace the whole thing with my EFI folder.
If it still doesn't work, add me on discord evn#9731
 
Joined
Aug 9, 2019
Messages
29
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
Can you check if you have secure boot disabled? Turn on csm as well. You need to replace efi on your harddrive. Go into windows, download
https://www.diskgenius.com
And load EFI sector on your macos drive. There will be a EFI folder, replace the whole thing with my EFI folder.
If it still doesn't work, add me on discord evn#9731


Hey I am attempting a Clean reinstall I messaged you on discord. Still trying to get this to work again.
 
Joined
Aug 9, 2019
Messages
29
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
I have this working perfectly. I found the mistake I made in the initial install. your directions were perfect.
 
Joined
Oct 10, 2018
Messages
32
Motherboard
Supermicro X11DPH-i
CPU
ES-6149
Graphics
GTX 760
Mac
  1. MacBook Pro
I have this working perfectly. I found the mistake I made in the initial install. your directions were perfect.
great to hear. Enjoy your full hackintosh experience.
 
Joined
Jun 5, 2019
Messages
4
Thank you for your excellent work! I followed your guide and install MacOS 10.13.6 on my P71(E3 1505M, 4K,P3000).
But all the usb can't work with USB3.0 devices, also the Thunderbolt can't recognize the external SSD.
Should I change the Bios setup or other things? I holp to join your Chinese discuss group if possible.
 
Joined
Jun 5, 2019
Messages
4
(1) The folder named EFI is the one I'm currently using, which is what I recommend for most use cases.
The internal screen uses Intel integrated graphics, while any external monitors connected through HDMI or DP uses Nvidia graphics card. This allows you to have maximum battery life while having the flexibility to have more horsepower when you need it.
Some software can still utilize discreet GPU even without an external monitor connected. For example, Adobe Premiere and Davinci Resolve (the software I use) can still utilize Nvidia GPU to accelerate video encoding/decoding.
(2) The folder named EFI_1 is there in case you only want to use Nvidia GPU and nothing else.
In order to use EFI_1, you will have to turn off IGPU inside Graphics settings in BIOS.
Rename EFI_1 to EFI if you want to use it.

If you find yourself in a situation where you don't have access to an external monitor and still need the GPU horsepower, then this option makes sense for you. Obviously, this comes with some downsides, mainly worse battery life, and no brightness control for internal display.

4. Download and install Nvidia web driver

The best and easiest way to install Nvidia web driver is to use a script, which you can find it here:
Credit: Benjamin-Dobell

5. All done, enjoy your Hackintosh experience
One more thing, you will need a Hackintosh compatible Wifi card in order to use wifi or Bluetooth.
DW1560 or DW1830 for example.

Thanks for your guide again. I followed your guide, flashed the VBios, Install High Sierra 10.13.6, but the Thunderbolt &USB3.0 didn't work. I fixed the USB3.0 with Hackintool 2.8 but have no idea with the Thunderbolt.
I also tried your "EFI_1", unfortunately, the internal screen is black&HDMI has no signal.
 
Status
Not open for further replies.
Top