Contribute
Register

[GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

Joined
Feb 25, 2013
Messages
23
Motherboard
Asus Maximus IX Hero
CPU
Intel Core i7 7700-K
Graphics
Intel HD 630
Im running Mojave 10.14.4.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
6,619
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Im running Mojave 10.14.4.
I have seen various issues when using multiple monitors with internal GPU. Please connect only 1 monitor and check system behavior. If system boots up properly every time (no black screens) then try the other monitor (again, only 1 monitor at a time).
 
Joined
Feb 25, 2013
Messages
23
Motherboard
Asus Maximus IX Hero
CPU
Intel Core i7 7700-K
Graphics
Intel HD 630
That works everytime.
If i only have the HDMI connected and boot np.
If i only have the DP connected and boot it works too.

Only if i plug in the second one it crash.
I dont get it like i said it worked a few times.
After Shutdown the system it doesnt work anymore without change anything on the config/kexts.
 
Joined
Jul 8, 2017
Messages
32
Motherboard
Maximus XI Hero (WIFI) CE
CPU
i9-9900K
Graphics
RX 560
Mac
iMac
Mobile Phone
Android, iOS
Can anyone confirm if the latest update fixes the no HDMI on the Maximus XI Hero Call of Duty Edition?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
6,619
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Can anyone confirm if the latest update fixes the no HDMI on the Maximus XI Hero Call of Duty Edition?
Not sure what you mean:
  • Latest update? You mean macOS 10.14.4?
  • No HDMI? Are you trying to activate the on-board HDMI port on your Maximum XI Hero?
  • Because you have RX 560, it may be best to configure your OS in headless mode where iGPU is active, but used for compute operations only such as H.264, HEVC, Quick Look, Preview, etc., but will not drive a display monitor.
 
Joined
Sep 18, 2013
Messages
47
Motherboard
Z390 M gaming
CPU
i7 8700k
Graphics
RX 580 8GB
Hi.
Wonderful guide @CaseySJ. Thanks!
My problem is my IGPU does not show properly in Hackintool. It's not recognised I believe
the build I'm working on is Gigabyte Z390 M Gaming/i7 8700k/high Sierra - I have both DVI and HDMI monitors the plan is to have a discrete card and one monitor attached to each. I'm first trying to get the IGPU to work and then the DPGU
Below are my files.
Any help would be great. have been working on this for 2 days, read a number of threads. idk what's wrong
thanks a lot
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
6,619
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Hi.
Wonderful guide @CaseySJ. Thanks!
My problem is my IGPU does not show properly in Hackintool. It's not recognised I believe
the build I'm working on is Gigabyte Z390 M Gaming/i7 8700k/high Sierra - I have both DVI and HDMI monitors the plan is to have a discrete card and one monitor attached to each. I'm first trying to get the IGPU to work and then the DPGU
Below are my files.
Any help would be great. have been working on this for 2 days, read a number of threads. idk what's wrong
thanks a lot
Hello @joanareis,

Please try the attached CLOVER folder that fixes the following issues:
  • Gigabyte Z390 motherboards work best with OsxAptioFix2Drv-free2000.efi in combination with slide=0 instead of AptioMemoryFix.efi and OsxAptioFix3Drv.efi. (Note: You had both of the latter memory fix drivers in your drivers64UEFI folder. Only 1 is allowed at a time.)
  • Blanked out IntelGFX and ig-platform-id from Clover Configurator --> Devices and -->Graphics. The iGPU is configured via WhateverGreen instead (Devices --> Properties).
  • Added a few more ACPI fixes.
  • Enabled "trust" checkbox in SMBIOS.
  • Modified Boot arguments.
These fixes should help with shutdown/restart as well.

Please check your BIOS settings as well:
  • IGFX --> Enabled
I noticed that you don't have a USB port limit patch in Kernel and Kext Patches. If you're running Mojave 10.14.4, you may add the 3 patches described here:
But the best long term solution is to create a custom USB SSDT by following the new user-friendly guide here:
 

Attachments

Joined
Sep 18, 2013
Messages
47
Motherboard
Z390 M gaming
CPU
i7 8700k
Graphics
RX 580 8GB
Joined
Sep 18, 2013
Messages
47
Motherboard
Z390 M gaming
CPU
i7 8700k
Graphics
RX 580 8GB
Quick reply, I replaced the clover folder with the one you sent. didn't work, still 7MB vram and glitches
One of the last lines I see when booting is
"Graphics driver failed to load: could not register with framerbuffer driver"



btw BIOS settings IGFX is enabled
thank you
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
6,619
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Quick reply, I replaced the clover folder with the one you sent. didn't work, still 7MB vram and glitches
One of the last lines I see when booting is
"Graphics driver failed to load: could not register with framerbuffer driver"
Ouch, that doesn't sound good. Are you running Mojave 10.14.4?
 
Top