Contribute
Register

Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean ML/Lion Install

Joined
Aug 18, 2011
Messages
23
Motherboard
Gigabyte GA-Z68X-UD3H-B3 (rev. 1.3) (BIOS ver. F12)
CPU
Intel Core i7-2700K OC @ 4.2GHz LGA 1155 Sandy Bridge
Graphics
XFX AMD Radeon HD 6870, 2 GB DDR5 PCI-E (full QE/CI)
Mac
iMac
Classic Mac
Mobile Phone
iOS
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

drgnmsr said:
Hello, I am trying to get the Optical SPDIF Out to work on this board/video card combo with OS X 10.7.4. Everything else is working flawlessly, including Built-In Internal Speakers, but I would like to connect this board to my 1000w Sony BRAVIA DAV-DZ170 Home Theater System . I read through this forum, and many others so far, and could not find any answers that worked for me. I downloaded the latest DSDT.aml from the DSDT Database for F12, but I can not seem to find an appropriate kext for the audio, and I have probably tried about a dozen from difference forums. Please advise and ask me any specifications that you need. Thanks. :)
Okay, I finally got sound out of the Optical SPDIF Out to work, but it is only stereo through Audio MIDI Setup, the Encoded Digital Audio feature does not work," and also "The selected devise has no output controls" in System Preferences. :( Also, I have read from other forums that they were able to get 5.1 Surround, but am still only getting Stereo. Please advise, and ask me any specifications that you need. Thanks.
 
Joined
Aug 25, 2011
Messages
3,714
Motherboard
GA-Z68X-UD3H-B3
CPU
i5-2500K
Graphics
Sapphire r9 390
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

dsmturbo said:
Okay I have it up and running, but not getting any audio. I chose Realtec from Multibeast and also apple roolback option?
Did I miss something?
 

Attachments

Joined
Mar 11, 2011
Messages
48
Motherboard
Asus P5Q Pro
CPU
E8450
Graphics
GT 610
Mac
MacBook Pro
Mobile Phone
Android
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

jester969 said:
dsmturbo said:
Okay I have it up and running, but not getting any audio. I chose Realtec from Multibeast and also apple roolback option?
Did I miss something?
That is what I checked in Multibeast Jester, although I do not have a OSX System portion listed. I had forgotten to check the Apple Rollback the 1st time so I just re-ran Multibeast and rebooted.
I also checked networking which works, and User DSDT using bios F12 .aml
If that okay to do or do I have to start over? Can I run Multibeast more than once I mean?

And I am just going to Donate again to this awesome place with all the wonderful people.
 
Joined
Aug 25, 2011
Messages
3,714
Motherboard
GA-Z68X-UD3H-B3
CPU
i5-2500K
Graphics
Sapphire r9 390
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

Yes
 
Joined
Mar 11, 2011
Messages
48
Motherboard
Asus P5Q Pro
CPU
E8450
Graphics
GT 610
Mac
MacBook Pro
Mobile Phone
Android
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

jester969 said:
And you get Sound? I have nothing in my System Preferences/Sound
And I don't have a OSX86 Software box to check as per image
 

Attachments

Joined
Mar 11, 2011
Messages
48
Motherboard
Asus P5Q Pro
CPU
E8450
Graphics
GT 610
Mac
MacBook Pro
Mobile Phone
Android
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

dsmturbo said:
jester969 said:
And you get Sound? I have nothing in my System Preferences/Sound
And I don't have a OSX86 Software box to check as per image
Okay I re-ran Multibeast and I must have checked something I should not have as now get a Panic Kernel error. I assume I have to boot from Unibeast USB and re-install?

I think perhaps I checked Mac Pro5,1 setting which it does not like.

Also, before I had no sound, as well as no SATA3
 

inc

Joined
Oct 26, 2010
Messages
152
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760 && AMD 6870 (Sapphire 0x6738)
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
512K, Plus, Power Mac, PowerBook, Quadra, Workgroup Server, Xserve
Mobile Phone
iOS
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

After I did the 10.7.4 update and re-ran my CustomBeast installer, I made the same edits to my ATI6000 kext that I did previously but it wouldn't identify correctly on boot. I was losing my mind and then decided to ditch Chimera and run with Chameleon Wizard's latest build of Chameleon and everything was fine.

I don't know if the newer builds of Chimera would have worked correctly or not, but I don't have a preference for chimera versus chameleon beyond "does my stuff work", so if you're having problems with your framebuffer personality, try a different boot loader if you're up for it.
 
Joined
Mar 11, 2011
Messages
48
Motherboard
Asus P5Q Pro
CPU
E8450
Graphics
GT 610
Mac
MacBook Pro
Mobile Phone
Android
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

inc said:
After I did the 10.7.4 update and re-ran my CustomBeast installer, I made the same edits to my ATI6000 kext that I did previously but it wouldn't identify correctly on boot. I was losing my mind and then decided to ditch Chimera and run with Chameleon Wizard's latest build of Chameleon and everything was fine.

I don't know if the newer builds of Chimera would have worked correctly or not, but I don't have a preference for chimera versus chameleon beyond "does my stuff work", so if you're having problems with your framebuffer personality, try a different boot loader if you're up for it.
I am not too sure what that means, sorry a real noob here. really the only problems I seem to be having are no sound and not too sure if my SATA 3 works. I somewhere got a file called as below that I haven't used and not too sure what it is or if I need it:

2613-DSDT-GA-Z68X-UD3H-FLYM4N.aml

EDIT: Sorry, I also have a folder called Kexts for sound 10.7.2 HD audio 3000 and I never used it

EDITed:
Okay, I followed the exact image in post 1, and rre-ran Multibeast re-checking all I had done before plus a couple I missed...oopps.
I now have sound, wahoo
I'll try SATA 3 later on

All you people on here 'Rock'
 

inc

Joined
Oct 26, 2010
Messages
152
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760 && AMD 6870 (Sapphire 0x6738)
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
512K, Plus, Power Mac, PowerBook, Quadra, Workgroup Server, Xserve
Mobile Phone
iOS
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

dsmturbo said:
I am not too sure what that means, sorry a real noob here.
I was posting a message to this build thread for general information, not in response to your post(s). Your problems are solved by following the instructions on the first post of this thread.
 
Joined
Jun 13, 2012
Messages
1
Mac
Classic Mac
Mobile Phone
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

I am going to do my first hackintosh with the z68 motherboard and core i5-2500k. I want to install os lion but am confused as to if i need a mac or hackintosh already to do this install? Thank you for your help
 
Top