Contribute
Register

GUIDE: GA-Z68MA-D2H-B3 UEFI BIOS - ALL WORKING, DSDT not required!

Joined
Mar 26, 2011
Messages
5
Motherboard
GA-Z68MA-D2H-B3
CPU
Intel Core i5 2500
Graphics
NVIDIA GeForce GTX 660
Mobile Phone
Android, iOS
No idea what you have. Please create a proper profile.
I updated my profile info. I have been trying to update the BIOS to the latest UEFI BIOS but without success. Under Windows 10, @BIOS is giving dll errors. Under Q-Flash, it gives the "BIOS ID check error". I changed the file name to match exactly the mobo name because it was missing some characters. Still no luck. I've seen many other owners of this mobo reporting errors, but some have done it somehow. The question is, how?...
 
Joined
Feb 25, 2013
Messages
28
Motherboard
Gigabyte GAZ68XUD4B3
CPU
I7-2600K OC's @4800 MHz
Graphics
GTX 980 TI
Mac
iMac, Mac mini
Mobile Phone
iOS
I did it recently...just can't remember how. I don't have the exact same board but similar. I put it on a pen drive and used q flash...I remember it wasn't intuitive...but I eventually figured it out...Sorry I can't help more
 
Joined
Apr 30, 2010
Messages
640
Motherboard
GA-Z270XP-SLI
CPU
i5-7600K
Mac
iMac
Classic Mac
Classic
Mobile Phone
Android
I did it recently...just can't remember how. I don't have the exact same board but similar. I put it on a pen drive and used q flash...I remember it wasn't intuitive...but I eventually figured it out...Sorry I can't help more
Likewise, it's been a long time since I used the ZA68. What I recall doing was to create a bootable usb with MS-DOS and extracted the Flashefi.exe and bios image (Z8MAD2H3.U1C) to the usb and updated the bios using flashefi.exe (which is what Gigabyte tells you must be used). I don't think @BIOS or Q-Flash work for the uefi bios upgrade. Good luck.
 
Joined
Mar 26, 2011
Messages
5
Motherboard
GA-Z68MA-D2H-B3
CPU
Intel Core i5 2500
Graphics
NVIDIA GeForce GTX 660
Mobile Phone
Android, iOS
UPDATE: I managed to update the BIOS to the UEFI version and also to install High Sierra. I had to use a MS-DOS formatted USB stick and run the flashefi.exe from the stick. Thank you @ghorwith.
 
Joined
Aug 17, 2011
Messages
300
Motherboard
GA-Z170MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
I have been running Sierra very nicely for about a year. Yesterday I decided to upgrade to High Sierra. My Sierra installation would not update so I had to do a clean install of high Sierra with UniBeast. That seemed to work but now I am only able to boot the new installation with the EFI folder from the installer. I thought maybe if I could get somebody who has High Sierra running with this motherboard to let me have a copy of their working EFI folder I might be able to get this thing working properly. Please and thank you.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
21,091
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I have been running Sierra very nicely for about a year. Yesterday I decided to upgrade to High Sierra. My Sierra installation would not update so I had to do a clean install of high Sierra with UniBeast. That seemed to work but now I am only able to boot the new installation with the EFI folder from the installer. I thought maybe if I could get somebody who has High Sierra running with this motherboard to let me have a copy of their working EFI folder I might be able to get this thing working properly. Please and thank you.
You already have a working EFI folder on your USB installer.

Boot from your USB and when you get to the desktop download and run EFI Mounter and mount the EFI partition of your USB.
Copy the entire /EFI folder from the EFI partition of your USB to the desktop.
Eject the USB.
Run EFI Mounter again and mount the EFI partition of your HDD.
Delete the entire /EFI folder from the EFI partition of your HDD.
Copy the /EFI folder from your desktop to the EFI partition of your HDD.
Restart

You should now be able to boot from your HDD in the same way that you could previously boot from your USB.
 
Joined
Aug 17, 2011
Messages
300
Motherboard
GA-Z170MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
Yes thank you, I've already done all that. The EFI from the installer lets me boot but it has limited video and audio and doesn't seem to let me change any of that with multi beast.
 
Joined
Aug 17, 2011
Messages
300
Motherboard
GA-Z170MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
Well things are getting better. I got the audio working. Now if I could just find a way to have more than one Monitor resolution. 1024x768 is pretty weak, but that's all I can get right now. I read the config.plist and it seems to have my video card listed, but beyond that I really don't know what I'm reading.
 
Joined
Aug 17, 2011
Messages
300
Motherboard
GA-Z170MX-Gaming 5
CPU
i5 7400
Graphics
HD630
Classic Mac
Classic, LC, Power Mac
Mobile Phone
iOS
The older Sierra install recognizes the display as a specific make and model, eg., Acer X223W, with options for Resolution and Rotation, and a few other things. whereas the new install of High Sierra only sees a generic display with a single resolution. I am trying to figure out how I can get it to see the display and all the options.

First Picture is what I want. Second picture is what I have now.

Acer.png


pref_displays.png
 
Last edited:
Joined
Oct 8, 2011
Messages
167
Motherboard
HP 2570p-Clover
CPU
i5-3210M
Graphics
HD4000, 1366x768
is someone still using this mobo with ML and hd3000 only and could get hdmi out to work?
because I tried with the solution from page #9 from @savestheday but it doesn't work for me, with that dsdt.aml I get immediately KP on boot.. is someone willing to help me? Tia ;(
 
Top