Contribute
Register

GUIDE: GA-Z68MA-D2H-B3 UEFI BIOS - ALL WORKING, DSDT not required!

Joined
Jul 27, 2011
Messages
221
Motherboard
Asus P8Z77-I Deluxe
CPU
Intel Core i7 3770K
Graphics
NVIDIA GeForce GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
OK. I have my optical drive working, for some reason it only works when attached to one of the white SATA ports, connected to a blue port and it doesn't work. The eject button is also working fine.
 
Joined
Jul 27, 2011
Messages
221
Motherboard
Asus P8Z77-I Deluxe
CPU
Intel Core i7 3770K
Graphics
NVIDIA GeForce GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Artifacts...? 512 Mb solve..?

Artifacts..? = No artifacts whatsoever. As stated in first post.

512MB solve..? = Elaborate on your question.
 
Joined
Jul 27, 2011
Messages
221
Motherboard
Asus P8Z77-I Deluxe
CPU
Intel Core i7 3770K
Graphics
NVIDIA GeForce GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
BIOS not EFI memory video 480+2 Mb seem cause artifacts...

EFI 512 Mb video not artifacts...

I see. Possibly, although since I started using Mountain Lion Developer Preview a few months back I've not seen any artefacts at all, whereas on Lion I would get them every now and again.
 
Joined
Aug 11, 2011
Messages
3
Motherboard
Hackintosh
CPU
Intel i5-2500K
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
So it looks like USB3 doesn't work properly as dojrude mentioned, the USB Super-Speed Bus appears in System Info and my USB3 flash disk (my only USB3 device) appears beneath, but it does not mount nor can I access it from Disk Utility.

Also, DVD-ROMs and hot-swapping SATA hard disks do not work (as sonicseamus enquired). This is an interesting one because before I upgraded to the RTM build of ML hot-swapping was working at some point in the DP builds. Possibly related to the UEFI upgrade...

These issues do not affect me personally as I don't require the affected functionality, however some people will. I can see the issues are not uncommon so hopefully a fix will be found very soon.

SATA hot swap does work, the default UEFI setting disables hot swap. Just go back to the bios and enable hot plug for each of your SATA ports.
 
Joined
Dec 4, 2011
Messages
1
Motherboard
Gigabyte Z68MA-D2H-B3 UEFI
CPU
i5 2500k
Graphics
HD 3000
Mac
Classic Mac
Mobile Phone
Worked like a charm

Everything is working, Airplay, Audio, DVDW, Graphics.

Thanks!
 
Joined
Jun 21, 2011
Messages
11
Motherboard
Mountain Lion 10.8.1
CPU
Intel i5 2500K
Graphics
9800GTX
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Hi,

Simple question, how did you update your firmware to UEFI bios?

I already tried:
- From the Qflash (Key END) with the BIOS in a USB key, error checksum
- From Win XP 32Bits / Win 7 32 bits, the application doesn't seems to launch
- From Win XP Live CD same issue
- From Win 7 64Bits the application is crashing

I successfully upgrated from F9 to F10 version with the Qflash.

Actually I have some issue:
- When the computer sleeps, it resets my BIOS settings
- I can't use the Eject button on my keyboard

Do you recommend me to update my bios and use your guide?

Otherwise, everything is perfect !
 
Joined
Jul 23, 2012
Messages
808
Motherboard
GA-Z77N-WIFI-F3-Clover
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
  1. Mac mini
Hi,

Simple question, how did you update your firmware to UEFI bios?

I already tried:
- From the Qflash (Key END) with the BIOS in a USB key, error checksum
- From Win XP 32Bits / Win 7 32 bits, the application doesn't seems to launch
- From Win XP Live CD same issue
- From Win 7 64Bits the application is crashing

I successfully upgrated from F9 to F10 version with the Qflash.

Actually I have some issue:
- When the computer sleeps, it resets my BIOS settings
- I can't use the Eject button on my keyboard

Do you recommend me to update my bios and use your guide?

Otherwise, everything is perfect !


you cannot use the qflash to update the uefi firmware, the uefi downloaded from gigabyte come with the flash tools, create a bootable DOS USB drive, and run the flash program.
 
Joined
Nov 24, 2010
Messages
75
Motherboard
Custom
CPU
i920
Graphics
ATI 5750
Mobile Phone
  1. Android
  2. Other
BIOS Update

Just a word of warning.. Once you go UEFI you can't go back to F10/F09/etc.... Or at least I haven't found a way. So, if your system is working okay you might want to hold off on the update as some people are reporting problems.

I was able to get everything working except HD3000 on 10.6.8. Which I hoped to stay on... However, after spending a few days with no luck I bit the bullet and bought 10.8. It's downloading now so hopefully I'll have it resolved by tomorrow.
 
Top