[Guide] GA-X58A-UD3R (2.0) BIOS FH - i7 930 - Apple OEM HD5770

Not open for further replies.
May 11, 2015
Gigabyte GA-X58A-UD3R (rev. 2.0)-FF
Xeon W3680 - MacPro 5,1
Asus GeForce 210
  1. Mac Pro
Mobile Phone
  1. Android

Hello again.

Happy to say I've been able to get the system now to reboot and have saved a CCclone backup. Thank you.

Here are the outstanding issues.

1. NETWORK - Ethernet is working
2. GRAPHICS - Display works (but low res only - card can display 1680x1050)
3. USB - USB Keyboard and Mouse are functional > No USB 3 drivers were loaded.

Not Working yet
1. OSX - Yosemite is sluggish
I assume this will improve once the drivers are all good

2. AUDIO - No audio > Loaded Audio driver ALC889
Should I try other drivers? Any suggestions?

3. GRAPHICS - display shows low res only - card can display 1680x1050 > GraphicsEnabler=YES was NOT selected.
I tried updating the chameleon.Boot.plist in the /Extras folder adding
<key>Graphics Mode</key>
but this caused the system to not reboot. Have I missed a step?

4. PS/2 - Ports not working > No PS/2 drivers were loaded.
Have yet to try

5. PCI - I have a MOTU PCIe 424 card yet to install to support music production.
Have yet to try

Any advice on next steps, driver selections and possible tweaking would be greatly appreciated.

Thanks in advance! :)
Feb 17, 2014
GA-H170-Gaming 3
i7 7700K
GTX 780
  1. iMac
Mobile Phone
  1. iOS
Hi i just installed Yosemite on my system with Unibeast and Multibeast.

I have some problems with USB some time works and sometimes didnt works. I have another problem with Ethernet not showing on system report after i installed Multibeast with DSDT User option.

In system report under Ethernet Cards it show this message: this computer does not appear to have any PCI ethernet card installed.(This does not appear at fist login, i saw the correct info and in network preference to before install Multibeast.)

Quick Start > UserDSDT (DSDT aml file downloaded from Tony's Database)
Drivers > Audio > Realtek ALCxxx > ALC889
Drivers > Disk > 3rd Party SATA
Drivers > Misc > FakeSMC v6.14.1364
Drivers > Misc > FakeSMC v6.14.1364 Plugins
Drivers > Misc > FakeSMC v6.14.1364 HWMonitor Application
Drivers > Misc > USB 3.0 - Universval
Drivers > Network > Realtek > RealtekRTL81xx v0.0.90(Tried too with RealtekRTL8111 v1.2.3)
Drivers > System > AppleACPIPlatform Rollback > 10.9.5 AppleACPIPlatform Rollback
Drivers > System >AppleIntelCPUPowerManagement>os x 10.9.0
Drivers > System >AppleRTC Patch for CMOS Reset
Bootloaders > Chimera v4.0.1
Customize > 1080p Display Mode
Customize > Boot Options > Basic Boot Options
Customize > Boot Options > Generate CPU States
Customize > Boot Options > Hibernate Mode - Dekstop
Customize > Boot Options > Kext Dev Mode
Customize > Boot Options > Use KernelCache
Customize > System Definitions > Mac Pro > Mac Pro 5,1
Customize > Themes > tonymacx86 Black


Gigabyte GA-X58A-UD3R rev 2.0 Bios version FH
-Network RTL8111E
-Audio Realtek ALC889 codec
Core i7 960
Sapphire HD 7950 3GB OC
4 x Patriot Signature Line 4 GB DDR3 @ 1066Mhz.
1 x SSD Samsung EVO 850 250GB

Thanks in advance i hope you can help me.
Aug 11, 2010
Gigabyte Z87X-UD5H F10c
Radeon Rx580 8GB
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
adriancan for the network did you try AppleRTL8169Ethernet.kext it works for me and it appears in the system report.

Btw Yosemite works but I found it a bit sluggish, it sometimes need to think before resizing a finder window or to switch from one task to another or just a bit of lag when starting to type. If any of you could point me in the proper direction I wold appreciate.
At the moment I am running the Nvidia web driver 346.02.02f03 with a gtx680 it seems to have a bug and it does default to the osx driver even if you restart it selecting the web driver.

Thanks for the amazing tips a guides you guys keep posting :)

My Boot.plist:
<plist version="1.0">
<key>Kernel Flags</key>
<string>kext-dev-mode=1 nvda_drv=1 -v</string>
<key>Legacy Logo</key>
<key>Default Partition</key>
Not open for further replies.