Contribute
Register

[GUIDE] FOR INSTALLING 10.7.4 i3,i5,i7 USERS

Status
Not open for further replies.
Joined
Jul 23, 2012
Messages
1
Motherboard
Mac OS X Snow Leopard & Windows 8
CPU
Intel Core I7 2620M
Graphics
Nvidia GeForce GT520m + HD3000
Mac
Classic Mac
Mobile Phone
Thanks Man!!
 
Joined
Jun 23, 2012
Messages
6
Motherboard
Mac OS X LION 10.7.3
CPU
Intel i5 2450M
Graphics
Radeon HD 4600
Mac
Classic Mac
Mobile Phone
OK I will try this when I get home.

My Mac OS Lion is not genuine ,because Mac App Store do not accept credit cards from Serbia, I can not buy original :(

Did i right understand you, when I reboot, I pick again USB to start over again, and not to pick partitton with Lion 10.7.4 ?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
OK I will try this when I get home.

My Mac OS Lion is not genuine ,because Mac App Store do not accept credit cards from Serbia, I can not buy original :(

Did i right understand you, when I reboot, I pick again USB to start over again, and not to pick partitton with Lion 10.7.4 ?

You need to boot from the USB stick with HP BIOS screen (F9), then select your freshly installed partition on the HDD. But if you don't have genuine Lion, then all bets are off (because who knows what you have), and it is specifically against the rules of this forum.
 
Joined
Mar 29, 2012
Messages
15
Mac
Classic Mac
Mobile Phone
Hey guys, I'm going to attempt this update soon and I had a few questions.

I'm currently on a perfectly stable 10.7.3 install, thanks to blueking, donkey and others. Thanks for all the help back then.

I wish to update to 10.7.4 and I'm wondering if when it comes to tegezee's step "use latest multibeast use the patched SSDT " should I use the latest HP ProBook Installer instead, I think it is v5 Beta8 Final? Will this Installer work for 10.7.4 as well? I ask because of this user I see before me experiencing problems with stepping/processor speed.

Also, I'm using a special DSDT for the 1080p screen, I'm assuming I'll continue to use the DSDT on 10.7.4 as well?

So basically, I'll install the combo update, install patched ktext, use HP Installer v5 beta8 ( instead of MultiBeast ) to update the SSDT and then reboot and hope for the best!

Big thanks to you guys who help out regularly here, its much appreciated.
 
Joined
Jun 23, 2012
Messages
6
Motherboard
Mac OS X LION 10.7.3
CPU
Intel i5 2450M
Graphics
Radeon HD 4600
Mac
Classic Mac
Mobile Phone
I installed and working 10.7.4 and 10.8 but in CPU info it says that I have 800 MHZ Intel i5 , does anyone have a solution for this problem ?
 
Joined
Aug 3, 2012
Messages
1
Motherboard
HP ProBook 4530s
CPU
i5-2430M
Graphics
Intel HD Graphics 3000
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Hi Guys,

I'm new to the forum, can you advise where I can download the ProBook Installer v4 from. I have looked on the legacy forums, but it states "You do not have the required permissions to view the files attached to this post. Can you advise please :confused:

Thanks
 
Joined
Nov 19, 2011
Messages
21
Motherboard
H67N-USB3-B3 (F9 BIOS)
CPU
Intel Core i3 2105
Graphics
HD 3000
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
I installed 10.7.4 from scratch on Probook 4530s (BIOS F23) with i3 2350M, 4GB RAM and 500GB HDD:

- Used 'Install OS X Lion.app' (newly DL'd from App store) and Unibeast Lion 1.5.3 create boot key (afterwards, also added Probook installer V5.1b1 [link] to Applications folder on same key.)
- Boot key on Probook, Press ESC and select it in boot menu
- Use Utilities>DiskUtility to format GUID with two partitions (one small 8GB named 'RecoveryHD' partition for recovery, but not needed, the other 'HackHD' with remaining space)
- Installed Lion to HackHD partition
- Reboot, select HackHD partition (it boots fine)
- Have to plug in a USB keyboard to make install wizard prompt go away (apparently fixed in newer Unibeast)
- After boot, grab Probook Installer
- Select following options
---OS X Version > 10.7.4
---Chimera 1.11.0
---Graphics Fix (noticed some lines in menus after a while, fixed with this)
---Ethernet Kext Installer
---CPU SSDTs i3, i5, & i7 > i3 processors > i3 2350m
---DSDTs for Standard Screens > 4230s-4530s HD 3000 > BIO revision F20
---System Definitions > Macbook Pro (8,2,), 15in [Not mandatory but looks better than original IMO]
---Brightness fix (100%) -- choose whatever % version you want obviously
---[Not mandatory] Colour profiles (not needed, but I prefer them to the stock) > HP Probook 4530s Original
---[Not mandatory] Extra Tools > Chameleon Wizare, HW Monitor, Kext Utility
NB: No Wifi at the moment because I have the Realtek card. I didn't read enough before buying and assumed Lnx2Mac's kext supported all Realtek cards. I ordered an Atheros from eBay.

So far most things seem to be working well, with one issue that I'm hoping someone can offer some advice on (currently being tracked here):

- Track pad tap to click seems to be a little buggy (need double taps for some dock/menu items to get single click behavior, better w DSDT below)
- Battery indicator issues. Displayed proper % on battery power, but displays "Not Charging" and "Plug/Full Battery" logo when on AC power. UPDATE: Fixed here w thx to RehabMan.

All in all, fairly minor issues.

BIG thanks to all who helped get the Probooks roaring! It is a great hack laptop project.

Further Customizations:

- Restored the installer USB key to the 'RecoveryHD' partition and then hid that partition in fstab (it still shows up at boot in Chimera). If I screw anything up while tweaking and have to start over, I can just boot into RecoveryHD and reinstall fresh.

- Altered the default colour profile so it would load immediately and in guest account (not load only after login)
 
Joined
Apr 4, 2012
Messages
6
Motherboard
Probook 4430s
CPU
i5 2430M @ 2.4
Graphics
Intel HD
Mac
Classic Mac
Mobile Phone
So I want to update to 10.7.4 and I've read this (and other) threads, but here's one thing I don't understanding. When I go to find the patched kexts by BigDonkey I get the following message. Where are they? Sorry if I've missed something obvious.

"All native 10.7.4 patched kexts for 4530S

You do not have the required permissions to view the files attached to this post."

UPDATE----

For those of you who have having the same issue... it's like the 7th post down as the link goes to the old forum not the post in this new/active forum...
 
Status
Not open for further replies.
Top