Contribute
Register

[Guide] Fanless mini Mojave: i5-8600 | Gigabyte Z370N WiFi | Intel HD630

Joined
Jun 4, 2016
Messages
62
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
MacBook, MacBook Pro
Mobile Phone
Android
#41
Magic Mouse won't stay connected via BT.
Might be your BT device. First I had a dongle that was okay but poor with BT audio. Switched to an ex-mac air card, which is better. Your mouse should be okay with any BT.

Yes, I just updated to 10.14.2. All good.
 
Last edited:
Joined
Jul 30, 2018
Messages
80
Motherboard
GA-Z370N wifi
CPU
i7-8700
Graphics
HD 630
Mac
MacBook Pro
Mobile Phone
iOS
#42
Including the GPUpatch.plist file. To put this the simplest method
Open the GPUpatch.plist file in clover configurator
under Section Click on Devices
Click on the Properties Tab
Under Devices Click on PciRoot(0x0)/Pci(0x2,0x0), click Right mouse button and copy
Under Tools click MountEFI
select your boot drive EFI partition and MountPartition, Provide password then click Open Partition
under clover open with Clover configurator config.plist file
Like above click Devices -> Properties -> Devices-> Paste
(If you have already applied the previous patch delete it First)
OR
As it is a plist file copy the content and paste it in appropriate location in your config.plist file
 

Attachments

Joined
Jun 4, 2016
Messages
62
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
MacBook, MacBook Pro
Mobile Phone
Android
#43
Including the GPUpatch.plist file. To put this the simplest method
So I've looked into the IORegistry and that's where the display ports (and all IO devices) are defined. Mine currently now has 2 devices (DP and one HDMI I imagine). Prior to your recent fix, I guess was only one device, a single HDMI. So your patches now define all 3 display devices, it seems. Plus did you say 2048MB memory? Any other things added in those patches?

Did you use FBPatcher and the "connectors" tab to test for each device? There's not clear documentation on how to use it for that. I mean there are 56 pages of comments, probably it's all in there somewhere. I think the documentation for the USB ports is better.

I'll have a look at applying the patches.
 
Joined
Jul 30, 2018
Messages
80
Motherboard
GA-Z370N wifi
CPU
i7-8700
Graphics
HD 630
Mac
MacBook Pro
Mobile Phone
iOS
#44
So I've looked into the IORegistry and that's where the display ports (and all IO devices) are defined. Mine currently now has 2 devices (DP and one HDMI I imagine). Prior to your recent fix, I guess was only one device, a single HDMI. So your patches now define all 3 display devices, it seems. Plus did you say 2048MB memory? Any other things added in those patches?

Did you use FBPatcher and the "connectors" tab to test for each device? There's not clear documentation on how to use it for that. I mean there are 56 pages of comments, probably it's all in there somewhere. I think the documentation for the USB ports is better.

I'll have a look at applying the patches.
in our motherboard there are 2 HDMI ports one 1.4 (4k @ 30Hzs) one 2.0 (4k @ 60 Hzs) and one DP so this patch defines all 3 ports I have tested all individually and it works. Also have enabled HDMI2 in the patch. Yes the connector tab will show you 3 connections all defined as DP as default, so you have to define the HDMI ports, which this patch does. Also as mentioned 2048MB memory. I think the above is true for intel 8th generation CPUs View attachment 371695
 

Attachments

Last edited:
Joined
Jul 30, 2018
Messages
80
Motherboard
GA-Z370N wifi
CPU
i7-8700
Graphics
HD 630
Mac
MacBook Pro
Mobile Phone
iOS
#45
Proper USB Power
Put both the files in Clover->ACPI->patched
Based on Rehabman's guide for USB Power

Now I can charge my iPad after this.
 

Attachments

Joined
Jun 4, 2016
Messages
62
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
MacBook, MacBook Pro
Mobile Phone
Android
#46
Put both the files in Clover->ACPI->patched
Okay, thanks. Although same 500mA coming from the front USB on my Samsung phone. Anyway I don't mind, it was the chap in the other thread who wanted to charge his iphone faster.
 
Joined
Jul 30, 2018
Messages
80
Motherboard
GA-Z370N wifi
CPU
i7-8700
Graphics
HD 630
Mac
MacBook Pro
Mobile Phone
iOS
#48
Joined
Dec 9, 2015
Messages
7
Motherboard
Gigabyte Z370N ITX
CPU
i7-8700
Graphics
UHD 630
Mac
MacBook Pro
#49
Might be your BT device. First I had a dongle that was okay but poor with BT audio. Switched to an ex-mac air card, which is better. Your mouse should be okay with any BT.

Yes, I just updated to 10.14.2. All good.
FYI I was able to get my Magic Mouse to work. It was a mistake on my part. I didn't have the antennas attached to my bt card. I wasn't using wifi and didn't realize the antennas are used for both wifi and bt.
 
Top